summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-10-03 00:20:26 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-03 22:21:00 +0200
commit6e813f13ba23ea1b7adc4b635b4d9508d0a9954c (patch)
treeef4b117bf0f526d48f43f0b15e7b12a1b1443fc9 /sci-biology/phred
parentnet-misc/remmina: warn about encrypted VNC deps. (diff)
downloadgentoo-6e813f13ba23ea1b7adc4b635b4d9508d0a9954c.tar.gz
gentoo-6e813f13ba23ea1b7adc4b635b4d9508d0a9954c.tar.bz2
gentoo-6e813f13ba23ea1b7adc4b635b4d9508d0a9954c.zip
sci-biology/phred: Revbump to EAPI=6
Package-Manager: portage-2.3.1
Diffstat (limited to 'sci-biology/phred')
-rw-r--r--sci-biology/phred/Manifest2
-rw-r--r--sci-biology/phred/files/phred-071220-fix-build-system.patch82
-rw-r--r--sci-biology/phred/files/phred-071220-fix-qa.patch36
-rw-r--r--sci-biology/phred/phred-071220-r1.ebuild51
-rw-r--r--sci-biology/phred/phred-071220.ebuild40
5 files changed, 170 insertions, 41 deletions
diff --git a/sci-biology/phred/Manifest b/sci-biology/phred/Manifest
index 92cfe6ce81b8..c326374708c9 100644
--- a/sci-biology/phred/Manifest
+++ b/sci-biology/phred/Manifest
@@ -1 +1 @@
-DIST phred-dist-071220.b-acd.tar.gz 357767 SHA256 364b0b54c29717ba4c8acc48a128eaf25ba1d7f06acab7565975f6879764a975
+DIST phred-dist-071220.b-acd.tar.gz 357767 SHA256 364b0b54c29717ba4c8acc48a128eaf25ba1d7f06acab7565975f6879764a975 SHA512 0a6b0a733e6dcc0495eaab720b75f8e5815df494d0a773b8b8336d5208321c2ba475921084835a769367ec51aed156585ab97346a510100d4337e3215ec75276 WHIRLPOOL 9b14cfb1ca970a14ef613ca17efb82955c0ecec414dfad8835c883650f306b3a79846b7a410a9359cbd9ca953d890673366b6f865a2a357e81213d34b3327d3e
diff --git a/sci-biology/phred/files/phred-071220-fix-build-system.patch b/sci-biology/phred/files/phred-071220-fix-build-system.patch
new file mode 100644
index 000000000000..997f39941a07
--- /dev/null
+++ b/sci-biology/phred/files/phred-071220-fix-build-system.patch
@@ -0,0 +1,82 @@
+* Fix build system to honour CC, CFLAGS, CPPFLAGS and LDFLAGS
+* Specify a default target, in order to keep the ebuild slim
+
+--- a/Makefile
++++ b/Makefile
+@@ -12,9 +12,9 @@
+
+ # UNIX specific definitions (default)
+ #
+-CC= cc
+-CFLAGS= -O -DANSI_C $(LXFLAGS)
+-CLIB= -lm
++CC ?= cc
++CPPFLAGS += -DANSI_C $(LXFLAGS)
++LIBS += -lm
+
+ # Windows 'nmake' specific definitions
+ #
+@@ -133,9 +133,6 @@
+ $(objdir)writeSDF.o \
+ $(objdir)writeSeq.o
+
+-SRCS = $(OBJS:.o=.c)
+-WOBJ = $(OBJS:.o=.obj)
+-
+ INCS = \
+ $(incdir)chromatData.h \
+ $(incdir)freeChromatData.h \
+@@ -179,48 +176,18 @@
+ # UNIX make specific phred target
+ # note: a horizontal tab character must precede `$(CC)'
+ #
+-phred: $(OBJS)
+- $(CC) $(CFLAGS) -o phred $(OBJS) $(CLIB)
+
+
+-# Windows nmake specific phred target
+-#
+-forwindows: $(WOBJ)
+- $(CC) $(CFLAGS) /Fephred $(WOBJ)
+-# $(CC) $(CFLAGS) /Fedaev daev.c
++.PHONY: all
++all: phred daev
+
+
+-# test CC: refuse to compile if
+-#
+-# o SunOS
+-#
+-# AND
+-#
+-# o using /usr/ucb/cc compiler
+-#
+-# NOTE: this compiler causes problems: see PHRED.DOC
+-#
+-test_cc:
+- @if [ `uname` = SunOS ] ; \
+- then \
+- if [ `which $(CC)` = "/usr/ucb/cc" ] ; \
+- then \
+- echo ""; \
+- echo "============================================================"; \
+- echo "| |"; \
+- echo "| This SUN C compiler produces a bad phred executable. |"; \
+- echo "| |"; \
+- echo "| Please see the PHRED.DOC file for more information. |"; \
+- echo "| |"; \
+- echo "============================================================"; \
+- echo ""; \
+- exit 1; \
+- fi \
+- fi
++phred: $(OBJS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o phred $^ $(LIBS)
+
+
+ daev: daev.o
+- $(CC) $(CFLAGS) -o daev daev.o -lm
++ $(CC) $(LDFLAGS) $(CFLAGS) -o daev $^ $(LIBS)
+
+
+ clean:
diff --git a/sci-biology/phred/files/phred-071220-fix-qa.patch b/sci-biology/phred/files/phred-071220-fix-qa.patch
new file mode 100644
index 000000000000..ab4d2ea023f6
--- /dev/null
+++ b/sci-biology/phred/files/phred-071220-fix-qa.patch
@@ -0,0 +1,36 @@
+Fix implicit declarations:
+* daev.c: In function ‘processParameters’:
+* daev.c:849:14: warning: implicit declaration of function ‘isdigit’ [-Wimplicit-function-declaration]
+* if( !isdigit( argv[iarg][0] ) )
+
+--- a/autoPhred.c
++++ b/autoPhred.c
+@@ -57,6 +57,7 @@
+ static int xstrcmp();
+ #endif
+
++int freeMBRData( MBRData *mbrData );
+ #ifdef ANSI_C
+ int autoPhred( Option *option )
+ #else
+--- a/daev.c
++++ b/daev.c
+@@ -58,6 +58,7 @@
+ #include <sys/stat.h>
+ #include <time.h>
+ #include <math.h>
++#include <ctype.h>
+
+ #ifndef _WIN32
+ #include <dirent.h>
+--- a/mergedBaseRead.c
++++ b/mergedBaseRead.c
+@@ -63,7 +63,7 @@
+ Peak *peak;
+ Observed_peak *obs_peak;
+
+- static initFlag = 0;
++ static int initFlag = 0;
+ static char mchar[256][256];
+
+ if( initFlag == 0 )
diff --git a/sci-biology/phred/phred-071220-r1.ebuild b/sci-biology/phred/phred-071220-r1.ebuild
new file mode 100644
index 000000000000..acaf74e7d430
--- /dev/null
+++ b/sci-biology/phred/phred-071220-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A base caller for Sanger DNA sequencing"
+HOMEPAGE="http://phrap.org/phredphrapconsed.html"
+SRC_URI="phred-dist-071220.b-acd.tar.gz"
+
+LICENSE="phrap"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}"
+
+RESTRICT="fetch"
+PATCHES=(
+ "${FILESDIR}/${PN}-071220-fix-build-system.patch"
+ "${FILESDIR}/${PN}-071220-fix-qa.patch"
+)
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE} and obtain the file"
+ einfo "${SRC_URI}, then place it in ${DISTDIR}"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin phred daev
+
+ insinto /usr/share/${PN}
+ doins phredpar.dat
+
+ echo "PHRED_PARAMETER_FILE=${EPREFIX}/usr/share/${PN}/phredpar.dat" > 99phred || die
+ doenvd 99phred
+
+ newdoc DAEV.DOC DAEV.DOC.txt
+ newdoc PHRED.DOC PHRED.DOC.txt
+}
diff --git a/sci-biology/phred/phred-071220.ebuild b/sci-biology/phred/phred-071220.ebuild
deleted file mode 100644
index 22600ba92c50..000000000000
--- a/sci-biology/phred/phred-071220.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-DESCRIPTION="A base caller for Sanger DNA sequencing"
-HOMEPAGE="http://phrap.org/phredphrapconsed.html"
-SRC_URI="phred-dist-071220.b-acd.tar.gz"
-
-LICENSE="phrap"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}"
-
-RESTRICT="fetch"
-
-pkg_nofetch() {
- elog "Please visit ${HOMEPAGE} and obtain the file"
- elog "${SRC_URI}, then place it in ${DISTDIR}"
-}
-
-src_compile() {
- sed -i -e 's/CFLAGS=/CFLAGS += /' Makefile
- emake daev || die
- emake || die
-}
-
-src_install() {
- dobin phred daev || die
- insinto /usr/share/${PN}
- doins phredpar.dat || die
- echo "PHRED_PARAMETER_FILE=/usr/share/${PN}/phredpar.dat" > 99phred
- doenvd 99phred || die
- newdoc DAEV.DOC DAEV.DOC.txt
- newdoc PHRED.DOC PHRED.DOC.txt
-}