summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-07 08:15:03 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-07 08:15:03 +0100
commit4de276291f0a434375d93748a25e8ef5c85c9bb0 (patch)
tree73d0494580c5a64550ca168a53823ae361e0905f /sci-biology/phylip/phylip-3.696-r1.ebuild
parentdev-ruby/addressable: add 2.4.0 (diff)
downloadgentoo-4de276291f0a434375d93748a25e8ef5c85c9bb0.tar.gz
gentoo-4de276291f0a434375d93748a25e8ef5c85c9bb0.tar.bz2
gentoo-4de276291f0a434375d93748a25e8ef5c85c9bb0.zip
sci-biology/phylip: Fix install path for libs
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-biology/phylip/phylip-3.696-r1.ebuild')
-rw-r--r--sci-biology/phylip/phylip-3.696-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-biology/phylip/phylip-3.696-r1.ebuild b/sci-biology/phylip/phylip-3.696-r1.ebuild
new file mode 100644
index 000000000000..c9c7b70b99b3
--- /dev/null
+++ b/sci-biology/phylip/phylip-3.696-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION=" The PHYLogeny Inference Package"
+HOMEPAGE="http://evolution.genetics.washington.edu/phylip.html"
+SRC_URI="http://evolution.gs.washington.edu/${PN}/download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ mv Makefile.unx Makefile || die
+ sed \
+ -e "/ -o /s:\(\$(CC)\):\1 ${LDFLAGS}:g" \
+ -i Makefile || die "Patching Makefile failed."
+ mkdir ../fonts || die
+}
+
+src_compile() {
+ emake -j1 \
+ CC="$(tc-getCC)" \
+ DC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wno-unused-result" \
+ all put
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}" || die
+
+ mv exe/font* fonts || die "Font move failed."
+ mv exe/factor exe/factor-${PN} || die "Renaming factor failed."
+
+ dolib.so exe/*so && rm exe/*so || die
+ dobin exe/*
+
+ dodoc "${FILESDIR}"/README.Gentoo
+
+ dohtml -r phylip.html doc
+
+ insinto /usr/share/${PN}/
+ doins -r fonts
+}