summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/poa/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/poa/files')
-rw-r--r--sci-biology/poa/files/2-respect-flags.patch26
-rw-r--r--sci-biology/poa/files/respect-cflags.patch13
2 files changed, 39 insertions, 0 deletions
diff --git a/sci-biology/poa/files/2-respect-flags.patch b/sci-biology/poa/files/2-respect-flags.patch
new file mode 100644
index 000000000000..bdd638cf64b7
--- /dev/null
+++ b/sci-biology/poa/files/2-respect-flags.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile b/Makefile
+index a65bed0..713a7ab 100644
+--- a/Makefile
++++ b/Makefile
+@@ -26,9 +26,10 @@ LIBOBJECTS= \
+ stringptr.o
+
+
+-CC = gcc
++CC ?= gcc
+ #CFLAGS= -g -ansi-strict -W -Wall -DUSE_WEIGHTED_LINKS -DUSE_PROJECT_HEADER -I.
+-CFLAGS= -g -DUSE_WEIGHTED_LINKS -DUSE_PROJECT_HEADER -I.
++OPT_CFLAGS = -g
++CFLAGS= $(OPT_CFLAGS) -DUSE_WEIGHTED_LINKS -DUSE_PROJECT_HEADER -I.
+ # -I$(HOME)/lib/include
+ # -DREPORT_MAX_ALLOC
+
+@@ -44,7 +45,7 @@ liblpo.a: $(LIBOBJECTS)
+
+ # NB: LIBRARY MUST FOLLOW OBJECTS OR LINK FAILS WITH UNRESOLVED REFERENCES!!
+ poa: $(OBJECTS) liblpo.a
+- $(CC) -o $@ $(OBJECTS) -lm liblpo.a
++ $(CC) $(LDFLAGS) -o $@ $(OBJECTS) -lm liblpo.a
+
+ what:
+ @echo poa: partial-order based sequence alignment program
diff --git a/sci-biology/poa/files/respect-cflags.patch b/sci-biology/poa/files/respect-cflags.patch
new file mode 100644
index 000000000000..2ae08db4ff4d
--- /dev/null
+++ b/sci-biology/poa/files/respect-cflags.patch
@@ -0,0 +1,13 @@
+diff -urN poaV2.orig/Makefile poaV2/Makefile
+--- poaV2.orig/Makefile 2004-03-11 21:33:30.000000000 -0800
++++ poaV2/Makefile 2006-03-09 20:09:27.000000000 -0800
+@@ -28,7 +28,8 @@
+
+ CC = gcc
+ #CFLAGS= -g -ansi-strict -W -Wall -DUSE_WEIGHTED_LINKS -DUSE_PROJECT_HEADER -I.
+-CFLAGS= -g -DUSE_WEIGHTED_LINKS -DUSE_PROJECT_HEADER -I.
++OPT_CFLAGS = -g
++CFLAGS= $(OPT_CFLAGS) -DUSE_WEIGHTED_LINKS -DUSE_PROJECT_HEADER -I.
+ # -I$(HOME)/lib/include
+ # -DREPORT_MAX_ALLOC
+