summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-23 12:51:59 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-23 12:51:59 +0100
commitb24fab79ca7863993080b5fafd4ce414ff132c73 (patch)
tree5d33ed177382a54c8eb7d2b71e4daffd924efb04 /sci-biology/qrna/qrna-2.0.3c-r3.ebuild
parentmedia-gfx/krita: Drop 4.2.7.1-r1 (diff)
downloadgentoo-b24fab79ca7863993080b5fafd4ce414ff132c73.tar.gz
gentoo-b24fab79ca7863993080b5fafd4ce414ff132c73.tar.bz2
gentoo-b24fab79ca7863993080b5fafd4ce414ff132c73.zip
sci-biology/qrna: Port to EAPI 7
Closes: https://bugs.gentoo.org/710554 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology/qrna/qrna-2.0.3c-r3.ebuild')
-rw-r--r--sci-biology/qrna/qrna-2.0.3c-r3.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/sci-biology/qrna/qrna-2.0.3c-r3.ebuild b/sci-biology/qrna/qrna-2.0.3c-r3.ebuild
index 5c580a24d2a3..34b59e9fb0a3 100644
--- a/sci-biology/qrna/qrna-2.0.3c-r3.ebuild
+++ b/sci-biology/qrna/qrna-2.0.3c-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit toolchain-funcs
@@ -12,7 +12,6 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="
dev-lang/perl
@@ -26,15 +25,13 @@ PATCHES=(
src_prepare() {
default
- sed \
- -e "s:^CC.*:CC = $(tc-getCC):" \
- -e "/^AR/s:ar:$(tc-getAR):g" \
- -e "/^RANLIB/s:ranlib:$(tc-getRANLIB):g" \
- -e "/CFLAGS/s:=.*$:= ${CFLAGS}:" \
- -i {src,squid,squid02}/Makefile || die
rm -v squid*/*.a || die
}
+src_configure() {
+ tc-export AR CC RANLIB
+}
+
src_compile() {
local d
for d in squid squid02 src; do