summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/raxml/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/raxml/files')
-rw-r--r--sci-biology/raxml/files/raxml-7.2.5-makefile.patch29
-rw-r--r--sci-biology/raxml/files/raxml-7.2.6-makefile.patch29
2 files changed, 58 insertions, 0 deletions
diff --git a/sci-biology/raxml/files/raxml-7.2.5-makefile.patch b/sci-biology/raxml/files/raxml-7.2.5-makefile.patch
new file mode 100644
index 000000000000..8b381e50cb58
--- /dev/null
+++ b/sci-biology/raxml/files/raxml-7.2.5-makefile.patch
@@ -0,0 +1,29 @@
+ Makefile.gcc | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.gcc b/Makefile.gcc
+index 8d09549..59af556 100644
+--- a/Makefile.gcc
++++ b/Makefile.gcc
+@@ -1,10 +1,10 @@
+ # Makefile August 2006 by Alexandros Stamatakis
+ # Makefile cleanup October 2006, Courtesy of Peter Cordes <peter@cordes.ca>
+
+-CC = gcc
++CC ?= gcc
+
+
+-CFLAGS = -D_GNU_SOURCE -fomit-frame-pointer -funroll-loops -O2
++CFLAGS += -D_GNU_SOURCE
+ #-Wall -std=c99 -pedantic -Wunused-parameter -Wredundant-decls -Wreturn-type -Wswitch-default -Wunused-value -Wimplicit -Wimplicit-function-declaration -Wimplicit-int -Wimport -pedantic-errors -Wunused -Wunused-function -Wunused-label -Wno-int-to-pointer-cast -Wbad-function-cast -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wold-style-definition -Wstrict-prototypes -Wdeclaration-after-statement -Wpointer-sign -Wextra -Wredundant-decls -Wunused -Wunused-function -Wunused-parameter -Wunused-value -Wunused-variable -Wformat -Wformat-nonliteral -Wparentheses -Wsequence-point -Wuninitialized -Wundef -Wbad-function-cast
+
+
+@@ -19,7 +19,7 @@ all : raxmlHPC
+ GLOBAL_DEPS = axml.h globalVariables.h
+
+ raxmlHPC : $(objs)
+- $(CC) -o raxmlHPC $(objs) $(LIBRARIES)
++ $(CC) $(LDFLAGS) -o raxmlHPC $(objs) $(LIBRARIES)
+
+ classify.o : classify.c $(GLOBAL_DEPS)
+ evaluatePartialSpecialGeneric.o : evaluatePartialSpecialGeneric.c $(GLOBAL_DEPS)
diff --git a/sci-biology/raxml/files/raxml-7.2.6-makefile.patch b/sci-biology/raxml/files/raxml-7.2.6-makefile.patch
new file mode 100644
index 000000000000..ae83e2eef4e7
--- /dev/null
+++ b/sci-biology/raxml/files/raxml-7.2.6-makefile.patch
@@ -0,0 +1,29 @@
+ Makefile.gcc | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.gcc b/Makefile.gcc
+index 716b6c6..f0c1de2 100644
+--- a/Makefile.gcc
++++ b/Makefile.gcc
+@@ -1,10 +1,10 @@
+ # Makefile August 2006 by Alexandros Stamatakis
+ # Makefile cleanup October 2006, Courtesy of Peter Cordes <peter@cordes.ca>
+
+-CC = gcc
++CC ?= gcc
+
+
+-CFLAGS = -D_GNU_SOURCE -fomit-frame-pointer -funroll-loops -O2 -msse
++CFLAGS += -D_GNU_SOURCE
+
+
+
+@@ -19,7 +19,7 @@ all : raxmlHPC
+ GLOBAL_DEPS = axml.h globalVariables.h
+
+ raxmlHPC : $(objs)
+- $(CC) -o raxmlHPC $(objs) $(LIBRARIES)
++ $(CC) $(LDFLAGS) -o raxmlHPC $(objs) $(LIBRARIES)
+
+ classify.o : classify.c $(GLOBAL_DEPS)
+ evaluatePartialSpecialGeneric.o : evaluatePartialSpecialGeneric.c $(GLOBAL_DEPS)