summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/seaview
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/seaview')
-rw-r--r--sci-biology/seaview/Manifest1
-rw-r--r--sci-biology/seaview/metadata.xml12
-rw-r--r--sci-biology/seaview/seaview-4.3.5.ebuild77
3 files changed, 90 insertions, 0 deletions
diff --git a/sci-biology/seaview/Manifest b/sci-biology/seaview/Manifest
new file mode 100644
index 000000000000..6bb12c484533
--- /dev/null
+++ b/sci-biology/seaview/Manifest
@@ -0,0 +1 @@
+DIST seaview_4.3.5.tar.gz 309530 SHA256 38050d6792eb799d61e5e849f76971a9c7d45f467e5c04fbc4363062d8e7100d SHA512 b20c018da9a29d79fe0393fed5d29117729492ea8f36e72d4aeb98044a3de4a13331bd29e76ca552a08f6da764e57e69f9fb0325fc031551514d7a54b56c849a WHIRLPOOL 82fc7324bf1d934d69712629808d6b4178a5f2cdcf25351fb2fe2784f9cea0c1ec0aaaba7a3a08c84795108eb049394ceaab052af8cc0efbb0975064fa4e80e0
diff --git a/sci-biology/seaview/metadata.xml b/sci-biology/seaview/metadata.xml
new file mode 100644
index 000000000000..33794f43ab01
--- /dev/null
+++ b/sci-biology/seaview/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <longdescription>
+ SeaView is a graphical multiple sequence alignment editor developped by
+ Manolo Gouy. SeaView is able to read and write various alignment
+ formats (NEXUS, MSF, CLUSTAL, FASTA, PHYLIP, MASE). It allows to
+ manually edit the alignment, and also to run DOT-PLOT or CLUSTALW
+ programs to locally improve the alignment.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-biology/seaview/seaview-4.3.5.ebuild b/sci-biology/seaview/seaview-4.3.5.ebuild
new file mode 100644
index 000000000000..00abeb426064
--- /dev/null
+++ b/sci-biology/seaview/seaview-4.3.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A graphical multiple sequence alignment editor"
+HOMEPAGE="http://pbil.univ-lyon1.fr/software/seaview.html"
+SRC_URI="ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/seaview/archive/${PN}_${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="+xft"
+
+CDEPEND="
+ sys-libs/zlib
+ x11-libs/fltk:1
+ x11-libs/libX11
+ xft? (
+ x11-libs/libXft
+ x11-libs/fltk:1[xft] )"
+RDEPEND="${CDEPEND}
+ sci-biology/clustalw
+ || ( sci-libs/libmuscle sci-biology/muscle )
+ sci-biology/phyml"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # respect CXXFLAGS (package uses them as CFLAGS)
+ sed \
+ -e "s:^CC.*:CC = $(tc-getCC):" \
+ -e "s:^CXX.*:CXX = $(tc-getCXX):" \
+ -e "s:\$(OPT):${CXXFLAGS}:" \
+ -e "s:^OPT:#OPT:" \
+ -e "s:^FLTK = .*$:FLTK = ${EPREFIX}/usr/include/fltk-1:" \
+ -e "s:^#IFLTK .*:IFLTK = $(fltk-config --use-images --cflags):" \
+ -e "s:^#LFLTK .*:LFLTK = $(fltk-config --use-images --ldflags):" \
+ -e "s:^USE_XFT:#USE_XFT:" \
+ -e "s:^#HELPFILE:HELPFILE:" \
+ -e "s:/usr/share/doc/seaview/seaview.htm:${EPREFIX}/usr/share/seaview/seaview.htm:" \
+ -e "s:^#PHYMLNAME:PHYMLNAME:" \
+ -e 's:-lXinerama::g' \
+ -e 's:-lpng::g' \
+ -e 's:-ljpeg::g' \
+ -e 's:-lfontconfig::g' \
+ -i Makefile || die "sed failed while editing Makefile"
+
+ if use xft; then
+ sed \
+ -e "s:^#USE_XFT .*:USE_XFT = -DUSE_XFT $($(tc-getPKG_CONFIG) --cflags xft):" \
+ -e "s:-lXft:$($(tc-getPKG_CONFIG) --libs xft):" \
+ -i Makefile || die "sed failed while editing Makefile to enable xft"
+ else
+ sed -i -e "s:-lXft::" Makefile || die
+ fi
+}
+
+src_install() {
+ dobin seaview
+
+ # /usr/share/seaview/seaview.html is hardcoded in the binary, see Makefile
+ insinto /usr/share/seaview
+ doins example.nxs seaview.html
+
+ insinto /usr/share/seaview/images
+ doins seaview.xpm
+
+ make_desktop_entry seaview Seaview
+
+ doman seaview.1
+}