summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-20 16:47:13 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-20 18:37:13 +0200
commitbf671c6314a8faa990c51d5593d3b4d2d61ed31e (patch)
tree0915aae5a3bf3a157d645dbfff209e35a12b3345 /sci-biology/seqan/seqan-1.4.2-r1.ebuild
parentsci-biology/samtools: [QA] Add missing python metadata variables (diff)
downloadgentoo-bf671c6314a8faa990c51d5593d3b4d2d61ed31e.tar.gz
gentoo-bf671c6314a8faa990c51d5593d3b4d2d61ed31e.tar.bz2
gentoo-bf671c6314a8faa990c51d5593d3b4d2d61ed31e.zip
sci-biology/seqan: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sci-biology/seqan/seqan-1.4.2-r1.ebuild')
-rw-r--r--sci-biology/seqan/seqan-1.4.2-r1.ebuild24
1 files changed, 16 insertions, 8 deletions
diff --git a/sci-biology/seqan/seqan-1.4.2-r1.ebuild b/sci-biology/seqan/seqan-1.4.2-r1.ebuild
index 4848f159d145..5fd8f1ae8a14 100644
--- a/sci-biology/seqan/seqan-1.4.2-r1.ebuild
+++ b/sci-biology/seqan/seqan-1.4.2-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils python-single-r1
+inherit cmake-utils python-any-r1
DESCRIPTION="C++ Sequence Analysis Library"
HOMEPAGE="http://www.seqan.de/"
@@ -15,13 +15,17 @@ SLOT="$(get_version_component_range 1-2)"
LICENSE="BSD GPL-3"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE="cpu_flags_x86_sse4_1 test"
-DEPEND="sys-libs/zlib
- app-arch/bzip2
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE} cpu_flags_x86_sse4_1"
+REQUIRED_USE="cpu_flags_x86_sse4_1"
-#S="${WORKDIR}"/${PN}-${PN}-v${PV}
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ $(python_gen_any_dep 'dev-python/nose[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+ )"
PATCHES=(
"${FILESDIR}/${P}-shared.patch"
@@ -29,6 +33,10 @@ PATCHES=(
"${FILESDIR}/${P}-buildsystem.patch"
)
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
src_prepare() {
# pkg-config file, taken from seqan 2.1
cp "${FILESDIR}"/${PN}.pc.in ${PN}-${SLOT}.pc || die