summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-20 16:47:13 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-20 18:37:13 +0200
commitbf671c6314a8faa990c51d5593d3b4d2d61ed31e (patch)
tree0915aae5a3bf3a157d645dbfff209e35a12b3345 /sci-biology/seqan/seqan-2.2.0-r1.ebuild
parentsci-biology/samtools: [QA] Add missing python metadata variables (diff)
downloadgentoo-bf671c6314a8faa990c51d5593d3b4d2d61ed31e.tar.gz
gentoo-bf671c6314a8faa990c51d5593d3b4d2d61ed31e.tar.bz2
gentoo-bf671c6314a8faa990c51d5593d3b4d2d61ed31e.zip
sci-biology/seqan: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sci-biology/seqan/seqan-2.2.0-r1.ebuild')
-rw-r--r--sci-biology/seqan/seqan-2.2.0-r1.ebuild28
1 files changed, 20 insertions, 8 deletions
diff --git a/sci-biology/seqan/seqan-2.2.0-r1.ebuild b/sci-biology/seqan/seqan-2.2.0-r1.ebuild
index f59ae0a1bae1..2452ff0baea6 100644
--- a/sci-biology/seqan/seqan-2.2.0-r1.ebuild
+++ b/sci-biology/seqan/seqan-2.2.0-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils python-single-r1
+inherit cmake-utils python-any-r1
DESCRIPTION="C++ Sequence Analysis Library"
HOMEPAGE="http://www.seqan.de/"
@@ -15,21 +15,33 @@ SLOT="0"
LICENSE="BSD GPL-3"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="cpu_flags_x86_sse4_1 doc test"
+REQUIRED_USE="cpu_flags_x86_sse4_1"
+
RDEPEND="
app-arch/bzip2
sys-libs/zlib
!!sci-biology/seqan:2.0
!!sci-biology/seqan:2.1
!!sci-biology/seqan:2.2"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-REQUIRED_USE="doc? ( ${PYTHON_REQUIRED_USE} ) test? ( ${PYTHON_REQUIRED_USE} ) cpu_flags_x86_sse4_1"
+DEPEND="
+ ${RDEPEND}
+ doc? (
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+ )
+ test? (
+ $(python_gen_any_dep 'dev-python/nose[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+ )"
S="${WORKDIR}"/${PN}-${PN}-v${PV}
+pkg_setup() {
+ if use test || use doc; then
+ python-any-r1_pkg_setup
+ fi
+}
+
src_prepare() {
seqan_major_ver=$(get_version_component_range 1)
seqan_majorminor_ver=$(get_version_component_range 1-2)