summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/shrimp/shrimp-2.2.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/shrimp/shrimp-2.2.3.ebuild')
-rw-r--r--sci-biology/shrimp/shrimp-2.2.3.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/sci-biology/shrimp/shrimp-2.2.3.ebuild b/sci-biology/shrimp/shrimp-2.2.3.ebuild
new file mode 100644
index 000000000000..7f2033d9054a
--- /dev/null
+++ b/sci-biology/shrimp/shrimp-2.2.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit flag-o-matic python-single-r1 toolchain-funcs
+
+MY_PV=${PV//./_}
+
+DESCRIPTION="SHort Read Mapping Package"
+HOMEPAGE="http://compbio.cs.toronto.edu/shrimp/"
+SRC_URI="http://compbio.cs.toronto.edu/shrimp/releases/SHRiMP_${MY_PV}.src.tar.gz"
+
+LICENSE="shrimp"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="custom-cflags +cpu_flags_x86_sse2"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# file collision on /usr/bin/utils #453044
+DEPEND="!sci-mathematics/cado-nfs"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}"
+
+S=${WORKDIR}/SHRiMP_${MY_PV}
+
+pkg_pretend() {
+ use cpu_flags_x86_sse2 || die "This package needs sse2 support in your CPU"
+}
+
+pkg_setup() {
+ if [[ ${CC} == *gcc* ]] && ! tc-has-openmp; then
+ elog "Please set CC to an OPENMP capable compiler (e.g. gcc[openmp] or icc"
+ die "C compiler lacks OPENMP support"
+ fi
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ sed \
+ -e '1 a #include <stdint.h>' \
+ -i common/dag_glue.cpp || die
+ # respect LDFLAGS wrt 331823
+ sed \
+ -e "s/LDFLAGS/LIBS/" \
+ -e "s/\$(LD)/& \$(LDFLAGS)/" \
+ -e 's/-static//' \
+ -i Makefile || die
+
+ append-flags -fopenmp
+ if ! use custom-cflags; then
+ append-flags -O3
+ replace-flags -O* -O3
+ fi
+ tc-export CXX
+
+ cd utils || die
+ sed -e '/^#!/d' -i *py || die
+ sed -e '1i#!/usr/bin/python' -i *py || die
+}
+
+src_compile() {
+ emake CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ local i
+ newdoc bin/README README.bin && rm bin/README
+ dobin bin/* utils/split-contigs utils/temp-sink
+ dodoc HISTORY README TODO SPLITTING_AND_MERGING SCORES_AND_PROBABILITES
+
+ pushd utils > /dev/null
+
+ python_doscript *py
+
+ rm *.py *.o *.c split-contigs temp-sink || die
+ insinto /usr/share/${PN}
+ doins -r *
+}