summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/velvet/velvet-1.2.10.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/velvet/velvet-1.2.10.ebuild')
-rw-r--r--sci-biology/velvet/velvet-1.2.10.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/sci-biology/velvet/velvet-1.2.10.ebuild b/sci-biology/velvet/velvet-1.2.10.ebuild
new file mode 100644
index 000000000000..86b06ffcd125
--- /dev/null
+++ b/sci-biology/velvet/velvet-1.2.10.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="A sequence assembler for very short reads"
+HOMEPAGE="http://www.ebi.ac.uk/~zerbino/velvet/"
+SRC_URI="http://www.ebi.ac.uk/~zerbino/velvet/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc openmp"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ if ! use doc; then
+ sed -i -e '/default :/ s/doc//' "${S}"/Makefile || die
+ fi
+ elog "Upstream recommendes using -O3 in CFLAGS"
+ echo
+ elog "To adjust the MAXKMERLENGTH or CATEGORIES parameters as described in the manual,"
+ elog "please set the variables VELVET_MAXKMERLENGTH or VELVET_CATEGORIES in your"
+ elog "environment or /etc/make.conf, then re-emerge the package. For example:"
+ elog " VELVET_MAXKMERLENGTH=NN emerge [options] velvet"
+ MAKEOPTS+=" -j1"
+
+ if [[ $(tc-getCC) =~ gcc ]]; then
+ local eopenmp=-fopenmp
+ elif [[ $(tc-getCC) =~ icc ]]; then
+ local eopenmp=-openmp
+ else
+ elog "Cannot detect compiler type so not setting openmp support"
+ fi
+ append-flags -fPIC ${eopenmp}
+ append-ldflags ${eopenmp}
+
+ tc-export CC
+
+ MAKE_XOPTS=(
+ CC=$(tc-getCC)
+ CFLAGS="${CFLAGS}"
+ OPT="${CFLAGS}"
+ )
+ if [[ ${VELVET_MAXKMERLENGTH} != "" ]]; then MAKE_XOPTS+=( MAXKMERLENGTH=${VELVET_MAXKMERLENGTH} ); fi
+ if [[ ${VELVET_CATEGORIES} != "" ]]; then MAKE_XOPTS+=( CATEGORIES=${VELVET_CATEGORIES} ); fi
+}
+
+src_compile() {
+ emake "${MAKE_XOPTS[@]}"
+ emake "${MAKE_XOPTS[@]}" color
+}
+
+src_test() {
+ emake "${MAKE_XOPTS[@]}" test
+}
+
+src_install() {
+ dobin velvet{g,h,g_de,h_de}
+ insinto /usr/share/${PN}
+ doins -r contrib
+ dodoc Manual.pdf CREDITS.txt ChangeLog
+}