summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 00:48:19 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 00:48:19 +0100
commit03d68993ae99b4ef037f5f4e60e1837420bb4744 (patch)
treef59555492852d768f6595fb465e55d539e76b4bc /sci-biology
parentsci-biology/last: Remove old (diff)
downloadgentoo-03d68993ae99b4ef037f5f4e60e1837420bb4744.tar.gz
gentoo-03d68993ae99b4ef037f5f4e60e1837420bb4744.tar.bz2
gentoo-03d68993ae99b4ef037f5f4e60e1837420bb4744.zip
sci-biology/plink: Remove old
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/plink/Manifest1
-rw-r--r--sci-biology/plink/files/1.07-flags.patch44
-rw-r--r--sci-biology/plink/files/plink-1.07-gcc47.patch64
-rw-r--r--sci-biology/plink/metadata.xml8
-rw-r--r--sci-biology/plink/plink-1.07-r1.ebuild47
5 files changed, 0 insertions, 164 deletions
diff --git a/sci-biology/plink/Manifest b/sci-biology/plink/Manifest
index 3efed74ba495..75806d2b2477 100644
--- a/sci-biology/plink/Manifest
+++ b/sci-biology/plink/Manifest
@@ -1,2 +1 @@
-DIST plink-1.07-src.zip 2257297 BLAKE2B 572daeec24ec53daa017de9d4326c5db316f94fdcb40fb3d6a889643a5b5c60208a9424246e70414982a4659dd9c9bae5115d7ba3dc45183b521d1809fe2f00b SHA512 493f9f32ecd9eb20c5d11dc8ac98c47a9e695059cec3d1ad6f17465b71609577032368c0fee0d3d564e9451c3c07761e444717bec0f4628caefc587fceb1f6c3
DIST plink-1.90_pre140514.zip 822157 BLAKE2B 3c29670862de99c9715bc37d8cffc2b02c0cb25ad746975f253ca1e8094b24668cc6739943c68bfa407471f30835a74c6ad027eaa56a92f13445e0a02854cad3 SHA512 679f1e136b11f35f1d49636bc44ffd17e72e4e38edc5daa270cd963ca39f7b8a80f31905a94de517059e5b3ea7a6bf518ae34a5c2af8a05c530bd6df771606c4
diff --git a/sci-biology/plink/files/1.07-flags.patch b/sci-biology/plink/files/1.07-flags.patch
deleted file mode 100644
index aa130f29beb2..000000000000
--- a/sci-biology/plink/files/1.07-flags.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 172c795..466f09f 100644
---- a/Makefile
-+++ b/Makefile
-@@ -26,25 +26,25 @@ WITH_R_PLUGINS = 1
- WITH_WEBCHECK = 1
- FORCE_32BIT =
- WITH_ZLIB = 1
--WITH_LAPACK =
--FORCE_DYNAMIC =
-+WITH_LAPACK = 1
-+FORCE_DYNAMIC = 1
-
- # Put C++ compiler here; Windows has it's own specific version
- CXX_UNIX = g++
- CXX_WIN = c:\bin\mingw\bin\mingw32-g++.exe
-
- # Any other compiler flags here ( -Wall, -g, etc)
--CXXFLAGS =
-+CXXFLAGS ?= -O2
-
- # Misc
--LIB_LAPACK = /usr/lib/liblapack.so.3
-+LIB_LAPACK = `$(PKG_CONFIG) --libs lapack`
-
-
- # --------------------------------------------------------------------
- # Do not edit below this line
- # --------------------------------------------------------------------
-
--CXXFLAGS += -O3 -I.
-+CXXFLAGS += -I.
- OUTPUT = plink
-
- # Some system specific flags
-@@ -151,7 +151,7 @@ OBJ = $(SRC:.cpp=.o)
- all : $(OUTPUT)
-
- $(OUTPUT) :
-- $(CXX) $(CXXFLAGS) -o $(OUTPUT) $(OBJ) $(LIB)
-+ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $(OUTPUT) $(OBJ) $(LIB)
-
- $(OBJ) : $(HDR)
-
diff --git a/sci-biology/plink/files/plink-1.07-gcc47.patch b/sci-biology/plink/files/plink-1.07-gcc47.patch
deleted file mode 100644
index 6c289edae153..000000000000
--- a/sci-biology/plink/files/plink-1.07-gcc47.patch
+++ /dev/null
@@ -1,64 +0,0 @@
- elf.cpp | 6 +++---
- idhelp.cpp | 8 ++++----
- sets.cpp | 8 ++++----
- 3 files changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/elf.cpp b/elf.cpp
-index ec2ed3d..a57665f 100644
---- a/elf.cpp
-+++ b/elf.cpp
-@@ -1175,10 +1175,10 @@ void Plink::elfBaseline()
- << setw(8) << gcnt << " "
- << setw(8) << (double)cnt / (double)gcnt << "\n";
-
-- map<int,int>::iterator i = chr_cnt.begin();
-- while ( i != chr_cnt.end() )
-+ map<int,int>::iterator j = chr_cnt.begin();
-+ while ( j != chr_cnt.end() )
- {
-- int c = i->first;
-+ int c = j->first;
- int x = chr_cnt.find( c )->second;
- int y = chr_gcnt.find( c )->second;
-
-diff --git a/idhelp.cpp b/idhelp.cpp
-index a9244fa..8882097 100644
---- a/idhelp.cpp
-+++ b/idhelp.cpp
-@@ -772,12 +772,12 @@ void IDHelper::idHelp()
- for (int j = 0 ; j < jointField.size(); j++ )
- {
- set<IDField*> & jf = jointField[j];
-- set<IDField*>::iterator j = jf.begin();
-+ set<IDField*>::iterator k = jf.begin();
- PP->printLOG(" { ");
-- while ( j != jf.end() )
-+ while ( k != jf.end() )
- {
-- PP->printLOG( (*j)->name + " " );
-- ++j;
-+ PP->printLOG( (*k)->name + " " );
-+ ++k;
- }
- PP->printLOG(" }");
- }
-diff --git a/sets.cpp b/sets.cpp
-index 3a8f92f..66787e8 100644
---- a/sets.cpp
-+++ b/sets.cpp
-@@ -768,11 +768,11 @@ vector_t Set::profileTestScore()
- //////////////////////////////////////////////
- // Reset original missing status
-
-- vector<Individual*>::iterator i = PP->sample.begin();
-- while ( i != PP->sample.end() )
-+ vector<Individual*>::iterator j = PP->sample.begin();
-+ while ( j != PP->sample.end() )
- {
-- (*i)->missing = (*i)->flag;
-- ++i;
-+ (*j)->missing = (*j)->flag;
-+ ++j;
- }
-
- ////////////////////////////////////////////////
diff --git a/sci-biology/plink/metadata.xml b/sci-biology/plink/metadata.xml
index c281934d9943..8417d1580d40 100644
--- a/sci-biology/plink/metadata.xml
+++ b/sci-biology/plink/metadata.xml
@@ -5,12 +5,4 @@
<email>sci-biology@gentoo.org</email>
<name>Gentoo Biology Project</name>
</maintainer>
- <use>
- <flag name="webcheck">
- add support for online update checking every time the program starts
- </flag>
- <flag name="R">
- add support R language
- </flag>
- </use>
</pkgmetadata>
diff --git a/sci-biology/plink/plink-1.07-r1.ebuild b/sci-biology/plink/plink-1.07-r1.ebuild
deleted file mode 100644
index 3e1d4d5b0b43..000000000000
--- a/sci-biology/plink/plink-1.07-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Whole genome association analysis toolset"
-HOMEPAGE="http://pngu.mgh.harvard.edu/~purcell/plink/"
-SRC_URI="http://pngu.mgh.harvard.edu/~purcell/plink/dist/${P}-src.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="lapack -webcheck R"
-KEYWORDS="amd64 x86"
-
-DEPEND="
- app-arch/unzip
- lapack? ( virtual/pkgconfig )"
-RDEPEND="
- sys-libs/zlib
- lapack? ( virtual/lapack )"
-
-S="${WORKDIR}/${P}-src"
-
-# Package collides with net-misc/putty. Renamed to p-link following discussion with Debian.
-# Package contains bytecode-only jar gPLINK.jar. Ignored, notified upstream.
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PV}-flags.patch \
- "${FILESDIR}"/${P}-gcc47.patch
- use webcheck || sed -i '/WITH_WEBCHECK =/ s/^/#/' "${S}/Makefile" || die
- use R || sed -i '/WITH_R_PLUGINS =/ s/^/#/' "${S}/Makefile" || die
- use lapack || sed -i '/WITH_LAPACK =/ s/^/#/' "${S}/Makefile" || die
- tc-export PKG_CONFIG
-}
-
-src_compile() {
- emake \
- CXX_UNIX=$(tc-getCXX)
-}
-
-src_install() {
- newbin plink p-link
- dodoc README.txt
-}