summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-25 11:51:11 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-25 11:51:11 +0100
commit363526d4663d10660c2c593d11a9ab3707443572 (patch)
tree5e29162c3d71efc940c6c6e06dc76ade020b58bd /sci-biology
parentmail-filter/amavisd-new: stable 2.12.0-r3 for ppc, bug #721534 (diff)
downloadgentoo-363526d4663d10660c2c593d11a9ab3707443572.tar.gz
gentoo-363526d4663d10660c2c593d11a9ab3707443572.tar.bz2
gentoo-363526d4663d10660c2c593d11a9ab3707443572.zip
sci-biology/abyss: respect AR override, bug #725300
Use AM_PROG_AR to default to standard AR discovery instead of make's 'ar'. Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/725300 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/abyss/abyss-2.0.3-r1.ebuild56
-rw-r--r--sci-biology/abyss/files/abyss-2.0.3-prog-AR.patch11
2 files changed, 67 insertions, 0 deletions
diff --git a/sci-biology/abyss/abyss-2.0.3-r1.ebuild b/sci-biology/abyss/abyss-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..6c8571fafa60
--- /dev/null
+++ b/sci-biology/abyss/abyss-2.0.3-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
+HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
+SRC_URI="https://github.com/bcgsc/abyss/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="abyss"
+SLOT="0"
+IUSE="+mpi openmp misc-haskell"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-cpp/sparsehash
+ dev-libs/boost:=
+ misc-haskell? (
+ dev-libs/gmp:0=
+ virtual/libffi:0=
+ )
+ mpi? ( sys-cluster/openmpi )"
+DEPEND="${RDEPEND}
+ misc-haskell? (
+ dev-lang/ghc
+ )"
+
+PATCHES=("${FILESDIR}"/${PN}-2.0.3-prog-AR.patch)
+
+# todo: --enable-maxk=N configure option
+# todo: fix automagic mpi toggling
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/-Werror//" configure.ac || die #365195
+ sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ # disable building haskell tool Misc/samtobreak
+ # unless request by user: bug #534412
+ use misc-haskell || export ac_cv_prog_ac_ct_GHC=
+
+ econf $(use_enable openmp)
+}
diff --git a/sci-biology/abyss/files/abyss-2.0.3-prog-AR.patch b/sci-biology/abyss/files/abyss-2.0.3-prog-AR.patch
new file mode 100644
index 000000000000..d41c58ad261a
--- /dev/null
+++ b/sci-biology/abyss/files/abyss-2.0.3-prog-AR.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/725300
+--- a/configure.ac
++++ b/configure.ac
+@@ -17,6 +17,7 @@ AC_CHECK_TOOL(GHC, ghc)
+ AM_CONDITIONAL([HAVE_GHC], ["$GHC" --version])
+ AC_CHECK_PROG(PANDOC, pandoc, yes)
+ AM_CONDITIONAL([HAVE_PANDOC], [test x"$PANDOC" = x"yes"])
++AM_PROG_AR
+
+ # Checks for header files.
+ AC_CHECK_HEADERS([dlfcn.h fcntl.h float.h limits.h \