summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-03-13 13:04:58 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-13 13:04:58 +0100
commit7c7749512da505f839b5e64d69ef9650139b26bc (patch)
treef5b01b031038d8db24701d5451c42a4c53c01a66 /sci-biology
parentsci-biology/embassy-domainatrix: Port to EAPI 7 (diff)
downloadgentoo-7c7749512da505f839b5e64d69ef9650139b26bc.tar.gz
gentoo-7c7749512da505f839b5e64d69ef9650139b26bc.tar.bz2
gentoo-7c7749512da505f839b5e64d69ef9650139b26bc.zip
sci-biology/embassy-mse: Fix building against clang/LLD
Closes: https://bugs.gentoo.org/731850 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/embassy-mse/files/embassy-mse-3.0.0.650_fix-build-system.patch39
1 files changed, 18 insertions, 21 deletions
diff --git a/sci-biology/embassy-mse/files/embassy-mse-3.0.0.650_fix-build-system.patch b/sci-biology/embassy-mse/files/embassy-mse-3.0.0.650_fix-build-system.patch
index c1095b266d60..23e656dc0a86 100644
--- a/sci-biology/embassy-mse/files/embassy-mse-3.0.0.650_fix-build-system.patch
+++ b/sci-biology/embassy-mse/files/embassy-mse-3.0.0.650_fix-build-system.patch
@@ -1,11 +1,3 @@
- ckit/Makefile.am | 2 +-
- configure.ac | 67 +++++++++++---------------------------------------
- emboss_acd/Makefile.am | 2 +-
- src/Makefile.am | 6 ++---
- 4 files changed, 18 insertions(+), 59 deletions(-)
-
-diff --git a/ckit/Makefile.am b/ckit/Makefile.am
-index f87b131..a670d2b 100644
--- a/ckit/Makefile.am
+++ b/ckit/Makefile.am
@@ -2,7 +2,7 @@
@@ -17,11 +9,9 @@ index f87b131..a670d2b 100644
CKITSRC = datafiles.c next.c seqentry.c strings.c gcg.c pir.c \
seqspec.c ttyinterface.c nextseqentry.c \
-diff --git a/configure.ac b/configure.ac
-index a20d488..eb208bf 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -635,33 +635,6 @@ AS_CASE([${host_os}],
+@@ -635,33 +635,6 @@
@@ -55,7 +45,7 @@ index a20d488..eb208bf 100644
dnl FIXME: This does no longer seem required with Autoconf 2.67?
dnl Intel MacOSX 10.6 puts X11 in a non-standard place
dnl AS_IF([test "x${with_x}" != "xno"],
-@@ -737,21 +710,6 @@ AX_LIB_POSTGRESQL
+@@ -737,21 +710,6 @@
@@ -77,7 +67,7 @@ index a20d488..eb208bf 100644
dnl Test if --enable-localforce given
locallink="no"
embprefix="/usr/local"
-@@ -874,6 +832,13 @@ AC_ARG_ENABLE([systemlibs],
+@@ -874,6 +832,13 @@
AM_CONDITIONAL([ESYSTEMLIBS], [test "x${enable_systemlibs}" = "xyes"])
@@ -91,7 +81,7 @@ index a20d488..eb208bf 100644
# Enable the purify tool: --enable-purify, sets CC and LIBTOOL
-@@ -1000,17 +965,13 @@ AS_IF([test "x${enable_savestats}" = "xyes"],
+@@ -1000,17 +965,13 @@
@@ -116,8 +106,6 @@ index a20d488..eb208bf 100644
-diff --git a/emboss_acd/Makefile.am b/emboss_acd/Makefile.am
-index e1c1878..e253c95 100644
--- a/emboss_acd/Makefile.am
+++ b/emboss_acd/Makefile.am
@@ -1,3 +1,3 @@
@@ -125,11 +113,9 @@ index e1c1878..e253c95 100644
-pkgdata_DATA = *.acd
+pkgdata_DATA = $(srcdir)/*.acd
pkgdatadir=$(prefix)/share/EMBOSS/acd
-diff --git a/src/Makefile.am b/src/Makefile.am
-index b44632a..84e89b5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
-@@ -18,9 +18,7 @@ AM_CPPFLAGS = -I../h \
+@@ -18,9 +18,7 @@
-I../../../ajax/ensembl -I../../../ajax/ajaxdb \
-I../../../ajax/acd -I../../../plplot
else
@@ -140,10 +126,21 @@ index b44632a..84e89b5 100644
endif
if ISSHARED
-@@ -60,5 +58,5 @@ LDADD = ../ckit/libckit.la \
+@@ -35,7 +33,7 @@
+ -lnucleus -lacd -lajaxdb -lensembl -lajaxg -lajax -lepcre \
+ $(NLAIXLIBS) -leplplot
+ else
+-AIX_CFLAGS = -Wl,-bdynamic -Wl,-brtl -L${embprefix}/lib -lnucleus -lacd \
++AIX_CFLAGS = -Wl,-bdynamic -Wl,-brtl -lnucleus -lacd \
+ -lajaxdb -lensembl -lajaxg -lajax -lepcre $(NLAIXLIBS) -leplplot
+ endif
+ endif
+@@ -59,6 +57,6 @@
+ ../../../plplot/libeplplot.la \
$(XLIB)
else
- LDADD = ../ckit/libckit.la -L${embprefix}/lib -lnucleus -lacd -lajaxdb \
+-LDADD = ../ckit/libckit.la -L${embprefix}/lib -lnucleus -lacd -lajaxdb \
- -lensembl -lajaxg -lajax -lepcre $(NLADD) -leplplot $(XLIB)
++LDADD = ../ckit/libckit.la -lnucleus -lacd -lajaxdb \
+ -lensembl -lajaxg -lajax $(NLADD) $(NCURSES_LIBS) $(XLIB)
endif