summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-10-03 19:41:38 +0200
committerDavid Seifert <soap@gentoo.org>2021-10-03 19:41:38 +0200
commit9eab85fba2bfef0ad9b849a75a7e78d2895d4eba (patch)
tree8848dedbddd27ed01331f9649f6d873ed7cef037 /sci-biology
parentsci-biology/samtools: add 1.13 (diff)
downloadgentoo-9eab85fba2bfef0ad9b849a75a7e78d2895d4eba.tar.gz
gentoo-9eab85fba2bfef0ad9b849a75a7e78d2895d4eba.tar.bz2
gentoo-9eab85fba2bfef0ad9b849a75a7e78d2895d4eba.zip
sci-biology/bcftools: add 1.13
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/bcftools/Manifest1
-rw-r--r--sci-biology/bcftools/bcftools-1.13.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sci-biology/bcftools/Manifest b/sci-biology/bcftools/Manifest
index 77114df86c03..958ce72a852c 100644
--- a/sci-biology/bcftools/Manifest
+++ b/sci-biology/bcftools/Manifest
@@ -1 +1,2 @@
DIST bcftools-1.10.2.tar.bz2 3702679 BLAKE2B 51acce94d463868562199206504dc8afb50c671c11139c5a96f52cedf135bb7a46115c69411b9943b970a2395e3c866275c85e345a4a40a90194d1094698314e SHA512 f07e405efa16b9b1b18521342df3eaf840ed1b3028b736a6b4d139012ea85769ddfb3cd3a2c94958415d984d07805dfcd3d4bbec0db401b3f071b861a56d1300
+DIST bcftools-1.13.tar.bz2 6906796 BLAKE2B 4c02d65733d28684f9a976e082913d79dbac4463c9471fc26d8ee0cbe7ad25af429cf7d01b9771bc34309386ccd2d77ebd54fbf64ed4183d1c2ebfbc0e727afb SHA512 aa533233dd2fec2279859204be39430c4fc630137a91d57fe917fd7a220044d5202ddc3d44bcffc3bd5bd5bb64f6ea4c8ec3c31e5e1ec72399998f1e6f23a55a
diff --git a/sci-biology/bcftools/bcftools-1.13.ebuild b/sci-biology/bcftools/bcftools-1.13.ebuild
new file mode 100644
index 000000000000..b0ddd23857c2
--- /dev/null
+++ b/sci-biology/bcftools/bcftools-1.13.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-single-r1
+
+DESCRIPTION="Utilities for variant calling and manipulating VCF and BCF files"
+HOMEPAGE="http://www.htslib.org"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-lang/perl
+ $(python_gen_cond_dep '
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ ')
+ =sci-libs/htslib-${PV}*:=
+ sys-libs/zlib
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ python_fix_shebang misc/{gff2gff,guess-ploidy,plot-roh}.py
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --disable-bcftools-plugins \
+ --disable-libgsl \
+ --with-htslib=system
+}