summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-19 00:39:18 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-19 00:39:56 +0200
commita4da0209640e967dbbc8cd85820ff8858e34f872 (patch)
tree07d9ed66629bb8285aa78706aa005d0ff257b740 /sci-biology
parentdev-python/pycares: add package (bug 533578) (diff)
downloadgentoo-a4da0209640e967dbbc8cd85820ff8858e34f872.tar.gz
gentoo-a4da0209640e967dbbc8cd85820ff8858e34f872.tar.bz2
gentoo-a4da0209640e967dbbc8cd85820ff8858e34f872.zip
sci-biology/bowtie: Allow for compiling with GCC 6
Gentoo-bug: 593966 Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/bowtie/bowtie-2.2.9.ebuild3
-rw-r--r--sci-biology/bowtie/files/bowtie-2.2.9-fix-c++14.patch29
2 files changed, 31 insertions, 1 deletions
diff --git a/sci-biology/bowtie/bowtie-2.2.9.ebuild b/sci-biology/bowtie/bowtie-2.2.9.ebuild
index 6e664202dfdf..8544512a3f0d 100644
--- a/sci-biology/bowtie/bowtie-2.2.9.ebuild
+++ b/sci-biology/bowtie/bowtie-2.2.9.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Popular short read aligner for Next-generation sequencing data"
HOMEPAGE="http://bowtie-bio.sourceforge.net/bowtie2/"
@@ -25,6 +25,7 @@ S="${WORKDIR}/${PN}2-${PV}"
DOCS=( AUTHORS NEWS TUTORIAL )
HTML_DOCS=( doc/{manual.html,style.css} )
+PATCHES=( "${FILESDIR}/${PN}-2.2.9-fix-c++14.patch" )
pkg_pretend() {
if ! use cpu_flags_x86_sse2 ; then
diff --git a/sci-biology/bowtie/files/bowtie-2.2.9-fix-c++14.patch b/sci-biology/bowtie/files/bowtie-2.2.9-fix-c++14.patch
new file mode 100644
index 000000000000..cd2a67b6a52b
--- /dev/null
+++ b/sci-biology/bowtie/files/bowtie-2.2.9-fix-c++14.patch
@@ -0,0 +1,29 @@
+Fix building with C++14, which errors out due to differing semantics between C++98
+and C++14 with regards to allowing destructors to throw exceptions.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=593966
+
+--- a/blockwise_sa.h
++++ b/blockwise_sa.h
+@@ -87,7 +87,11 @@
+ _logger(__logger)
+ { }
+
+- virtual ~BlockwiseSA() { }
++ virtual ~BlockwiseSA()
++#if __cplusplus >= 201103L
++ noexcept(false)
++#endif
++ { }
+
+ /**
+ * Get the next suffix; compute the next bucket if necessary.
+@@ -216,6 +220,9 @@
+ { _randomSrc.init(__seed); reset(); }
+
+ ~KarkkainenBlockwiseSA()
++#if __cplusplus >= 201103L
++ noexcept(false)
++#endif
+ {
+ #ifdef WITH_TBB
+ tbb_grp.wait();