summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 00:48:25 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 00:48:25 +0100
commitb0b40d543fca146fa2907f8d8ca63970403a74f1 (patch)
tree222daf665efcc1f1204ed4d7cb6f06265d5705eb /sci-biology
parentsci-biology/mrbayes: Remove old (diff)
downloadgentoo-b0b40d543fca146fa2907f8d8ca63970403a74f1.tar.gz
gentoo-b0b40d543fca146fa2907f8d8ca63970403a74f1.tar.bz2
gentoo-b0b40d543fca146fa2907f8d8ca63970403a74f1.zip
sci-biology/tree-puzzle: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild39
1 files changed, 18 insertions, 21 deletions
diff --git a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
index 27dd0bc2212f..8e2a07f8183e 100644
--- a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
+++ b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data"
HOMEPAGE="http://www.tree-puzzle.de"
@@ -13,44 +13,41 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="mpi"
+RESTRICT="test"
DEPEND="mpi? ( virtual/mpi )"
RDEPEND="${DEPEND}"
-RESTRICT="test"
-
-pkg_setup () {
- use mpi && [ $(tc-getCC) = icc ] && die "The parallelized version of tree-puzzle cannot be compiled using icc.
- Either disable the \"mpi\" USE flag to compile only the non-parallelized
- version of the program, or use gcc as your compiler (CC=\"gcc\")."
-}
+PATCHES=( "${FILESDIR}"/${PN}-impl-dec.patch )
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-impl-dec.patch
+pkg_setup() {
+ use mpi && [[ $(tc-getCC) == icc* ]] &&
+ die "The parallelized version of tree-puzzle cannot be compiled using icc.
+ Either disable the \"mpi\" USE flag to compile only the non-parallelized
+ version of the program, or use gcc as your compiler (CC=\"gcc\")."
}
src_configure() {
default
if ! use mpi; then
- sed \
- -e 's:bin_PROGRAMS = puzzle$(EXEEXT) ppuzzle:bin_PROGRAMS = puzzle :' \
- -e 's:DIST_SOURCES = $(ppuzzle_SOURCES) $(puzzle_SOURCES):DIST_SOURCES = $(puzzle_SOURCES):' \
- -i "${S}"/src/Makefile || die
+ sed \
+ -e 's:bin_PROGRAMS = puzzle$(EXEEXT) ppuzzle:bin_PROGRAMS = puzzle :' \
+ -e 's:DIST_SOURCES = $(ppuzzle_SOURCES) $(puzzle_SOURCES):DIST_SOURCES = $(puzzle_SOURCES):' \
+ -i src/Makefile || die
fi
}
src_install() {
dobin src/puzzle
use mpi && dobin src/ppuzzle
- dodoc AUTHORS ChangeLog README
+ einstalldocs
# User manual
- insinto /usr/share/doc/${PF}
- doins doc/tree-puzzle.pdf
+ dodoc doc/tree-puzzle.pdf
# Example data files
insinto /usr/share/${PN}/data
- rm data/Makefile*
- doins data/*
+ rm data/Makefile* || die
+ doins -r data/.
}