summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-08-17 13:19:19 +0200
committerDavid Seifert <soap@gentoo.org>2019-08-17 13:19:19 +0200
commitbcc75ebcff4cfb8a99a5a5f418f3b73174da7e11 (patch)
tree4fd87a75ebf689209ebfa50fe9388a6f4e73c442 /sci-biology
parentsci-biology/stride: [QA] Version the distfile (diff)
downloadgentoo-bcc75ebcff4cfb8a99a5a5f418f3b73174da7e11.tar.gz
gentoo-bcc75ebcff4cfb8a99a5a5f418f3b73174da7e11.tar.bz2
gentoo-bcc75ebcff4cfb8a99a5a5f418f3b73174da7e11.zip
sci-biology/stride: Port to EAPI 7
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/stride/files/stride-20011129-fix-buildsystem.patch21
-rw-r--r--sci-biology/stride/files/stride-LDFLAGS.patch11
-rw-r--r--sci-biology/stride/stride-20011129-r1.ebuild24
3 files changed, 31 insertions, 25 deletions
diff --git a/sci-biology/stride/files/stride-20011129-fix-buildsystem.patch b/sci-biology/stride/files/stride-20011129-fix-buildsystem.patch
new file mode 100644
index 000000000000..ec4415ec45d4
--- /dev/null
+++ b/sci-biology/stride/files/stride-20011129-fix-buildsystem.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,3 @@
+-CC = gcc -g
+ FLAGS = -lm -o
+
+ SOURCE = stride.c splitstr.c rdpdb.c initchn.c geometry.c thr2one.c one2thr.c filename.c tolostr.c strutil.c place_h.c hbenergy.c memory.c helix.c sheet.c rdmap.c phipsi.c command.c molscr.c die.c hydrbond.c mergepat.c fillasn.c escape.c p_jrnl.c p_rem.c p_atom.c p_helix.c p_sheet.c p_turn.c p_ssbond.c p_expdta.c p_model.c p_compnd.c report.c nsc.c area.c ssbond.c chk_res.c chk_atom.c turn.c pdbasn.c dssp.c outseq.c chkchain.c elem.c measure.c asngener.c p_endmdl.c stred.c contact_order.c contact_map.c
+@@ -7,12 +6,9 @@
+
+ BINDIR = .
+
+-.c.o:
+- $(CC) -c $< -o $@
+-
+
+ stride : $(OBJECT)
+- $(CC) $(OBJECT) $(FLAGS) $(BINDIR)/stride
++ $(CC) $(LDFLAGS) $(OBJECT) $(FLAGS) $(BINDIR)/stride
+
+ $(OBJECT) : stride.h protot.h
+
diff --git a/sci-biology/stride/files/stride-LDFLAGS.patch b/sci-biology/stride/files/stride-LDFLAGS.patch
deleted file mode 100644
index 1761b12129bd..000000000000
--- a/sci-biology/stride/files/stride-LDFLAGS.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile 2009-10-27 21:18:45.000000000 +0100
-+++ Makefile.new 2009-10-27 21:19:00.000000000 +0100
-@@ -12,7 +12,7 @@
-
-
- stride : $(OBJECT)
-- $(CC) $(OBJECT) $(FLAGS) $(BINDIR)/stride
-+ $(CC) $(LDFLAGS) $(OBJECT) $(FLAGS) $(BINDIR)/stride
-
- $(OBJECT) : stride.h protot.h
-
diff --git a/sci-biology/stride/stride-20011129-r1.ebuild b/sci-biology/stride/stride-20011129-r1.ebuild
index 77a19f3ea898..678887de925e 100644
--- a/sci-biology/stride/stride-20011129-r1.ebuild
+++ b/sci-biology/stride/stride-20011129-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Protein secondary structure assignment from atomic coordinates"
HOMEPAGE="http://webclu.bio.wzw.tum.de/stride/"
@@ -11,25 +11,21 @@ SRC_URI="
ftp://ftp.ebi.ac.uk/pub/software/unix/${PN}/src/${PN}.tar.gz -> ${P}.tar.gz
https://dev.gentoo.org/~jlec/distfiles/${PN}-20060723-update.patch.bz2"
-SLOT="0"
LICENSE="STRIDE"
+SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE=""
-
-S="${WORKDIR}"
-
RESTRICT="mirror bindist"
-src_prepare() {
+S="${WORKDIR}"
+PATCHES=(
# this patch updates the source to the most recent
# version which was kindly provided by the author
- epatch \
- "${DISTDIR}/${PN}-20060723-update.patch.bz2" \
- "${FILESDIR}"/${PN}-LDFLAGS.patch
+ "${S}"/${PN}-20060723-update.patch
+ "${FILESDIR}"/${PN}-20011129-fix-buildsystem.patch
+)
- # fix makefile
- sed -e "/^CC/s|gcc -g|$(tc-getCC) ${CFLAGS}|" -i Makefile || \
- die "Failed to fix Makefile"
+src_configure() {
+ tc-export CC
}
src_install() {