summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-12 11:06:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-12 16:31:15 +0100
commitc4919007b325c1ab3852e60f64926ff98984d16f (patch)
tree42b3b094e145b3d7808db7660c581b7b51a2d058 /sci-biology
parentemboss-r2.eclass: Support EAPI-7 (diff)
downloadgentoo-c4919007b325c1ab3852e60f64926ff98984d16f.tar.gz
gentoo-c4919007b325c1ab3852e60f64926ff98984d16f.tar.bz2
gentoo-c4919007b325c1ab3852e60f64926ff98984d16f.zip
sci-biology/emboss: EAPI-7 bump, minor style
Bug: https://bugs.gentoo.org/770262 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/emboss/emboss-6.6.0-r1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/sci-biology/emboss/emboss-6.6.0-r1.ebuild b/sci-biology/emboss/emboss-6.6.0-r1.ebuild
index 2aa5aa9bc5c9..1c74ded5e22f 100644
--- a/sci-biology/emboss/emboss-6.6.0-r1.ebuild
+++ b/sci-biology/emboss/emboss-6.6.0-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
EBO_EAUTORECONF=1
@@ -9,10 +9,11 @@ inherit emboss-r2 readme.gentoo-r1
DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
SRC_URI="ftp://emboss.open-bio.org/pub/${PN^^}/${P^^}.tar.gz"
+S="${WORKDIR}/${P^^}"
+LICENSE+=" Apache-2.0 GPL-3+ CC-BY-3.0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="minimal"
-LICENSE+=" Apache-2.0 GPL-3+ CC-BY-3.0"
RDEPEND="
!games-action/xbomber
@@ -27,8 +28,6 @@ PDEPEND="
sci-biology/rebase
)"
-S="${WORKDIR}/${P^^}"
-
PATCHES=(
"${FILESDIR}"/${P}_fix-build-system.patch
"${FILESDIR}"/${P}_FORTIFY_SOURCE-fix.patch
@@ -42,20 +41,20 @@ src_install() {
readme.gentoo_create_doc
# Install env file for setting libplplot and acd files path.
- cat > 22emboss <<- EOF || die
+ newenvd - 22emboss <<- EOF || die
# ACD files location
EMBOSS_ACDROOT="${EPREFIX}/usr/share/EMBOSS/acd"
EMBOSS_DATA="${EPREFIX}/usr/share/EMBOSS/data"
EOF
- doenvd 22emboss
# Remove useless dummy files
- find "${ED%/}"/usr/share/EMBOSS -name dummyfile -delete || die "Failed to remove dummy files"
+ find "${ED}"/usr/share/EMBOSS -name dummyfile -delete \
+ || die "Failed to remove dummy files"
# Move the provided codon files to a different directory. This will avoid
# user confusion and file collisions on case-insensitive file systems (see
# bug #115446). This change is documented in "README.gentoo".
- mv "${ED%/}"/usr/share/EMBOSS/data/CODONS{,.orig} \
+ mv "${ED}"/usr/share/EMBOSS/data/CODONS{,.orig} \
|| die "Failed to move CODON directory"
}