summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-24 08:10:27 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-24 08:10:27 +0100
commitd0d613f06aae55ab73f71229d00724034ca3c765 (patch)
tree732159ebc742d345856e9f3c57cddd931884a810 /sci-biology
parentsci-biology/biopandas: add 0.4.1 (diff)
downloadgentoo-d0d613f06aae55ab73f71229d00724034ca3c765.tar.gz
gentoo-d0d613f06aae55ab73f71229d00724034ca3c765.tar.bz2
gentoo-d0d613f06aae55ab73f71229d00724034ca3c765.zip
sci-biology/biopython: add 1.81
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/biopython/Manifest1
-rw-r--r--sci-biology/biopython/biopython-1.81.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sci-biology/biopython/Manifest b/sci-biology/biopython/Manifest
index 014c48aa8401..c693a5a8a963 100644
--- a/sci-biology/biopython/Manifest
+++ b/sci-biology/biopython/Manifest
@@ -1 +1,2 @@
DIST biopython-1.79.tar.gz 16738730 BLAKE2B 8c97fc23e458f7bc98b0ed0226bd6fb42f6c6f3ce03d562b13fac66c5061451595cd5bd01cad07bbe1fc6b20f4de21b0f03766b5a20e602545da888047a57185 SHA512 81e2718f4015bb038637b4d1181e6bea48018fec1e769c5f0ab75442a769336899191f1222e82e1b9569c1fac470500d7582420e5cbe9bce0056b41751adeaaa
+DIST biopython-1.81.tar.gz 19324875 BLAKE2B be3a85f5b60638987d6186af498411b494f8d27389f24cd1b9e658bc6b1a29c799ec8b20a9ac0b955c6d4c239706f4dbb5b75f6d56908f63d731b1d56c9fd587 SHA512 1595fad6631bfb6cf4e1a92ed72e6093e2a0c24f3c0bd4182267ec9742fb03dff16099eedde139598aa6b5b8380bbac9e48246cb9ab8b44109333d60adfd00ed
diff --git a/sci-biology/biopython/biopython-1.81.ebuild b/sci-biology/biopython/biopython-1.81.ebuild
new file mode 100644
index 000000000000..8b90d610c6ae
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.81.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python modules for computational molecular biology"
+HOMEPAGE="https://www.biopython.org/ https://pypi.org/project/biopython/"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ >=dev-python/reportlab-3.5.13-r1[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/flex"
+
+DOCS=( {CONTRIB,DEPRECATED,NEWS,README}.rst Doc/. )
+
+python_test() {
+ distutils_install_for_testing
+ cp -r {Doc,Tests} "${TEST_DIR}"/lib/ || die
+
+ # need to create symlinks for doctests
+ mkdir -p "${TEST_DIR}"/lib/Bio/Align || die
+ ln -r -s "${S}"/Bio/Align/substitution_matrices \
+ "${TEST_DIR}"/lib/Bio/Align/substitution_matrices || die
+
+ cd "${TEST_DIR}"/lib/Tests || die
+ rm test_BioSQL_{psycopg2.py,MySQLdb.py,mysql_connector.py} || die
+ "${EPYTHON}" run_tests.py --offline --verbose || die
+}
+
+python_install_all() {
+ # remove files causing ecompressdir to fail
+ rm Doc/examples/ls_orchid.gbk.{gz,bz2} || die
+
+ distutils-r1_python_install_all
+
+ dodir /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
+}
+
+pkg_postinst() {
+ optfeature_header "For database support you need to install:"
+ optfeature "MySQL database support" dev-python/mysqlclient
+ optfeature "PostgreSQL database support" dev-python/psycopg:2
+
+ optfeature_header "Some applications need extra packages:"
+ optfeature "EMBOSS (The European Molecular Biology Open Software Suite)" sci-biology/emboss
+}