summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-17 18:49:15 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-17 18:49:15 +0200
commite8f895d2073e56ef184485fdc2b51e04a636d1d8 (patch)
treebb366db983cefc7acca4d24a42c8d39ea58dd753 /sci-biology
parentgui-apps/grim: drop old (diff)
downloadgentoo-e8f895d2073e56ef184485fdc2b51e04a636d1d8.tar.gz
gentoo-e8f895d2073e56ef184485fdc2b51e04a636d1d8.tar.bz2
gentoo-e8f895d2073e56ef184485fdc2b51e04a636d1d8.zip
sci-biology/biopandas: Version bump to 0.2.7
Bug: https://bugs.gentoo.org/718470 Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/biopandas/Manifest1
-rw-r--r--sci-biology/biopandas/biopandas-0.2.7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-biology/biopandas/Manifest b/sci-biology/biopandas/Manifest
index edc8d21dfb49..f3fce8563c51 100644
--- a/sci-biology/biopandas/Manifest
+++ b/sci-biology/biopandas/Manifest
@@ -1 +1,2 @@
DIST biopandas-0.2.1.tar.gz 209379 BLAKE2B 839a6f569f12b95c9b1c75dc755d009c77d7ef8224e517aed5026ffa6c33bd3826fe3862fec03469e967005a500600782fc372951d61358e2fe3bb56af734228 SHA512 0ea7aec84251d8d6ec4736c4968228133bd8622afb17d6916287168cb9f9757c5a97a4d5a52ac0e2f30027bf0edf9d76413db142f70d606f1359b8a4e06de7c8
+DIST biopandas-0.2.7.tar.gz 255846 BLAKE2B b8c6a66f51a00266bc1a271ecfe00b4cfddd24b9766e63e2ad4187048ddd8f985d70eb8083b1be3887a0fd9b666c97553029ecd90c7b73ae882e5347bbc54d2e SHA512 cf4f12601b7f63ca3d5e9a17c6628e4975968f722c9db72e32c00e80ec335c5bf6a928a5f887b16ecd316c49b298d77634cbe1c4ef1ca505379b1de5335e2569
diff --git a/sci-biology/biopandas/biopandas-0.2.7.ebuild b/sci-biology/biopandas/biopandas-0.2.7.ebuild
new file mode 100644
index 000000000000..9be9a8ac4a3c
--- /dev/null
+++ b/sci-biology/biopandas/biopandas-0.2.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+MY_PN="BioPandas"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Molecular Structures in Pandas DataFrames"
+HOMEPAGE="
+ https://rasbt.github.io/biopandas/
+ https://github.com/rasbt/biopandas
+ https://pypi.org/project/BioPandas/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+
+distutils_enable_tests nose
+
+python_test() {
+ "${EPYTHON}" --version || die
+ "${EPYTHON}" -c "import numpy; print('numpy %s' % numpy.__version__)" || die
+ "${EPYTHON}" -c "import scipy; print('scipy %s' % scipy.__version__)" || die
+ "${EPYTHON}" -c "import pandas; print('pandas %s' % pandas.__version__)" || die
+
+ nosetests -s --verbose ${PN} || die
+}