summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-10-27 21:56:15 +0100
committerDavid Seifert <soap@gentoo.org>2020-10-27 21:56:15 +0100
commitfb89f8f6053ab2d65cd1c7b1604aa0a1df8bf216 (patch)
treed0050d578f2d80e901baa03ed99fcc633d75c930 /sci-biology
parentsci-mathematics/gmp-ecm: Keyword 7.0.4-r2 arm64, #749927 (diff)
downloadgentoo-fb89f8f6053ab2d65cd1c7b1604aa0a1df8bf216.tar.gz
gentoo-fb89f8f6053ab2d65cd1c7b1604aa0a1df8bf216.tar.bz2
gentoo-fb89f8f6053ab2d65cd1c7b1604aa0a1df8bf216.zip
sci-biology/phylip: Version bump to 3.698
Bug: https://bugs.gentoo.org/707150 Bug: https://bugs.gentoo.org/727982 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/phylip/Manifest1
-rw-r--r--sci-biology/phylip/files/phylip-3.698-fno-common.patch70
-rw-r--r--sci-biology/phylip/files/phylip-3.698-makefile.patch266
-rw-r--r--sci-biology/phylip/phylip-3.698.ebuild60
4 files changed, 397 insertions, 0 deletions
diff --git a/sci-biology/phylip/Manifest b/sci-biology/phylip/Manifest
index 5a714766bc16..2f29996a668c 100644
--- a/sci-biology/phylip/Manifest
+++ b/sci-biology/phylip/Manifest
@@ -1,2 +1,3 @@
DIST phylip-3.69.tar.gz 1511935 BLAKE2B 76aa5a79d2553c6f269c011f633d1101ee4d85ac398a36dd463e5605d90833ecb1e5f6c21edba3e142e2d4ab5ef034fa739e52e0ab3f941a7987915ae352be0b SHA512 e36d12bfe597896b4298c1d0e3b0b7bd783573dc03e861b9472d8284391b2339cb3fb58eb6580298724bbd516127b68925815455514f939da9272fcfed7e229d
DIST phylip-3.696.tar.gz 3955721 BLAKE2B dc75fc442eb63e44bc2e68e5dc97b3ff8f741bfa53740ed57ca114b53dcb71db9baeb9a96c3e693f7fae92afbaa71c7b5acfb39e7770bacb6aafa8c33b355be6 SHA512 711a9a34be72b0f63c746733cd1384f091b7cc597dbd9a40c130e074efbf0a0ecc30e5a6b3452bb73dc69cddbdae2fc07d1c0a68f0be207471eab73ab876c6be
+DIST phylip-3.698.zip 9675991 BLAKE2B 8d020cf17b3245b9827af4bdd1d17167c3e1a41ae805766c4b72f09de107775314a2a296c00f84f928487403cc02741fd46ae73585d0dba143f4b926777e9add SHA512 7f822dabd1ffdb6a689e0c308f5a3ae129bd86e305086a18c0c755ac3c6ca28a4337d52ced76b280706926370e23f19f304851ef82e32833d1945ed277f7d70d
diff --git a/sci-biology/phylip/files/phylip-3.698-fno-common.patch b/sci-biology/phylip/files/phylip-3.698-fno-common.patch
new file mode 100644
index 000000000000..986b1d9650ab
--- /dev/null
+++ b/sci-biology/phylip/files/phylip-3.698-fno-common.patch
@@ -0,0 +1,70 @@
+--- a/src/draw.c
++++ b/src/draw.c
+@@ -34,6 +34,11 @@
+
+ char fontname[LARGE_BUF_LENGTH];
+
++long treecolor, namecolor, backcolor, bottomcolor, vrmlskycolornear, vrmlskycolorfar,
++ vrmlgroundcolornear, vrmlgroundcolorfar, vrmlplotcolor;
++
++char afmfile[FNMLNGTH];
++
+ /* format of matrix: capheight, length[32],length[33],..length[256]*/
+
+ byte *full_pic ;
+--- a/src/draw.h
++++ b/src/draw.h
+@@ -52,10 +52,10 @@
+ double intensity, x, y, z;
+ } vrmllighttype;
+
+-long treecolor, namecolor, backcolor, bottomcolor, vrmlskycolornear, vrmlskycolorfar,
++extern long treecolor, namecolor, backcolor, bottomcolor, vrmlskycolornear, vrmlskycolorfar,
+ vrmlgroundcolornear, vrmlgroundcolorfar, vrmlplotcolor;
+
+-char afmfile[FNMLNGTH];
++extern char afmfile[FNMLNGTH];
+
+ double lengthtext(char *, long, char *, fonttype);
+ double heighttext(fonttype, char *);
+--- a/src/drawtree.c
++++ b/src/drawtree.c
+@@ -69,7 +69,7 @@
+ uselengths, regular, rotate, empty, rescaled,
+ notfirst, improve, nbody, firstscreens, labelavoid;
+ boolean pictbold,pictitalic,pictshadow,pictoutline;
+-boolean javarun;
++extern boolean javarun;
+
+ striptype stripe;
+ plottertype plotter, oldplotter;
+--- a/src/phylip.c
++++ b/src/phylip.c
+@@ -34,6 +34,8 @@
+
+ #include "phylip.h"
+
++boolean javarun;
++
+ #ifdef WIN32
+ #include <windows.h>
+ /* for console code (clear screen, text color settings) */
+--- a/src/phylip.h
++++ b/src/phylip.h
+@@ -331,7 +331,7 @@
+ /* Lower-triangular format. */
+ #define MAT_LOWERTRI (MAT_LOWER | MAT_MACHINE)
+
+-boolean javarun;
++extern boolean javarun;
+
+ typedef long *steptr;
+ typedef long longer[6];
+@@ -351,7 +351,6 @@
+ extern long spp, words, bits;
+ extern boolean ibmpc, ansi, tranvsp;
+ extern naym *nayme; /* names of species */
+-boolean firstplotblock; // for debugging BMP output
+
+ #define ebcdic EBCDIC
+
diff --git a/sci-biology/phylip/files/phylip-3.698-makefile.patch b/sci-biology/phylip/files/phylip-3.698-makefile.patch
new file mode 100644
index 000000000000..f55ab98dd9cb
--- /dev/null
+++ b/sci-biology/phylip/files/phylip-3.698-makefile.patch
@@ -0,0 +1,266 @@
+--- a/src/Makefile.unx
++++ b/src/Makefile.unx
+@@ -81,7 +81,6 @@
+ #CC = cc
+ #
+ # To use GCC instead:
+-CC = gcc
+ #
+ # ----------------------------------------------------------------------------
+ #
+@@ -91,7 +90,6 @@
+ #
+ #
+ #A minimal one
+-CFLAGS =
+ #
+ # A basic one for debugging
+ #CFLAGS = -g
+@@ -220,7 +218,7 @@
+ @echo "Done."
+ @echo ""
+
+-put:
++put: all
+ @echo "Installing PHYLIP v3.6 binaries in $(EXEDIR)"
+ @mkdir -p $(EXEDIR)
+ @cp $(PROGS) $(EXEDIR)
+@@ -270,195 +268,195 @@
+ clique.o: clique.c disc.h phylip.h
+
+ clique: clique.o disc.o phylip.o
+- $(CC) $(CFLAGS) clique.o disc.o phylip.o $(LIBS) -o clique
++ $(CC) $(LDFLAGS) clique.o disc.o phylip.o $(LIBS) -o clique
+
+ cons.o: cons.c cons.h phylip.h
+
+ consense.o: consense.c cons.h phylip.h
+
+ consense: consense.o phylip.o cons.o
+- $(CC) $(CFLAGS) consense.o phylip.o cons.o $(LIBS) -o consense
++ $(CC) $(LDFLAGS) consense.o phylip.o cons.o $(LIBS) -o consense
+
+ contml.o: contml.c cont.h phylip.h
+
+ contml: contml.o cont.o phylip.o
+- $(CC) $(CFLAGS) contml.o cont.o phylip.o $(LIBS) -o contml
++ $(CC) $(LDFLAGS) contml.o cont.o phylip.o $(LIBS) -o contml
+
+ contrast.o: contrast.c cont.h phylip.h
+
+ contrast: contrast.o cont.o phylip.o
+- $(CC) $(CFLAGS) contrast.o cont.o phylip.o $(LIBS) -o contrast
++ $(CC) $(LDFLAGS) contrast.o cont.o phylip.o $(LIBS) -o contrast
+
+ dnacomp.o: dnacomp.c seq.h phylip.h
+
+ dnacomp: dnacomp.o seq.o phylip.o
+- $(CC) $(CFLAGS) dnacomp.o seq.o phylip.o $(LIBS) -o dnacomp
++ $(CC) $(LDFLAGS) dnacomp.o seq.o phylip.o $(LIBS) -o dnacomp
+
+ dnadist.o: dnadist.c seq.h phylip.h
+
+ dnadist: dnadist.o seq.o phylip.o
+- $(CC) $(CFLAGS) dnadist.o seq.o phylip.o $(LIBS) -o dnadist
++ $(CC) $(LDFLAGS) dnadist.o seq.o phylip.o $(LIBS) -o dnadist
+
+ dnainvar.o: dnainvar.c seq.h phylip.h
+
+ dnainvar: dnainvar.o seq.o phylip.o
+- $(CC) $(CFLAGS) dnainvar.o seq.o phylip.o $(LIBS) -o dnainvar
++ $(CC) $(LDFLAGS) dnainvar.o seq.o phylip.o $(LIBS) -o dnainvar
+
+ dnaml.o: dnaml.c seq.h phylip.h
+
+ dnaml: dnaml.o seq.o phylip.o
+- $(CC) $(CFLAGS) dnaml.o seq.o phylip.o $(LIBS) -o dnaml
++ $(CC) $(LDFLAGS) dnaml.o seq.o phylip.o $(LIBS) -o dnaml
+
+ dnamlk.o: dnamlk.c seq.h phylip.h mlclock.h printree.h
+
+ dnamlk: dnamlk.o seq.o phylip.o mlclock.o printree.o
+- $(CC) $(CFLAGS) dnamlk.o seq.o phylip.o mlclock.o printree.o $(LIBS) -o dnamlk
++ $(CC) $(LDFLAGS) dnamlk.o seq.o phylip.o mlclock.o printree.o $(LIBS) -o dnamlk
+
+ dnamove.o: dnamove.c seq.h moves.h phylip.h
+
+ dnamove: dnamove.o seq.o moves.o phylip.o
+- $(CC) $(CFLAGS) dnamove.o seq.o moves.o phylip.o $(LIBS) -o dnamove
++ $(CC) $(LDFLAGS) dnamove.o seq.o moves.o phylip.o $(LIBS) -o dnamove
+
+ dnapenny.o: dnapenny.c seq.h phylip.h
+
+ dnapenny: dnapenny.o seq.o phylip.o
+- $(CC) $(CFLAGS) dnapenny.o seq.o phylip.o $(LIBS) -o dnapenny
++ $(CC) $(LDFLAGS) dnapenny.o seq.o phylip.o $(LIBS) -o dnapenny
+
+ dnapars.o: dnapars.c seq.h phylip.h
+
+ dnapars: dnapars.o seq.o phylip.o
+- $(CC) $(CFLAGS) dnapars.o seq.o phylip.o $(LIBS) -o dnapars
++ $(CC) $(LDFLAGS) dnapars.o seq.o phylip.o $(LIBS) -o dnapars
+
+ dolmove.o: dolmove.c disc.h moves.h dollo.h phylip.h
+
+ dolmove: dolmove.o disc.o moves.o dollo.o phylip.o
+- $(CC) $(CFLAGS) dolmove.o disc.o moves.o dollo.o phylip.o $(LIBS) -o dolmove
++ $(CC) $(LDFLAGS) dolmove.o disc.o moves.o dollo.o phylip.o $(LIBS) -o dolmove
+
+ dollop.o: dollop.c disc.h dollo.h phylip.h
+
+ dollop: dollop.o disc.o dollo.o phylip.o
+- $(CC) $(CFLAGS) dollop.o disc.o dollo.o phylip.o $(LIBS) -o dollop
++ $(CC) $(LDFLAGS) dollop.o disc.o dollo.o phylip.o $(LIBS) -o dollop
+
+ dolpenny.o: dolpenny.c disc.h dollo.h phylip.h
+
+ dolpenny: dolpenny.o disc.o dollo.o phylip.o
+- $(CC) $(CFLAGS) dolpenny.o disc.o dollo.o phylip.o $(LIBS) -o dolpenny
++ $(CC) $(LDFLAGS) dolpenny.o disc.o dollo.o phylip.o $(LIBS) -o dolpenny
+
+ draw.o: draw.c draw.h phylip.h
+- $(CC) $(DFLAGS) -c draw.c
++ $(CC) $(DFLAGS) $(CPPFLAGS) -c draw.c
+
+ draw2.o: draw2.c draw.h phylip.h
+- $(CC) $(DFLAGS) -c draw2.c
++ $(CC) $(DFLAGS) $(CPPFLAGS) -c draw2.c
+
+ drawgram.o: drawgram.c draw.h phylip.h
+- $(CC) $(DFLAGS) -c drawgram.c
++ $(CC) $(DFLAGS) $(CPPFLAGS) -c drawgram.c
+
+ drawgram: drawgram.o draw.o draw2.o phylip.o
+- $(CC) $(DFLAGS) draw.o draw2.o drawgram.o phylip.o $(DLIBS) -o drawgram
++ $(CC) $(LDFLAGS) draw.o draw2.o drawgram.o phylip.o $(DLIBS) -o drawgram
+
+ # needed by java
+-libdrawgram.so: drawgram.o draw.o draw2.o phylip.o
+- $(CC) $(CFLAGS) -o libdrawgram.so -shared -fPIC drawgram.c draw.c draw2.c phylip.c $(CLIBS)
++libdrawgram.so:
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o libdrawgram.so -Wl,-soname,libdrawgram.so -shared -fPIC drawgram.c draw.c draw2.c phylip.c $(CLIBS)
+
+ drawtree.o: drawtree.c draw.h phylip.h
+- $(CC) $(DFLAGS) -shared -fPIC -c drawtree.c
++ $(CC) $(DFLAGS) $(CPPFLAGS) -c drawtree.c
+
+ drawtree: drawtree.o draw.o draw2.o phylip.o
+- $(CC) $(DFLAGS) draw.o draw2.o drawtree.o phylip.o $(DLIBS) -o drawtree
++ $(CC) $(LDFLAGS) draw.o draw2.o drawtree.o phylip.o $(DLIBS) -o drawtree
+
+ # needed by java
+-libdrawtree.so: drawtree.o draw.o draw2.o phylip.o
+- $(CC) $(CFLAGS) -o libdrawtree.so -shared -fPIC drawtree.c draw.c draw2.c phylip.c $(CLIBS)
++libdrawtree.so:
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o libdrawtree.so -Wl,-soname,libdrawtree.so -shared -fPIC drawtree.c draw.c draw2.c phylip.c $(CLIBS)
+
+ factor.o: factor.c phylip.h
+
+ factor: factor.o phylip.o
+- $(CC) $(CFLAGS) factor.o phylip.o $(LIBS) -o factor
++ $(CC) $(LDFLAGS) factor.o phylip.o $(LIBS) -o factor
+
+ fitch.o: fitch.c dist.h phylip.h
+
+ fitch: fitch.o dist.o phylip.o
+- $(CC) $(CFLAGS) fitch.o dist.o phylip.o $(LIBS) -o fitch
++ $(CC) $(LDFLAGS) fitch.o dist.o phylip.o $(LIBS) -o fitch
+
+ gendist.o: gendist.c phylip.h
+
+ gendist: gendist.o phylip.o
+- $(CC) $(CFLAGS) gendist.o phylip.o $(LIBS) -o gendist
++ $(CC) $(LDFLAGS) gendist.o phylip.o $(LIBS) -o gendist
+
+ kitsch.o: kitsch.c dist.h phylip.h
+
+ kitsch: kitsch.o dist.o phylip.o
+- $(CC) $(CFLAGS) kitsch.o dist.o phylip.o $(LIBS) -o kitsch
++ $(CC) $(LDFLAGS) kitsch.o dist.o phylip.o $(LIBS) -o kitsch
+
+ mix.o: mix.c disc.h wagner.h phylip.h
+
+ mix: mix.o disc.o wagner.o phylip.o
+- $(CC) $(CFLAGS) mix.o disc.o wagner.o phylip.o $(LIBS) -o mix
++ $(CC) $(LDFLAGS) mix.o disc.o wagner.o phylip.o $(LIBS) -o mix
+
+ move.o: move.c disc.h moves.h wagner.h phylip.h
+
+ move: move.o disc.o moves.o wagner.o phylip.o
+- $(CC) $(CFLAGS) move.o disc.o moves.o wagner.o phylip.o $(LIBS) -o move
++ $(CC) $(LDFLAGS) move.o disc.o moves.o wagner.o phylip.o $(LIBS) -o move
+
+ neighbor.o: neighbor.c dist.h phylip.h
+
+ neighbor: neighbor.o dist.o phylip.o
+- $(CC) $(CFLAGS) neighbor.o dist.o phylip.o $(LIBS) -o neighbor
++ $(CC) $(LDFLAGS) neighbor.o dist.o phylip.o $(LIBS) -o neighbor
+
+ pars.o: pars.c discrete.h phylip.h
+
+ pars: pars.o discrete.o phylip.o
+- $(CC) $(CFLAGS) pars.o discrete.o phylip.o $(LIBS) -o pars
++ $(CC) $(LDFLAGS) pars.o discrete.o phylip.o $(LIBS) -o pars
+
+ penny.o: penny.c disc.h wagner.h phylip.h
+
+ penny: penny.o disc.o wagner.o phylip.o
+- $(CC) $(CFLAGS) penny.o disc.o wagner.o phylip.o $(LIBS) -o penny
++ $(CC) $(LDFLAGS) penny.o disc.o wagner.o phylip.o $(LIBS) -o penny
+
+ proml.o: proml.c seq.h phylip.h
+
+ proml: proml.o seq.o phylip.o
+- $(CC) $(CFLAGS) proml.o seq.o phylip.o $(LIBS) -o proml
++ $(CC) $(LDFLAGS) proml.o seq.o phylip.o $(LIBS) -o proml
+
+ promlk.o: promlk.c seq.h phylip.h mlclock.h printree.h
+
+ promlk: promlk.o seq.o phylip.o mlclock.o printree.o
+- $(CC) $(CFLAGS) promlk.o seq.o phylip.o mlclock.o printree.o $(LIBS) -o promlk
++ $(CC) $(LDFLAGS) promlk.o seq.o phylip.o mlclock.o printree.o $(LIBS) -o promlk
+
+ protdist.o: protdist.c seq.h phylip.h
+
+ protdist: protdist.o seq.o phylip.o
+- $(CC) $(CFLAGS) protdist.o seq.o phylip.o $(LIBS) -o protdist
++ $(CC) $(LDFLAGS) protdist.o seq.o phylip.o $(LIBS) -o protdist
+
+ protpars.o: protpars.c seq.h phylip.h
+
+ protpars: protpars.o seq.o phylip.o
+- $(CC) $(CFLAGS) protpars.o seq.o phylip.o $(LIBS) -o protpars
++ $(CC) $(LDFLAGS) protpars.o seq.o phylip.o $(LIBS) -o protpars
+
+ restdist.o: restdist.c seq.h phylip.h
+
+ restdist: restdist.o seq.o phylip.o
+- $(CC) $(CFLAGS) restdist.o seq.o phylip.o $(LIBS) -o restdist
++ $(CC) $(LDFLAGS) restdist.o seq.o phylip.o $(LIBS) -o restdist
+
+ restml.o: restml.c seq.h phylip.h
+
+ restml: restml.o seq.o phylip.o
+- $(CC) $(CFLAGS) restml.o seq.o phylip.o $(LIBS) -o restml
++ $(CC) $(LDFLAGS) restml.o seq.o phylip.o $(LIBS) -o restml
+
+ retree.o: retree.c moves.h phylip.h
+
+ retree: retree.o moves.o phylip.o
+- $(CC) $(CFLAGS) retree.o moves.o phylip.o $(LIBS) -o retree
++ $(CC) $(LDFLAGS) retree.o moves.o phylip.o $(LIBS) -o retree
+
+ seqboot.o: seqboot.c phylip.h
+
+ seqboot: seqboot.o seq.o phylip.o
+- $(CC) $(CFLAGS) seqboot.o seq.o phylip.o $(LIBS) -o seqboot
++ $(CC) $(LDFLAGS) seqboot.o seq.o phylip.o $(LIBS) -o seqboot
+
+ treedist.o: treedist.c cons.h phylip.h
+
+ treedist: treedist.o phylip.o cons.o
+- $(CC) $(CFLAGS) treedist.o cons.o phylip.o $(LIBS) -o treedist
++ $(CC) $(LDFLAGS) treedist.o cons.o phylip.o $(LIBS) -o treedist
+
+
+ # ----------------------------------------------------------------------------
diff --git a/sci-biology/phylip/phylip-3.698.ebuild b/sci-biology/phylip/phylip-3.698.ebuild
new file mode 100644
index 000000000000..0a8ef8f815ec
--- /dev/null
+++ b/sci-biology/phylip/phylip-3.698.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION=" The PHYLogeny Inference Package"
+HOMEPAGE="http://evolution.genetics.washington.edu/phylip.html"
+SRC_URI="http://evolution.gs.washington.edu/${PN}/download/${P}.zip"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+# 'mix' tool collides with dev-lang/elixir, bug #537514
+RDEPEND="
+ x11-libs/libXaw
+ !dev-lang/elixir"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="app-arch/unzip"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_prepare() {
+ default
+
+ mkdir fonts || die
+ # clear out old binaries
+ rm -r exe || die
+}
+
+src_configure() {
+ tc-export CC
+ append-cflags -Wno-unused-result
+}
+
+src_compile() {
+ emake -C src -f Makefile.unx all put
+}
+
+src_install() {
+ mv exe/font* fonts || die "Font move failed"
+ mv exe/factor exe/factor-${PN} || die "Renaming factor failed"
+
+ dolib.so exe/*so
+ rm exe/*so || die
+ dobin exe/*
+
+ dodoc "${FILESDIR}"/README.Gentoo
+ docinto html
+ dodoc -r phylip.html doc
+
+ insinto /usr/share/phylip
+ doins -r fonts
+}