summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-03 18:54:26 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-03 18:54:26 +0200
commitfbdda699ffc5db18d5dc0b5e2c59cf511dec93b5 (patch)
treedd0479f419d7eafafacd27d5eb06110140d88fb2 /sci-biology
parentsci-biology/samtools: Bump to version 1.10 (diff)
downloadgentoo-fbdda699ffc5db18d5dc0b5e2c59cf511dec93b5.tar.gz
gentoo-fbdda699ffc5db18d5dc0b5e2c59cf511dec93b5.tar.bz2
gentoo-fbdda699ffc5db18d5dc0b5e2c59cf511dec93b5.zip
sci-biology/bcftools: Bump to version 1.10.2
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/bcftools/Manifest1
-rw-r--r--sci-biology/bcftools/bcftools-1.10.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sci-biology/bcftools/Manifest b/sci-biology/bcftools/Manifest
index eef8daed7a75..508a5c41fe37 100644
--- a/sci-biology/bcftools/Manifest
+++ b/sci-biology/bcftools/Manifest
@@ -1,2 +1,3 @@
+DIST bcftools-1.10.2.tar.bz2 3702679 BLAKE2B 51acce94d463868562199206504dc8afb50c671c11139c5a96f52cedf135bb7a46115c69411b9943b970a2395e3c866275c85e345a4a40a90194d1094698314e SHA512 f07e405efa16b9b1b18521342df3eaf840ed1b3028b736a6b4d139012ea85769ddfb3cd3a2c94958415d984d07805dfcd3d4bbec0db401b3f071b861a56d1300
DIST bcftools-1.5.tar.bz2 2975685 BLAKE2B 937b7db770dcaddafbd00b67c3b88501a3190564b2ca629b83e52b48b414a604dd203cd067e357e2b7d02c700387576fca458d1cab2982dafa3b2c215b528722 SHA512 66b8bc61b9fbb381679a6781f77a18f66e8105567992da011413bc573d99b619558a1cf58e9e1373ae347a8b81638dd91977802a07a4578ddc9c61fb53403233
DIST bcftools-1.9.tar.bz2 3134355 BLAKE2B dd551b509b1ee554f70be9da28a6eaf81dfcec43fc0d1aa972d64ef846f9db47f39177345e8c1ca754d11defb9c0823976ae94d6b3e7cd99313eed4f381182ed SHA512 fd662fb0d214eb75ac04fc4494e8dbaca84d10698ca14801427341def6a5df4af99e7bd4cd873da5422ae921deb49b940cedb926da356b1eabfac525a38f806c
diff --git a/sci-biology/bcftools/bcftools-1.10.2.ebuild b/sci-biology/bcftools/bcftools-1.10.2.ebuild
new file mode 100644
index 000000000000..179f7dea77e4
--- /dev/null
+++ b/sci-biology/bcftools/bcftools-1.10.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit python-single-r1
+
+DESCRIPTION="Utilities for variant calling and manipulating VCF and BCF files"
+HOMEPAGE="http://www.htslib.org"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-lang/perl
+ $(python_gen_cond_dep '
+ dev-python/matplotlib[${PYTHON_MULTI_USEDEP}]
+ ')
+ =sci-libs/htslib-${PV}*:=
+ sys-libs/zlib:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ python_fix_shebang misc/{guess-ploidy,plot-roh}.py
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --disable-bcftools-plugins \
+ --disable-libgsl \
+ --with-htslib=system
+}