summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-11-01 20:57:12 +0100
committerJeroen Roovers <jer@gentoo.org>2017-11-01 20:57:33 +0100
commit34dfafc5204a4c15ccb7f36d3de2567f4b3aac29 (patch)
treeba5f3b0a4de2c44567eaf8e9c8961b818e536498 /sci-calculators/units/units-2.16.ebuild
parentmedia-plugins/gst-plugins-meta: stable 1.12.3 for ppc64, bug #635900 (diff)
downloadgentoo-34dfafc5204a4c15ccb7f36d3de2567f4b3aac29.tar.gz
gentoo-34dfafc5204a4c15ccb7f36d3de2567f4b3aac29.tar.bz2
gentoo-34dfafc5204a4c15ccb7f36d3de2567f4b3aac29.zip
sci-calculators/units: Version bump.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'sci-calculators/units/units-2.16.ebuild')
-rw-r--r--sci-calculators/units/units-2.16.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sci-calculators/units/units-2.16.ebuild b/sci-calculators/units/units-2.16.ebuild
new file mode 100644
index 000000000000..052a0fabba92
--- /dev/null
+++ b/sci-calculators/units/units-2.16.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit eutils python-single-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units_cur"
+REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ sys-libs/readline:=
+ units_cur? (
+ ${PYTHON_DEPS}
+ dev-python/future[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+pkg_setup() {
+ use units_cur && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf ac_cv_path_PYTHON=no
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog NEWS README
+
+ # we're intentionally delaying this since 'make install' would
+ # get confused if we shove 'units_cur' there, and there is no real
+ # need to add more complexity for it
+ if use units_cur; then
+ sed \
+ -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
+ -e 's|^#!|&/usr/bin/python|g' \
+ units_cur_inst > units_cur || die
+ python_fix_shebang units_cur
+ python_doscript units_cur
+ fi
+}