summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-calculators/units
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-calculators/units')
-rw-r--r--sci-calculators/units/Manifest2
-rw-r--r--sci-calculators/units/metadata.xml11
-rw-r--r--sci-calculators/units/units-2.11.ebuild61
-rw-r--r--sci-calculators/units/units-2.11a.ebuild61
4 files changed, 135 insertions, 0 deletions
diff --git a/sci-calculators/units/Manifest b/sci-calculators/units/Manifest
new file mode 100644
index 000000000000..4acd6bebf414
--- /dev/null
+++ b/sci-calculators/units/Manifest
@@ -0,0 +1,2 @@
+DIST units-2.11.tar.gz 861772 SHA256 53b6daf2a03d9a060449944b0a6c1aca0d18a84d1d9a93098e4a8920181f5abe SHA512 83e062a0daf9541454cdcaa4efe03bf9f03afdcfdbe2013d5e913a53e1b5e37ef846a3129185898ad2d25e3ea632533f8eb8d89681c855b19a3998aca6e733ce WHIRLPOOL 4c405e0a81af2b02d05156225c26573631ddb02d323d160b0850fcfda52b4a84a36f3ddbfdc732aa8a9dc06c8fc59a41141f985d6025ea6cb18b87749b78d500
+DIST units-2.11a.tar.gz 865120 SHA256 cdc1ef5adf0701f9bf0f9e3c890cd832554e5bf3f078dab852e5a6783e525b8b SHA512 d942194b73a4d920d711bdcf07481aefff8fc1403f47ca73c1c0fd9837cb7c385a45f326d9537ba1aa77283c4f812be346a1b5ac15ca1e508c268857cc9d78db WHIRLPOOL 72efc473f9105796bdbdc92e2e355a0a2c8ede0ae5febbc017a112b6524e6ad9081a581cc22666ed4e7e74a87bf1b8d45e3a262df53358cbe32107edbe4b6230
diff --git a/sci-calculators/units/metadata.xml b/sci-calculators/units/metadata.xml
new file mode 100644
index 000000000000..d9728cf1d724
--- /dev/null
+++ b/sci-calculators/units/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>jer@gentoo.org</email>
+<name>Jeroen Roovers</name>
+</maintainer>
+<use>
+<flag name='units_cur'>Install the units_cur python script that updates currencies</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-calculators/units/units-2.11.ebuild b/sci-calculators/units/units-2.11.ebuild
new file mode 100644
index 000000000000..195064807337
--- /dev/null
+++ b/sci-calculators/units/units-2.11.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="xml"
+inherit eutils python-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="http://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ppc sparc x86 ~amd64-linux ~x86-linux"
+IUSE="+units_cur"
+
+DEPEND="
+ >=sys-libs/readline-4.1-r2
+ units_cur? (
+ dev-lang/python-exec:2
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ units_cur? (
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+"
+
+DOCS=( ChangeLog NEWS README )
+
+units_cur_prepare() {
+ local UNITS_PYTHON_MAJOR
+ UNITS_PYTHON_MAJOR=$(
+ UNITS_PYTHON_MAJOR=${EPYTHON/.*}
+ shopt -s extglob
+ echo ${UNITS_PYTHON_MAJOR/*([[:alpha:]])}
+ )
+ sed -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" units_cur${UNITS_PYTHON_MAJOR} > units_cur-${EPYTHON}
+}
+
+src_prepare() {
+ use units_cur && python_foreach_impl units_cur_prepare
+}
+
+src_compile() {
+ emake HAVE_PYTHON=no
+}
+
+units_cur_install() {
+ python_newexe units_cur-${EPYTHON} units_cur
+}
+
+src_install() {
+ emake DESTDIR="${D}" HAVE_PYTHON=no install
+
+ use units_cur && python_foreach_impl units_cur_install
+}
diff --git a/sci-calculators/units/units-2.11a.ebuild b/sci-calculators/units/units-2.11a.ebuild
new file mode 100644
index 000000000000..1fcb59208e70
--- /dev/null
+++ b/sci-calculators/units/units-2.11a.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="xml"
+inherit eutils python-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="http://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu-alpha/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units_cur"
+
+DEPEND="
+ >=sys-libs/readline-4.1-r2
+ units_cur? (
+ dev-lang/python-exec:2
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ units_cur? (
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+"
+
+DOCS=( ChangeLog NEWS README )
+
+units_cur_prepare() {
+ local UNITS_PYTHON_MAJOR
+ UNITS_PYTHON_MAJOR=$(
+ UNITS_PYTHON_MAJOR=${EPYTHON/.*}
+ shopt -s extglob
+ echo ${UNITS_PYTHON_MAJOR/*([[:alpha:]])}
+ )
+ sed -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" units_cur${UNITS_PYTHON_MAJOR} > units_cur-${EPYTHON}
+}
+
+src_prepare() {
+ use units_cur && python_foreach_impl units_cur_prepare
+}
+
+src_compile() {
+ emake HAVE_PYTHON=no
+}
+
+units_cur_install() {
+ python_newexe units_cur-${EPYTHON} units_cur
+}
+
+src_install() {
+ emake DESTDIR="${D}" HAVE_PYTHON=no install
+
+ use units_cur && python_foreach_impl units_cur_install
+}