summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 04:34:48 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:48:10 -0400
commit3f4901e8b7585721fae243d46c7aa1e1f0901985 (patch)
tree7a39a5e4703e2288fdb69bce30ec2bd971430362 /sci-calculators
parentnet-misc/x11-ssh-askpass: force gcc -E for imake's generation (diff)
downloadgentoo-3f4901e8b7585721fae243d46c7aa1e1f0901985.tar.gz
gentoo-3f4901e8b7585721fae243d46c7aa1e1f0901985.tar.bz2
gentoo-3f4901e8b7585721fae243d46c7aa1e1f0901985.zip
sci-calculators/hexcalc: EAPI6->8, fix license, drop dead HOMEPAGE
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild (renamed from sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild)35
1 files changed, 21 insertions, 14 deletions
diff --git a/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild b/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild
index c9740ad088e8..e3c78faf52ab 100644
--- a/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild
+++ b/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild
@@ -1,27 +1,34 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
-DESCRIPTION="A simple hex calculator for X"
-HOMEPAGE="ftp://ftp.x.org/R5contrib/"
+DESCRIPTION="Simple hex calculator for X"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="mirror://gentoo/${P}.tar.Z"
+S="${WORKDIR}/${PN}"
-LICENSE="GPL-2"
+LICENSE="HPND"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-RDEPEND="x11-libs/libXaw"
-DEPEND="${RDEPEND}
- >=x11-misc/imake-1.0.8-r1
- app-text/rman"
-
-S=${WORKDIR}/${PN}
-
-PATCHES=( "${FILESDIR}"/${PN}-{keypad,order}.diff )
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXt"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ app-text/rman
+ >=x11-misc/imake-1.0.8-r1"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-keypad.diff
+ "${FILESDIR}"/${PN}-order.diff
+)
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \