summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 04:26:00 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 04:56:02 -0400
commitcb1572313ce54913b44c5849bbed23de33d94e10 (patch)
tree72b5ee78a124b0fdada8b793adebd11fce301692 /sci-calculators
parentnet-misc/vncrec: pass -std=gnu89, fixup previous clang fix (diff)
downloadgentoo-cb1572313ce54913b44c5849bbed23de33d94e10.tar.gz
gentoo-cb1572313ce54913b44c5849bbed23de33d94e10.tar.bz2
gentoo-cb1572313ce54913b44c5849bbed23de33d94e10.zip
sci-calculators/hexcalc: pass -std=gnu89
Does not build with `clang -std=c2x`, early workaround for when this will become a default. (not actively hunting for these, merely revisiting packages previously looked at for clang16 even if not an issue "yet"). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild b/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild
index 20e117cd6853..729630099a29 100644
--- a/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild
+++ b/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Simple hex calculator for X"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
@@ -32,6 +32,8 @@ PATCHES=(
)
src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}