summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGavin D. Howard <gavin@gavinhoward.com>2023-06-03 20:46:27 -0600
committerSam James <sam@gentoo.org>2023-06-04 04:46:35 +0100
commitf68b2fb3d494b4c8a39fcbaba0c95bccd0bddb39 (patch)
tree51c75cfa53744992f8610c1aa0affc5db3dd1bec /sci-calculators
parentsci-calculators/bc-gh: add 6.6.0 (diff)
downloadgentoo-f68b2fb3d494b4c8a39fcbaba0c95bccd0bddb39.tar.gz
gentoo-f68b2fb3d494b4c8a39fcbaba0c95bccd0bddb39.tar.bz2
gentoo-f68b2fb3d494b4c8a39fcbaba0c95bccd0bddb39.zip
sci-calculators/bc-gh: drop 6.4.0
Signed-off-by: Gavin D. Howard <gavin@gavinhoward.com> Closes: https://github.com/gentoo/gentoo/pull/31296 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/bc-gh/Manifest1
-rw-r--r--sci-calculators/bc-gh/bc-gh-6.4.0.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/sci-calculators/bc-gh/Manifest b/sci-calculators/bc-gh/Manifest
index fc9156a19ec7..b175ff439d06 100644
--- a/sci-calculators/bc-gh/Manifest
+++ b/sci-calculators/bc-gh/Manifest
@@ -1,4 +1,3 @@
DIST bc-6.1.1.tar.xz 455456 BLAKE2B 7945ac623740abd9cbd894c20b8a03006caf64d2ce9770ade930d912c52b4e29b107b524d4a95ebea99e31921b7940e39e1afdeec837b4a03d3ed4e11b9f517b SHA512 0e7fb4d4223ace8ba5c1961cc0d7eba475174f92b75529fde64446b5d80db5729f848fd95507570711d2b8928996c87e837e926d31028f32e3f97cad47567d39
-DIST bc-6.4.0.tar.xz 460460 BLAKE2B 91d70f3907fde6d3c97c37872d57ac67e98990ab1e37324801a95184d7961002b68f2b6904520ab4c77c45a571c369fb0a6455553bb3db79553e01aece28e212 SHA512 6c7a86c534214e765e3890dffe77fb85ddf0764cde0c6ceb0385cce7de4c0d2db0815faf6bcf161fad75591461c346811a61c42c5eced7c3d84fe5b7eb719b60
DIST bc-6.5.0.tar.xz 461380 BLAKE2B e4aa633162d03fc5723e967ba81f985ab1b16e47b3c9a3ca1c32e9a717db682ce88cc6ba453d5e9b09539dcb8ddbb258b7b7dbdd2e27279355e3c35028d56130 SHA512 1cb03038d828a0b10734c29931777add8b22f194c507b8ff538ec1aa52a2a97a4ac2733d72cdb0710fdc6937807074e929f7918c56aaf5be8fbe908ea7c5a401
DIST bc-6.6.0.tar.xz 465272 BLAKE2B 489f6e20a06f2903421a2c8ba7249f52a52dadfd354de920bac098c6181d79e944c696aa787a143d72a12af1c1893b7b48341cf6e6c4003ceace88812dc72c96 SHA512 5d8e32a7e8bf34d36919f9ab4a84d410747bcaf66d8846c536e41b8a447fe0066d8b0de5a10011d77d50a880290423bae6dea1404f01edf6dfd5247d41ca19a0
diff --git a/sci-calculators/bc-gh/bc-gh-6.4.0.ebuild b/sci-calculators/bc-gh/bc-gh-6.4.0.ebuild
deleted file mode 100644
index 7b4e6bc4cbf5..000000000000
--- a/sci-calculators/bc-gh/bc-gh-6.4.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MY_P="bc-${PV}"
-DESCRIPTION="Implementation of POSIX bc with GNU extensions"
-HOMEPAGE="
- https://git.gavinhoward.com/gavin/bc/
- https://github.com/gavinhoward/bc/
-"
-SRC_URI="
- https://github.com/gavinhoward/bc/releases/download/${PV}/${MY_P}.tar.xz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="libedit readline"
-
-DEPEND="
- !readline? (
- libedit? ( dev-libs/libedit:= )
- )
- readline? (
- sys-libs/readline:=
- sys-libs/ncurses:=
- )
-"
-RDEPEND="
- ${DEPEND}
-"
-
-src_configure() {
- local myconf=(
- # GNU and BSD bc's have slightly different behavior. This bc can act
- # like both, changing at runtime with environment variables, but it
- # needs defaults, which can be set at compile time. This option sets all
- # of the defaults to match the GNU bc/dc since it's common on Linux.
- -pGNU
- # A lot of test results are generated first by a bc compatible with the
- # GNU bc. If there is no GNU bc installed, then those tests should be
- # skipped. That's what this option does. Without it, we would have a
- # dependency cycle. Those tests are super long, anyway.
- -G
- # Disables the automatic stripping of binaries.
- -T
- # Enables installing all locales, which is important for packages.
- -l
- # Disables some "problematic" tests that need specific options on Linux
- # to not trigger the OOM killer because malloc() lies.
- -P
- )
- if use readline ; then
- myconf+=( -r )
- elif use libedit ; then
- myconf+=( -e )
- fi
-
- local -x EXECSUFFIX="-gh"
- local -x PREFIX="${EPREFIX}/usr"
- ./configure.sh "${myconf[@]}" || die
-}
-
-src_test() {
- # This is to fix a bug encountered on Arch. It is to ensure we don't get
- # segfaults on `make check` when the error messages change because the error
- # messages are passed to printf(); they have format specifiers. With these
- # env vars, the internal error messages are used, instead of the installed
- # locales, which might be different since the new locale files are not
- # installed yet. (It is impossible to use uninstalled locales because of the
- # poor design of POSIX locales.)
- env LANG=C LC_ALL=C emake check
-}