summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-12 01:31:05 +0100
committerSam James <sam@gentoo.org>2021-04-12 02:07:34 +0100
commit939a776774f2cfa7bc4d817c4e0353920280db70 (patch)
tree8c35b1ded5c88c662e8cec45c15ac39e5d09a350 /sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.0-r1.ebuild
parentmedia-libs/libcddb: fix DEPEND typo (diff)
downloadgentoo-939a776774f2cfa7bc4d817c4e0353920280db70.tar.gz
gentoo-939a776774f2cfa7bc4d817c4e0353920280db70.tar.bz2
gentoo-939a776774f2cfa7bc4d817c4e0353920280db70.zip
sci-chemistry/GromacsWrapper: fix RDEPEND typo
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.0-r1.ebuild')
-rw-r--r--sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.0-r1.ebuild b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..593677d31290
--- /dev/null
+++ b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_7 )
+
+if [[ ${PV} = *9999* ]]; then
+ scm_eclass=git-r3
+ EGIT_REPO_URI="https://github.com/Becksteinlab/${PN}.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+else
+ scm_eclass=vcs-snapshot
+ SRC_URI="https://github.com/Becksteinlab/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit eutils distutils-r1 ${scm_eclass}
+
+DESCRIPTION="Python framework for Gromacs"
+HOMEPAGE="https://gromacswrapper.readthedocs.io"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-libs/numkit[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( >=dev-python/pandas-0.17[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/Becksteinlab/GromacsWrapper/issues/182
+ "${FILESDIR}"/${P}-tests-package.patch
+)