summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/PyMca
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/PyMca')
-rw-r--r--sci-chemistry/PyMca/Manifest1
-rw-r--r--sci-chemistry/PyMca/PyMca-4.6.2-r1.ebuild41
-rw-r--r--sci-chemistry/PyMca/PyMca-4.6.2.ebuild43
-rw-r--r--sci-chemistry/PyMca/files/4.4.1_p1-gentoo.patch40
-rw-r--r--sci-chemistry/PyMca/files/4.4.1_p1-impl-dec.patch12
-rw-r--r--sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch16
-rw-r--r--sci-chemistry/PyMca/metadata.xml22
7 files changed, 175 insertions, 0 deletions
diff --git a/sci-chemistry/PyMca/Manifest b/sci-chemistry/PyMca/Manifest
new file mode 100644
index 000000000000..c6899e234b21
--- /dev/null
+++ b/sci-chemistry/PyMca/Manifest
@@ -0,0 +1 @@
+DIST pymca4.6.2-src.tgz 15979581 SHA256 c50d3a54cad633bac3ec361d1b3b63a78292f1ad4ed976e5206665edd76bc32d SHA512 e33188b446c399e50cf65ebca4bfeef34e1b7d99c331f670dc41ca204284fbba996a1c83bd12a2410a9972927aa9c92b42b5374c58c924b3a8583d4f37be6528 WHIRLPOOL 47f0491aa0e470661bea1aa247d1db730f1db7266f1d2be2272d08f203faa2a084bcb40d579861365ace26d2f94abe03485183eed03139ad7b697cf57bfa5324
diff --git a/sci-chemistry/PyMca/PyMca-4.6.2-r1.ebuild b/sci-chemistry/PyMca/PyMca-4.6.2-r1.ebuild
new file mode 100644
index 000000000000..449f9b5ab220
--- /dev/null
+++ b/sci-chemistry/PyMca/PyMca-4.6.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PV="${PV/_}"
+
+DESCRIPTION="X-ray Fluorescence Toolkit"
+HOMEPAGE="http://pymca.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/pymca/pymca/${PN}${PV/_p1}/pymca${MY_PV}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="X hdf5 matplotlib"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/sip[${PYTHON_USEDEP}]
+ virtual/opengl
+ X? (
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/pyqwt[${PYTHON_USEDEP}]
+ )
+ hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+#S="${WORKDIR}/${PN}${MY_PV}"
+
+python_prepare_all() {
+ local PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+ export SPECFILE_USE_GNU_SOURCE=1
+ distutils-r1_python_prepare_all
+}
diff --git a/sci-chemistry/PyMca/PyMca-4.6.2.ebuild b/sci-chemistry/PyMca/PyMca-4.6.2.ebuild
new file mode 100644
index 000000000000..b1e6d2f50524
--- /dev/null
+++ b/sci-chemistry/PyMca/PyMca-4.6.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-pypy-*"
+
+inherit distutils eutils
+
+MY_PV="${PV/_}"
+
+DESCRIPTION="X-ray Fluorescence Toolkit"
+HOMEPAGE="http://pymca.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/pymca/pymca/${PN}${PV/_p1}/pymca${MY_PV}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="X hdf5 matplotlib"
+
+DEPEND="
+ dev-python/numpy
+ dev-python/sip
+ virtual/opengl
+ dev-python/pyopengl
+ X? (
+ dev-python/PyQt4
+ dev-python/pyqwt
+ )
+ hdf5? ( dev-python/h5py )
+ matplotlib? ( dev-python/matplotlib )"
+RDEPEND="${DEPEND}"
+
+#S="${WORKDIR}/${PN}${MY_PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ export SPECFILE_USE_GNU_SOURCE=1
+ distutils_src_prepare
+}
diff --git a/sci-chemistry/PyMca/files/4.4.1_p1-gentoo.patch b/sci-chemistry/PyMca/files/4.4.1_p1-gentoo.patch
new file mode 100644
index 000000000000..487a45963d21
--- /dev/null
+++ b/sci-chemistry/PyMca/files/4.4.1_p1-gentoo.patch
@@ -0,0 +1,40 @@
+diff --git a/setup.py b/setup.py
+index 0b0fa58..a4fdab6 100755
+--- a/setup.py
++++ b/setup.py
+@@ -41,34 +41,8 @@ for line in file(os.path.join('PyMca', 'PyMcaMain.py')).readlines():
+ print "PyMca X-Ray Fluorescence Toolkit %s" % __version__
+ print
+
+-print "Type 'L' to view the license."
+-print "Type 'yes' to accept the terms of the license."
+-print "Type 'no' to decline the terms of the license."
+-print
+-
+-while 1:
+- try:
+- resp = raw_input("Do you accept the terms of the license? ")
+- except KeyboardInterrupt:
+- raise SystemExit
+- except:
+- resp = ""
+-
+- resp = string.lower(string.strip(resp))
+-
+- if resp == "yes":
+- break
+-
+- if resp == "no":
+- sys.exit(1)
+-
+- if resp == "l":
+- os.system("more LICENSE.GPL")
+-
+-
+ # Specify all the required PyMca data
+-data_files = [('PyMca', ['LICENSE.GPL',
+- 'PyMca/Scofield1973.dict',
++data_files = [('PyMca', ['PyMca/Scofield1973.dict',
+ 'PyMca/changelog.txt',
+ 'PyMca/McaTheory.cfg',
+ 'PyMca/PyMcaSplashImage.png',
diff --git a/sci-chemistry/PyMca/files/4.4.1_p1-impl-dec.patch b/sci-chemistry/PyMca/files/4.4.1_p1-impl-dec.patch
new file mode 100644
index 000000000000..ea37348066d2
--- /dev/null
+++ b/sci-chemistry/PyMca/files/4.4.1_p1-impl-dec.patch
@@ -0,0 +1,12 @@
+diff --git a/PyMca/specfile/src/sfwrite.c b/PyMca/specfile/src/sfwrite.c
+index 24df907..93c18e9 100755
+--- a/PyMca/specfile/src/sfwrite.c
++++ b/PyMca/specfile/src/sfwrite.c
+@@ -55,6 +55,7 @@
+ */
+ #include <SpecFile.h>
+ #include <SpecFileP.h>
++#include <unistd.h>
+
+ /*
+ * Declarations
diff --git a/sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch b/sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch
new file mode 100644
index 000000000000..81dfaf038fa6
--- /dev/null
+++ b/sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch
@@ -0,0 +1,16 @@
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 0a77cdf..e7ba643 100644
+--- a/setup.py
++++ b/setup.py
+@@ -55,7 +55,7 @@ packages = ['PyMca','PyMca.PyMcaPlugins', 'PyMca.tests']
+ py_modules = []
+
+ # Specify all the required PyMca data
+-data_files = [(PYMCA_DATA_DIR, ['LICENSE.GPL',
++data_files = [(PYMCA_DATA_DIR, [
+ 'PyMca/PyMcaData/Scofield1973.dict',
+ 'changelog.txt',
+ 'PyMca/PyMcaData/McaTheory.cfg',
diff --git a/sci-chemistry/PyMca/metadata.xml b/sci-chemistry/PyMca/metadata.xml
new file mode 100644
index 000000000000..91146f1d585b
--- /dev/null
+++ b/sci-chemistry/PyMca/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+The PyMca Toolkit is a collection of Python tools for visualization and
+analysis of energy-dispersive X-ray fluorescence data. It builds its graphic
+interface and plotting routines on top of the C++ libraries Qt and Qwt
+through their respective Python bindings PyQt and PyQwt. Nevertheless,
+the data analysis routines can be used independently of any graphical
+interface.
+</longdescription>
+ <use>
+ <flag name="matplotlib">Support for plotting through matplotlib</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">pymca</remote-id>
+ </upstream>
+</pkgmetadata>