summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/ccpn/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/ccpn/files')
-rw-r--r--sci-chemistry/ccpn/files/2.3.1-parallel.patch38
-rw-r--r--sci-chemistry/ccpn/files/analysis8
-rw-r--r--sci-chemistry/ccpn/files/dangle8
-rw-r--r--sci-chemistry/ccpn/files/dataShifter8
-rw-r--r--sci-chemistry/ccpn/files/depositionFileImporter8
-rw-r--r--sci-chemistry/ccpn/files/eci8
-rw-r--r--sci-chemistry/ccpn/files/extendNmr8
-rw-r--r--sci-chemistry/ccpn/files/formatConverter8
-rw-r--r--sci-chemistry/ccpn/files/pipe2azara8
-rw-r--r--sci-chemistry/ccpn/files/talosn.patch16
-rw-r--r--sci-chemistry/ccpn/files/xeasy2azara8
11 files changed, 126 insertions, 0 deletions
diff --git a/sci-chemistry/ccpn/files/2.3.1-parallel.patch b/sci-chemistry/ccpn/files/2.3.1-parallel.patch
new file mode 100644
index 000000000000..fcf44707e082
--- /dev/null
+++ b/sci-chemistry/ccpn/files/2.3.1-parallel.patch
@@ -0,0 +1,38 @@
+diff --git a/ccpnmr2.3/c/Makefile b/ccpnmr2.3/c/Makefile
+index 01fb25a..8e8e1fe 100644
+--- a/ccpnmr2.3/c/Makefile
++++ b/ccpnmr2.3/c/Makefile
+@@ -5,22 +5,22 @@ all: compile
+ compile: global structure analysis clouds dynamics bayes
+
+ global:
+- cd memops/global && $(MAKE)
++ $(MAKE) -C memops/global
+
+-structure:
+- cd ccp/structure && $(MAKE)
++structure: global
++ $(MAKE) -C ccp/structure
+
+-analysis:
+- cd ccpnmr/analysis && $(MAKE)
++analysis: global
++ $(MAKE) -C ccpnmr/analysis
+
+-clouds:
+- cd ccpnmr/clouds && $(MAKE)
++clouds: global
++ $(MAKE) -C ccpnmr/clouds
+
+-dynamics:
+- cd ccpnmr/dynamics && $(MAKE)
++dynamics: global
++ $(MAKE) -C ccpnmr/dynamics
+
+-bayes:
+- cd other/cambridge/bayes && $(MAKE)
++bayes: global
++ $(MAKE) -C other/cambridge/bayes
+
+ clean: global_clean structure_clean analysis_clean clouds_clean dynamics_clean bayes_clean
+
diff --git a/sci-chemistry/ccpn/files/analysis b/sci-chemistry/ccpn/files/analysis
new file mode 100644
index 000000000000..828ed4e64ae9
--- /dev/null
+++ b/sci-chemistry/ccpn/files/analysis
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -i -O ${CCPNMR_TOP_DIR}/ccpn/python/ccpnmr/analysis/AnalysisGui.py $1 $2 $3 $4 $5 $6
diff --git a/sci-chemistry/ccpn/files/dangle b/sci-chemistry/ccpn/files/dangle
new file mode 100644
index 000000000000..6d8a42e615de
--- /dev/null
+++ b/sci-chemistry/ccpn/files/dangle
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O ${CCPNMR_TOP_DIR}/ccpn/python/cambridge/dangle/DangleGui.py $1 $2 $3 $4 $5 $6
diff --git a/sci-chemistry/ccpn/files/dataShifter b/sci-chemistry/ccpn/files/dataShifter
new file mode 100644
index 000000000000..c083960f2f60
--- /dev/null
+++ b/sci-chemistry/ccpn/files/dataShifter
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O ${CCPNMR_TOP_DIR}/ccpn/python/ccpnmr/format/gui/DataShifter.py $1 $2 $3 $4 $5 $6
diff --git a/sci-chemistry/ccpn/files/depositionFileImporter b/sci-chemistry/ccpn/files/depositionFileImporter
new file mode 100644
index 000000000000..09505ccc4925
--- /dev/null
+++ b/sci-chemistry/ccpn/files/depositionFileImporter
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O ${CCPNMR_TOP_DIR}/ccpn/python/pdbe/deposition/dataFileImport/dataFileImportGui.py $@
diff --git a/sci-chemistry/ccpn/files/eci b/sci-chemistry/ccpn/files/eci
new file mode 100644
index 000000000000..54d913348718
--- /dev/null
+++ b/sci-chemistry/ccpn/files/eci
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O ${CCPNMR_TOP_DIR}/ccpn/python/ccpnmr/eci/EntryCompletionGui.py $*
diff --git a/sci-chemistry/ccpn/files/extendNmr b/sci-chemistry/ccpn/files/extendNmr
new file mode 100644
index 000000000000..a2fe4c997c7c
--- /dev/null
+++ b/sci-chemistry/ccpn/files/extendNmr
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O -i -O ${CCPNMR_TOP_DIR}/ccpn/python/extendNmr/ExtendNmrGui.py $@
diff --git a/sci-chemistry/ccpn/files/formatConverter b/sci-chemistry/ccpn/files/formatConverter
new file mode 100644
index 000000000000..6cb273612352
--- /dev/null
+++ b/sci-chemistry/ccpn/files/formatConverter
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O ${CCPNMR_TOP_DIR}/ccpn/python/ccpnmr/format/gui/FormatConverter.py $1 $2 $3 $4 $5 $6
diff --git a/sci-chemistry/ccpn/files/pipe2azara b/sci-chemistry/ccpn/files/pipe2azara
new file mode 100644
index 000000000000..5a3710a134a7
--- /dev/null
+++ b/sci-chemistry/ccpn/files/pipe2azara
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O ${CCPNMR_TOP_DIR}/ccpn/python/ccp/format/spectra/params/NmrPipeData.py $1 $2 $3 $4 $5 $6
diff --git a/sci-chemistry/ccpn/files/talosn.patch b/sci-chemistry/ccpn/files/talosn.patch
new file mode 100644
index 000000000000..e19a0ab19783
--- /dev/null
+++ b/sci-chemistry/ccpn/files/talosn.patch
@@ -0,0 +1,16 @@
+ ccpnmr2.3/python/ccpnmr/format/general/Constants.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ccpnmr2.3/python/ccpnmr/format/general/Constants.py b/ccpnmr2.3/python/ccpnmr/format/general/Constants.py
+index d10553e..fb732db 100644
+--- a/ccpnmr2.3/python/ccpnmr/format/general/Constants.py
++++ b/ccpnmr2.3/python/ccpnmr/format/general/Constants.py
+@@ -865,7 +865,7 @@ IoSetupList = [
+ 'cyana': ['dihedrals.aco',1,1, [['SelectionList','version','Cyana version:',['2.0','2.1'],None]],
+ [['SelectionList','version','Cyana version:',['2.0','2.1'],None]]],
+ 'nmrStar': ['nmrStar.str',1,0, [],[]],
+- 'talos': ['dihedral.tab',1,0, [['MultiSelectionList','validClasses','Classes for valid constraint:',['Good','New','Warn','None'],None],
++ 'talos': ['dihedral.tab',1,0, [['MultiSelectionList','validClasses','Classes for valid constraint:',['Good','New','Warn','Dyn', 'Strong', 'Generous', 'None'],None],
+ ['IntEntry','validCount','Count variable lower limit for valid constraint:',0,None],
+ ['FloatEntry','multiplyDeviation','Multiplication factor to convert deviation in constraint range:',2.0,None]],
+ []]},
diff --git a/sci-chemistry/ccpn/files/xeasy2azara b/sci-chemistry/ccpn/files/xeasy2azara
new file mode 100644
index 000000000000..7b73714c2fa5
--- /dev/null
+++ b/sci-chemistry/ccpn/files/xeasy2azara
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+export CCPNMR_TOP_DIR=gentoo_sitedir
+export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+export TCL_LIBRARY=gentootcl
+export TK_LIBRARY=gentootk
+export PSIPRED_DIR=gentoousr
+gentoopython -O ${CCPNMR_TOP_DIR}/ccpn/python/ccp/format/spectra/params/XeasyData.py $1 $2 $3 $4 $5 $6