summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-03-13 19:32:12 +0100
committerPacho Ramos <pacho@gentoo.org>2022-03-13 19:36:36 +0100
commit55c361837ab6af4c0a43d9515c2e8e7f96102d89 (patch)
treec66d7192e5c234c2ccbb9d6acd1e433115aff6ac /sci-chemistry/dssp/dssp-4.0.4.ebuild
parentmedia-gfx/gimp-arrow-brushes: Fix homepage (diff)
downloadgentoo-55c361837ab6af4c0a43d9515c2e8e7f96102d89.tar.gz
gentoo-55c361837ab6af4c0a43d9515c2e8e7f96102d89.tar.bz2
gentoo-55c361837ab6af4c0a43d9515c2e8e7f96102d89.zip
sci-chemistry/dssp: Bump to 4.0.4
Closes: https://bugs.gentoo.org/834882 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry/dssp/dssp-4.0.4.ebuild')
-rw-r--r--sci-chemistry/dssp/dssp-4.0.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-chemistry/dssp/dssp-4.0.4.ebuild b/sci-chemistry/dssp/dssp-4.0.4.ebuild
new file mode 100644
index 000000000000..bc27c568c321
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-4.0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="https://swift.cmbi.umcn.nl/gv/dssp/ https://github.com/PDB-REDO/dssp"
+
+SRC_URI="https://github.com/PDB-REDO/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="
+ >=dev-libs/boost-1.70.0:=[zlib,threads(+)]
+ >=sci-libs/libcifpp-2.0.0
+"
+DEPEND=""
+RDEPEND="${BDEPEND}"
+
+pkg_postinst() {
+ if has_version "<=sci-chemistry/gromacs-2022"; then
+ ewarn "DSSP > 3.0.x is not compatible with gmx do_dssp:"
+ ewarn "https://gitlab.com/gromacs/gromacs/-/issues/4129"
+ ewarn
+ ewarn "Feel free to mask newer versions if needed."
+ fi
+}