summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/dssp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/dssp')
-rw-r--r--sci-chemistry/dssp/Manifest1
-rw-r--r--sci-chemistry/dssp/dssp-2.2.1-r1.ebuild44
-rw-r--r--sci-chemistry/dssp/files/Makefile7
-rw-r--r--sci-chemistry/dssp/files/dssp-2.0.4-gcc47.patch46
-rw-r--r--sci-chemistry/dssp/files/dssp-2.0.4-gentoo.patch70
-rw-r--r--sci-chemistry/dssp/files/dssp-2.1.0-gentoo.patch60
-rw-r--r--sci-chemistry/dssp/metadata.xml8
7 files changed, 236 insertions, 0 deletions
diff --git a/sci-chemistry/dssp/Manifest b/sci-chemistry/dssp/Manifest
new file mode 100644
index 000000000000..a5bba878b984
--- /dev/null
+++ b/sci-chemistry/dssp/Manifest
@@ -0,0 +1 @@
+DIST dssp-2.2.1.tgz 47141 SHA256 5fb5e7c085de16c05981e3a72869c8b082911a0b46e6dcc6dbd669c9f267e8e1 SHA512 4a273714d6b3230daea166caa7f4117d5ccb225bea0cf1bc2eb61539b6cc8e227d0ba19047d61f0ad0d1d6bc2efdec9c193bd44341e15ef0950acb4a22498811 WHIRLPOOL abdb6777ccc06b062e3f20226c555348cd221d9c3e14d2adb9aeb85f14f84db8841c2fbbc4a487f5fa021da6616cddf2e96fde787d7670c419926d24d24944bd
diff --git a/sci-chemistry/dssp/dssp-2.2.1-r1.ebuild b/sci-chemistry/dssp/dssp-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..5e8b800f9488
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-2.2.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="http://swift.cmbi.ru.nl/gv/dssp/"
+SRC_URI="ftp://ftp.cmbi.ru.nl/pub/molbio/software/dssp-2/${P}.tgz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-libs/boost:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ tc-export CXX
+
+ cat >> make.config <<- EOF
+ BOOST_LIB_SUFFIX = -mt
+ BOOST_LIB_DIR = "${EPREFIX}/usr/$(get_libdir)"
+ BOOST_INC_DIR = "${EPREFIX}/usr/include"
+ EOF
+
+ epatch \
+ "${FILESDIR}"/${PN}-2.1.0-gentoo.patch
+}
+
+src_install() {
+ dobin mkdssp
+ dosym mkdssp /usr/bin/dssp
+ doman doc/mkdssp.1
+ dodoc README.txt changelog
+
+ cat >> "${T}"/30-${PN} <<- EOF
+ DSSP="${EPREFIX}"/usr/bin/${PN}
+ EOF
+ doenvd "${T}"/30-${PN}
+}
diff --git a/sci-chemistry/dssp/files/Makefile b/sci-chemistry/dssp/files/Makefile
new file mode 100644
index 000000000000..575202ebbe2d
--- /dev/null
+++ b/sci-chemistry/dssp/files/Makefile
@@ -0,0 +1,7 @@
+#OBJ = AccSurf.o CalcAccSurf.o Contacts.o Date.o Dssp.o DsspCMBI.o p2clib.o Vector.o
+OBJ = AccSurf.o CalcAccSurf.o Contacts.o Date.o DsspCMBI.o p2clib.o Vector.o
+
+LIBS = -lm
+
+dssp: $(OBJ)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJ) $(LIBS)
diff --git a/sci-chemistry/dssp/files/dssp-2.0.4-gcc47.patch b/sci-chemistry/dssp/files/dssp-2.0.4-gcc47.patch
new file mode 100644
index 000000000000..5db1437beb1f
--- /dev/null
+++ b/sci-chemistry/dssp/files/dssp-2.0.4-gcc47.patch
@@ -0,0 +1,46 @@
+ src/matrix.h | 5 +++--
+ src/primitives-3d.cpp | 1 +
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/matrix.h b/src/matrix.h
+index 1053ad9..d7dae5f 100644
+--- a/src/matrix.h
++++ b/src/matrix.h
+@@ -14,6 +14,7 @@
+ #include <istream>
+ #include <cassert>
+ #include <stdexcept>
++#include <unistd.h>
+
+ // --------------------------------------------------------------------
+ // uBlas compatible matrix types
+@@ -284,7 +285,7 @@ class identity_matrix : public matrix_base<T>
+ template<typename T>
+ matrix<T> operator*(const matrix_base<T>& lhs, const matrix_base<T>& rhs)
+ {
+- matrix<T> result(min(lhs.dim_m(), rhs.dim_m()), min(lhs.dim_n(), rhs.dim_n()));
++ matrix<T> result(std::min(lhs.dim_m(), rhs.dim_m()), std::min(lhs.dim_n(), rhs.dim_n()));
+
+ for (uint32 i = 0; i < result.dim_m(); ++i)
+ {
+@@ -310,7 +311,7 @@ matrix<T> operator*(const matrix_base<T>& lhs, T rhs)
+ template<typename T>
+ matrix<T> operator-(const matrix_base<T>& lhs, const matrix_base<T>& rhs)
+ {
+- matrix<T> result(min(lhs.dim_m(), rhs.dim_m()), min(lhs.dim_n(), rhs.dim_n()));
++ matrix<T> result(std::min(lhs.dim_m(), rhs.dim_m()), std::min(lhs.dim_n(), rhs.dim_n()));
+
+ for (uint32 i = 0; i < result.dim_m(); ++i)
+ {
+diff --git a/src/primitives-3d.cpp b/src/primitives-3d.cpp
+index b04e7c4..4532ecd 100644
+--- a/src/primitives-3d.cpp
++++ b/src/primitives-3d.cpp
+@@ -9,6 +9,7 @@
+
+ #include <valarray>
+ #include <cmath>
++#include <unistd.h>
+
+ #include <boost/foreach.hpp>
+ #define foreach BOOST_FOREACH
diff --git a/sci-chemistry/dssp/files/dssp-2.0.4-gentoo.patch b/sci-chemistry/dssp/files/dssp-2.0.4-gentoo.patch
new file mode 100644
index 000000000000..3db40f640ccd
--- /dev/null
+++ b/sci-chemistry/dssp/files/dssp-2.0.4-gentoo.patch
@@ -0,0 +1,70 @@
+ makefile | 24 ++++++++++++++----------
+ 1 files changed, 14 insertions(+), 10 deletions(-)
+
+diff --git a/makefile b/makefile
+index df699b7..9d2167b 100644
+--- a/makefile
++++ b/makefile
+@@ -2,7 +2,7 @@
+ #
+ # Copyright Maarten L. Hekkelman, Radboud University 2008-2011.
+ # Distributed under the Boost Software License, Version 1.0.
+-# (See accompanying file LICENSE_1_0.txt or copy at
++# (See aCXXompanying file LICENSE_1_0.txt or copy at
+ # http://www.boost.org/LICENSE_1_0.txt)
+ #
+ # This makefile includes a file called make.config. It will create a
+@@ -24,22 +24,23 @@ BOOST_LIBS = thread regex filesystem program_options date_time iostreams math_
+ LIBS = $(BOOST_LIBS:%=boost_%$(BOOST_LIB_SUFFIX)) z bz2
+
+ DEFINES = USE_COMPRESSION LINUX VERSION='"$(VERSION)"'
+-CC = c++
++CXX ?= c++
+
+-CFLAGS = $(INC_DIR:%=-I%) -iquote src -g -Wall -Wno-multichar -pthread
+-LDOPTS = $(LIB_DIR:%=-L%) $(LIBS:%=-l%) -g -pthread
++CPPFLAGS += $(INC_DIR:%=-I%) -iquote src
++CXXFLAGS += -Wall -Wno-multichar -pthread
++LDOPTS = $(LIB_DIR:%=-L%) $(LIBS:%=-l%) -pthread
+
+ OBJ_DIR = obj
+
+ ifeq ($(DEBUG),1)
+ OBJ_DIR := $(OBJ_DIR).dbg
+-CFLAGS += -g3
++CFLAGS +=
+ else
+ DEFINES += NDEBUG
+-CFLAGS += -O3
++CFLAGS +=
+ endif
+
+-CFLAGS += $(DEFINES:%=-D%)
++CPPFLAGS += $(DEFINES:%=-D%)
+
+ DIST_NAME = dssp-$(VERSION)
+
+@@ -49,17 +50,20 @@ OBJECTS = $(OBJ_DIR)/mkdssp.o $(OBJ_DIR)/dssp.o $(OBJ_DIR)/primitives-3d.o $(OBJ
+
+ mkdssp: $(OBJECTS)
+ @ echo linking $@
+- @ $(CC) -static -o $@ $^ $(LDOPTS)
++ $(CXX) $(LDFLAGS) -o $@ $^ $(LDOPTS)
+ @ echo OK
+
+ include $(OBJECTS:%.o=%.d)
+
+ $(OBJECTS:.o=.d):
+
+-$(OBJ_DIR)/%.o: %.cpp
++OBJ_DIR:
+ @ if [ ! -d $(OBJ_DIR) ]; then mkdir $(OBJ_DIR); fi
++
++
++$(OBJ_DIR)/%.o: %.cpp OBJ_DIR
+ @ echo compiling $@
+- @ $(CC) -MD -c -o $@ $< $(CFLAGS)
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -MD -c -o $@ $<
+
+ clean:
+ rm -rf $(OBJ_DIR)/* mkdssp
diff --git a/sci-chemistry/dssp/files/dssp-2.1.0-gentoo.patch b/sci-chemistry/dssp/files/dssp-2.1.0-gentoo.patch
new file mode 100644
index 000000000000..15198feaea19
--- /dev/null
+++ b/sci-chemistry/dssp/files/dssp-2.1.0-gentoo.patch
@@ -0,0 +1,60 @@
+ makefile | 21 +++++++++++----------
+ 1 file changed, 11 insertions(+), 10 deletions(-)
+
+diff --git a/makefile b/makefile
+index d6f335e..68736c6 100644
+--- a/makefile
++++ b/makefile
+@@ -25,22 +25,23 @@ BOOST_LIBS = thread filesystem program_options iostreams system
+ LIBS = $(BOOST_LIBS:%=boost_%$(BOOST_LIB_SUFFIX)) z bz2
+
+ DEFINES = USE_COMPRESSION LINUX VERSION='"$(VERSION)"'
+-CXX = g++
++CXX ?= g++
+
+-CFLAGS += $(INC_DIR:%=-I%) -iquote src -g -Wall -Wno-multichar -pthread
+-LDOPTS += $(LIB_DIR:%=-L%) $(LIBS:%=-l%) -g -pthread
++CPPFLAGS += $(INC_DIR:%=-I%) -iquote src
++CXXFLAGS += -Wall -Wno-multichar -pthread
++LDOPTS += $(LIB_DIR:%=-L%) $(LIBS:%=-l%) -pthread
+
+ OBJ_DIR = obj
+
+ ifeq ($(DEBUG),1)
+ OBJ_DIR := $(OBJ_DIR).dbg
+-CFLAGS += -g3
++CFLAGS +=
+ else
+ DEFINES += NDEBUG
+-CFLAGS += -O3
++CFLAGS +=
+ endif
+
+-CFLAGS += $(DEFINES:%=-D%)
++CPPFLAGS += $(DEFINES:%=-D%)
+
+ DIST_NAME = dssp-$(VERSION)
+
+@@ -50,18 +51,18 @@ OBJECTS = $(OBJ_DIR)/mkdssp.o $(OBJ_DIR)/dssp.o $(OBJ_DIR)/primitives-3d.o $(OBJ
+
+ mkdssp: $(OBJECTS)
+ @ echo linking $@
+- @ $(CXX) -static -o $@ $^ $(LDOPTS)
++ $(CXX) $(LDFLAGS) -o $@ $^ $(LDOPTS)
+
+ include $(OBJECTS:%.o=%.d)
+
+ $(OBJECTS:.o=.d):
+
+-$(OBJ_DIR):
++OBJ_DIR:
+ @ mkdir -p $(OBJ_DIR)
+
+-$(OBJ_DIR)/%.o: %.cpp | $(OBJ_DIR)
++$(OBJ_DIR)/%.o: %.cpp OBJ_DIR
+ @ echo compiling $@
+- @ $(CXX) -MD -c -o $@ $< $(CFLAGS)
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -MD -c -o $@ $<
+
+ clean:
+ install -d $(BIN_DIR) $(MAN_DIR)
diff --git a/sci-chemistry/dssp/metadata.xml b/sci-chemistry/dssp/metadata.xml
new file mode 100644
index 000000000000..ae9ec7c5f6a4
--- /dev/null
+++ b/sci-chemistry/dssp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>