summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-30 09:14:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-30 11:27:02 +0200
commit88bccc096e61e4829d8d05aed0f5f42681c6e91f (patch)
tree4bfcbee21fef3b7303f62c25107541488b64f288 /sci-chemistry/gperiodic/gperiodic-3.0.1.ebuild
parentpackage.mask: Remove roundup mask (diff)
downloadgentoo-88bccc096e61e4829d8d05aed0f5f42681c6e91f.tar.gz
gentoo-88bccc096e61e4829d8d05aed0f5f42681c6e91f.tar.bz2
gentoo-88bccc096e61e4829d8d05aed0f5f42681c6e91f.zip
sci-chemistry/gperiodic: Drop 2.0.10-r2 and 3.0.1
Closes: https://bugs.gentoo.org/707580 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-chemistry/gperiodic/gperiodic-3.0.1.ebuild')
-rw-r--r--sci-chemistry/gperiodic/gperiodic-3.0.1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/sci-chemistry/gperiodic/gperiodic-3.0.1.ebuild b/sci-chemistry/gperiodic/gperiodic-3.0.1.ebuild
deleted file mode 100644
index 511cfe2ba428..000000000000
--- a/sci-chemistry/gperiodic/gperiodic-3.0.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Periodic table application for Linux"
-HOMEPAGE="https://sourceforge.net/projects/gperiodic/"
-SRC_URI="https://downloads.sourceforge.net/project/${PN}/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE="nls"
-MY_AVAILABLE_LINGUAS=" be bg cs da de es fi fr gl id is it lt ms nl pl pt_BR pt ru sv tr uk"
-
-RDEPEND="
- sys-libs/ncurses:0
- x11-libs/gtk+:2
- x11-libs/cairo[X]
- nls? ( sys-devel/gettext )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-makefile.patch \
- "${FILESDIR}"/${P}-nls.patch
- for lang in ${MY_AVAILABLE_LINGUAS}; do
- if ! has ${lang} ${LINGUAS-${lang}}; then
- einfo "Cleaning translation for ${lang}"
- rm po/${lang}.po || die
- fi
- done
-}
-
-src_compile() {
- local myopts
- use nls && myopts="enable_nls=1" || myopts="enable_nls=0"
- emake \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- CC=$(tc-getCC) ${myopts}
-}
-
-src_install() {
- local myopts
- use nls && myopts="enable_nls=1" || myopts="enable_nls=0"
- emake DESTDIR="${D}" ${myopts} install
- dodoc AUTHORS ChangeLog README
- newdoc po/README README.translation
-}