summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/imosflm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/imosflm')
-rw-r--r--sci-chemistry/imosflm/Manifest1
-rw-r--r--sci-chemistry/imosflm/files/1.0.4-impl-dec.patch12
-rw-r--r--sci-chemistry/imosflm/files/1.0.4-tk.patch50
-rw-r--r--sci-chemistry/imosflm/files/1.0.7-libpng16.patch13
-rw-r--r--sci-chemistry/imosflm/imosflm-1.0.7-r1.ebuild54
-rw-r--r--sci-chemistry/imosflm/metadata.xml5
6 files changed, 135 insertions, 0 deletions
diff --git a/sci-chemistry/imosflm/Manifest b/sci-chemistry/imosflm/Manifest
new file mode 100644
index 000000000000..2ce7d893b7fd
--- /dev/null
+++ b/sci-chemistry/imosflm/Manifest
@@ -0,0 +1 @@
+DIST imosflm-1.0.7.zip 941784 SHA256 b067261b4d7ef2f1f7581ddeaa08252d29f889acf89ce190eb0d8b30aa94b107 SHA512 f3163e1f71c5b1e24d6b3fbd5a040bbcebae25485d1258eef4b2725821f5f96c1260adb2bcc3ab57179d7b9b9e538ddf0494ab9b5be259b98d138fddacec8c77 WHIRLPOOL bd2b6bcdcc241fde41fe2ba99bd1e2f47bc444c46ee36a5b332d5c018b81a9d649378110a8bffa48ffc67a19b04ede7e61846b53a250e5fe3058ec0313fda80c
diff --git a/sci-chemistry/imosflm/files/1.0.4-impl-dec.patch b/sci-chemistry/imosflm/files/1.0.4-impl-dec.patch
new file mode 100644
index 000000000000..5d0dd7010910
--- /dev/null
+++ b/sci-chemistry/imosflm/files/1.0.4-impl-dec.patch
@@ -0,0 +1,12 @@
+diff --git a/c/tkImageLoad.c b/c/tkImageLoad.c
+index e7c46f0..1496a15 100755
+--- a/c/tkImageLoad.c
++++ b/c/tkImageLoad.c
+@@ -12,6 +12,7 @@
+ #include <tcl.h>
+ #include <tk.h>
+ #include <assert.h>
++#include <stdlib.h>
+
+ #define HEADER_LINE_LENGTH 512
+ #define BYTES_PER_PIXEL 2
diff --git a/sci-chemistry/imosflm/files/1.0.4-tk.patch b/sci-chemistry/imosflm/files/1.0.4-tk.patch
new file mode 100644
index 000000000000..a90175194eb4
--- /dev/null
+++ b/sci-chemistry/imosflm/files/1.0.4-tk.patch
@@ -0,0 +1,50 @@
+--- c/tkImageLoad.c 2009-08-14 21:10:19.000000000 +0200
++++ c/tkImageLoad.c.new 2009-08-14 21:10:55.000000000 +0200
+@@ -19,6 +19,7 @@
+ //#define BLOCKED 1
+ //#define UNBLOCKED 1
+ #define IN_BLOCK_FLIP 1
++#define USE_COMPOSITELESS_PHOTO_PUT_BLOCK
+
+ /* *********************************************************************/
+
+--- c/tkImageLoad.c 2009-08-14 21:13:29.000000000 +0200
++++ c/tkImageLoad.c.new 2009-08-14 21:14:59.000000000 +0200
+@@ -272,9 +272,11 @@
+ }
+ /* put the photo block into the image */
+ #ifdef __alpha
+- Tk_PhotoPutBlock(dp, &db, 0, 0, width, height);
++ Tk_PhotoPutBlock(dp, &db, 0, 0, width, height,
++ TK_PHOTO_COMPOSITE_OVERLAY);
+ #else
+- Tk_PhotoPutBlock(dp, &db, 0, 0, width, height, TK_PHOTO_COMPOSITE_SET);
++ Tk_PhotoPutBlock(dp, &db, 0, 0, width, height, TK_PHOTO_COMPOSITE_SET,
++ TK_PHOTO_COMPOSITE_OVERLAY);
+ #endif
+
+ /* Free the photo block's memory now it is finished with */
+@@ -417,9 +419,11 @@
+
+ /* put the photo block back into the image */
+ #ifdef __alpha
+- Tk_PhotoPutBlock(photo, &block, 0, 0, block.width, block.height);
++ Tk_PhotoPutBlock(photo, &block, 0, 0, block.width, block.height,
++ TK_PHOTO_COMPOSITE_OVERLAY);
+ #else
+- Tk_PhotoPutBlock(photo, &block, 0, 0, block.width, block.height,TK_PHOTO_COMPOSITE_SET);
++ Tk_PhotoPutBlock(photo, &block, 0, 0, block.width, block.height,TK_PHOTO_COMPOSITE_SET,
++ TK_PHOTO_COMPOSITE_OVERLAY);
+ #endif
+ /* Free the photo block's memory now it is finished with */
+ if (block.pixelPtr) {
+--- c/tkImageLoad.c 2009-08-14 21:15:06.000000000 +0200
++++ c/tkImageLoad.c.new 2009-08-14 21:16:53.000000000 +0200
+@@ -9,6 +9,7 @@
+ \************************************************************************/
+
+ #include <stdio.h>
++#include <string.h>
+ #include <tcl.h>
+ #include <tk.h>
+ #include <assert.h>
diff --git a/sci-chemistry/imosflm/files/1.0.7-libpng16.patch b/sci-chemistry/imosflm/files/1.0.7-libpng16.patch
new file mode 100644
index 000000000000..27efc6f36f4b
--- /dev/null
+++ b/sci-chemistry/imosflm/files/1.0.7-libpng16.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/467036
+
+--- src/contrast.tcl
++++ src/contrast.tcl
+@@ -3,7 +3,7 @@
+
+ package require palette
+
+-image create photo ::img::pixel_count_v -data "iVBORw0KGgoAAAANSUhEUgAAAA4AAABCCAIAAAGft0AHAAAABGdBTUEAAYagMeiWXwAAASFJREFUKJGtVFEWhCAINJ9H4f4n4jD7YauAA1jGT2EwAxNyMXMppZZu3bv6Q3t3iH7ob3fOPz3wdLoi7y8V1SOZp0NE02Hm7quc6VSVaokFKzMD8qKUUd0tyEQ0z1DchNQaud+JCHclzeIDOUCle7EjcA/XPZU4Klb9y2GDY68LVe8YiAihmXT052G9SQ0+m4yN2J7EZqrvnZpheMdGRLnq5/ViddTusPeux9o5G7fdsskrV9ej8rw3I80LhNUUgqmvwCY8izozZcvo5tGt1owfoGJhoEVtgcXg2da2gJa0JYESseRJ8gvyOYSGlxUkScYFoBoJB+RZrR+H2sWx2vEQrnv0pa4HYkFqF7UHrefRdjE5zQQFAp/Nqwf8XNePZ+AHq5sOPlXtupMAAAAASUVORK5CYII="
++image create photo ::img::pixel_count_v -data "iVBORw0KGgoAAAANSUhEUgAAAA4AAABCCAIAAAGft0AHAAAABGdBTUEAAYagMeiWXwAAASFJREFUeJytVFEWhCAINJ9H4f4n4jD7YauAA1jGT2EwAxNyMXMppZZu3bv6Q3t3iH7ob3fOPz3wdLoi7y8V1SOZp0NE02Hm7quc6VSVaokFKzMD8qKUUd0tyEQ0z1DchNQaud+JCHclzeIDOUCle7EjcA/XPZU4Klb9y2GDY68LVe8YiAihmXT052G9SQ0+m4yN2J7EZqrvnZpheMdGRLnq5/ViddTusPeux9o5G7fdsskrV9ej8rw3I80LhNUUgqmvwCY8izozZcvo5tGt1owfoGJhoEVtgcXg2da2gJa0JYESseRJ8gvyOYSGlxUkScYFoBoJB+RZrR+H2sWx2vEQrnv0pa4HYkFqF7UHrefRdjE5zQQFAp/Nqwf8XNePZ+AHq5sOPv4fGP4AAAAASUVORK5CYII="
+
+ class Contrast {
+ inherit Palette
diff --git a/sci-chemistry/imosflm/imosflm-1.0.7-r1.ebuild b/sci-chemistry/imosflm/imosflm-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..e49667e50dc7
--- /dev/null
+++ b/sci-chemistry/imosflm/imosflm-1.0.7-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs versionator
+
+MY_PV="$(delete_all_version_separators ${PV})"
+
+DESCRIPTION="A new GUI for the Mosflm crystallographic data processing tool"
+HOMEPAGE="http://www.mrc-lmb.cam.ac.uk/harry/imosflm"
+SRC_URI="${HOMEPAGE}/ver${MY_PV}/downloads/${P}.zip"
+
+LICENSE="ccp4"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-lang/tcl:0=
+ >=dev-tcltk/itcl-3.3
+ >=dev-tcltk/itk-3.3
+ >=dev-tcltk/iwidgets-4
+ >=dev-tcltk/tdom-0.8
+ >=dev-tcltk/tkimg-1.3
+ >=dev-tcltk/tktreectrl-2.1
+ dev-tcltk/anigif
+ dev-tcltk/combobox
+ dev-tcltk/tablelist
+ >=sci-chemistry/mosflm-7.0.9"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-libpng16.patch
+}
+
+src_install(){
+ rm -rf lib/{*.so,anigif,combobox}
+
+ insinto /usr/$(get_libdir)/${PN}
+ doins -r "${S}"/{src,bitmaps,lib}
+ fperms 775 /usr/$(get_libdir)/${PN}/src/imosflm
+
+ cat >> "${T}"/23imosflm <<- EOF
+ IMOSFLM_VERSION="${PV}"
+ EOF
+
+ doenvd "${T}"/23imosflm
+
+ make_wrapper imosflm /usr/$(get_libdir)/${PN}/src/imosflm
+}
diff --git a/sci-chemistry/imosflm/metadata.xml b/sci-chemistry/imosflm/metadata.xml
new file mode 100644
index 000000000000..51fdedab1b38
--- /dev/null
+++ b/sci-chemistry/imosflm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+</pkgmetadata>