summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/mosflm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/mosflm')
-rw-r--r--sci-chemistry/mosflm/Manifest1
-rw-r--r--sci-chemistry/mosflm/files/7.0.6-Makefile.patch13
-rw-r--r--sci-chemistry/mosflm/files/7.0.6-impl-dec.patch36
-rw-r--r--sci-chemistry/mosflm/files/7.0.6-parallel.patch28
-rw-r--r--sci-chemistry/mosflm/files/7.0.7-parallel.patch92
-rw-r--r--sci-chemistry/mosflm/files/7.0.9-parallel.patch92
-rw-r--r--sci-chemistry/mosflm/files/mosflm-7.0.7-buffer-overflow.patch16
-rw-r--r--sci-chemistry/mosflm/files/mosflm-7.0.7-impl-dec.patch29
-rw-r--r--sci-chemistry/mosflm/files/mosflm-7.0.9-buffer-overflow.patch16
-rw-r--r--sci-chemistry/mosflm/metadata.xml8
-rw-r--r--sci-chemistry/mosflm/mosflm-7.0.9.ebuild74
11 files changed, 405 insertions, 0 deletions
diff --git a/sci-chemistry/mosflm/Manifest b/sci-chemistry/mosflm/Manifest
new file mode 100644
index 000000000000..80df134c833e
--- /dev/null
+++ b/sci-chemistry/mosflm/Manifest
@@ -0,0 +1 @@
+DIST mosflm709.tgz 3324010 SHA256 d22b05211f274b50c284d4c14fcb456c52b13344e2a48d5f45855fe87f82f6d1 SHA512 aa85f8459f280e0e1d2d54041029ef072346ecef3ffcc7724eb524469e1b77dfbd95aac8b46f2b9682d605a4e5931d9c13f1162d5f3bcff08644db7e79a6316c WHIRLPOOL b3a82858a8d2a3162bc0fcfb3bf7fb7b01cfc6bca80b34643e7c6caae54b1ef1e2b24a58617ffe2b0423ca6626d51e31b49c0dba6a82ed5c61fa10d044e0d3b8
diff --git a/sci-chemistry/mosflm/files/7.0.6-Makefile.patch b/sci-chemistry/mosflm/files/7.0.6-Makefile.patch
new file mode 100644
index 000000000000..a35232f6e8c0
--- /dev/null
+++ b/sci-chemistry/mosflm/files/7.0.6-Makefile.patch
@@ -0,0 +1,13 @@
+--- Makefile 2008-10-17 16:15:30.000000000 +0200
++++ Makefile.new 2009-02-20 21:52:34.000000000 +0100
+@@ -22,7 +22,7 @@
+ CBFLIBS = cbf/lib/libcbf.a
+ JPGLIBS = jpg/libjpeg.a
+
+-all: $(DPSLIBS) $(CBFLIBS) $(JPGLIBS)
+- cd mosflm ; make
++all: dpslibs cbflibs
++ +make -C mosflm
+
+ ##########################################################################
+
diff --git a/sci-chemistry/mosflm/files/7.0.6-impl-dec.patch b/sci-chemistry/mosflm/files/7.0.6-impl-dec.patch
new file mode 100644
index 000000000000..da393eb93fe6
--- /dev/null
+++ b/sci-chemistry/mosflm/files/7.0.6-impl-dec.patch
@@ -0,0 +1,36 @@
+diff --git a/mosflm/bravais_fortran.c b/mosflm/bravais_fortran.c
+index 3d68cad..800bd0e 100644
+--- a/mosflm/bravais_fortran.c
++++ b/mosflm/bravais_fortran.c
+@@ -2,6 +2,7 @@
+ #include <stdlib.h>
+ #include <math.h>
+ #include "../util/util.h"
++#include "../util/bravais.h"
+
+ /* bravais_fortran_(): This routine converts array from FORTRAN program
+ to structure for call to bravais
+diff --git a/mosflm/chelp.c b/mosflm/chelp.c
+index b2aaefc..fa44ab0 100644
+--- a/mosflm/chelp.c
++++ b/mosflm/chelp.c
+@@ -5,6 +5,7 @@
+ /* modified for Linux by Joachim Meyer jmeyer@embl-heidelberg.de 1998.05.19 */
+
+ #include "chelp.h"
++#include <stdio.h>
+
+ #if CALL_LIKE_HPUX
+ void chelp ()
+diff --git a/mosflm/pck.c b/mosflm/pck.c
+index ec094fc..288671d 100644
+--- a/mosflm/pck.c
++++ b/mosflm/pck.c
+@@ -17,6 +17,7 @@
+ #include <math.h>
+ #include <ctype.h>
+ #include <string.h>
++#include <unistd.h>
+
+ #define BYTE char
+ #define WORD short int
diff --git a/sci-chemistry/mosflm/files/7.0.6-parallel.patch b/sci-chemistry/mosflm/files/7.0.6-parallel.patch
new file mode 100644
index 000000000000..f735c7ce5cf7
--- /dev/null
+++ b/sci-chemistry/mosflm/files/7.0.6-parallel.patch
@@ -0,0 +1,28 @@
+--- cbf/Makefile 2009-08-31 09:35:06.000000000 +0200
++++ cbf/Makefile.new 2009-08-31 10:44:46.000000000 +0200
+@@ -362,6 +362,8 @@
+ $(EXAMPLES)/img.h \
+ $(INCLUDE)/md5.h
+
++OBJ = $(subst .c,.o,$(SOURCE))
++
+ #
+ # Compile the library and examples
+ #
+@@ -379,11 +381,14 @@
+ $(LIB):
+ mkdir $(LIB)
+
++
++.c.o: $(SOURCE) $(HEADERS)
++ $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $<
++
+ #
+ # CBF library
+ #
+-$(LIB)/libcbf.a: $(SOURCE) $(HEADERS) $(COMMONDEP)
+- $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $(SOURCE)
++$(LIB)/libcbf.a: $(OBJ) $(COMMONDEP)
+ $(AR) cr $@ *.o
+ rm *.o
+ if [ -f $(RANLIB) ]; then $(RANLIB) $@ ; fi
diff --git a/sci-chemistry/mosflm/files/7.0.7-parallel.patch b/sci-chemistry/mosflm/files/7.0.7-parallel.patch
new file mode 100644
index 000000000000..df0a8b63273a
--- /dev/null
+++ b/sci-chemistry/mosflm/files/7.0.7-parallel.patch
@@ -0,0 +1,92 @@
+ Makefile | 21 ++++++++++-----------
+ cbf/Makefile | 9 +++++++--
+ 2 files changed, 17 insertions(+), 13 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 37f4c7e..51d4164 100644
+--- a/Makefile
++++ b/Makefile
+@@ -22,8 +22,8 @@ DPSLIBS = lib/DPSLIB.a
+ CBFLIBS = cbf/lib/libcbf.a
+ JPGLIBS = jpg/libjpeg.a
+
+-all: $(DPSLIBS) $(CBFLIBS) $(JPGLIBS)
+- cd mosflm ; make
++all: $(DPSLIBS)
++ $(MAKE) -C mosflm
+
+ ##########################################################################
+ # #
+@@ -47,22 +47,21 @@ dpslibs:
+
+ cbflibs:
+ rm -f `find ./cbf -name "*.a" -print`
+- cd cbf ; make all ; if [ -f $(RANLIB) ]; \
+- then $(RANLIB) lib/libcbf.a; fi
++ $(MAKE) -C cbf all
+
+ jpglibs:
+- cd jpg ; if [ ! -f Makefile ]; then ./configure ; fi; make libjpeg.a
++ cd jpg ; if [ ! -f Makefile ]; then ./configure ; fi; $(MAKE) libjpeg.a
+
+ ${DPSLIBS}:
+- make dpslibs
++ $(MAKE) dpslibs
+
+ ${CBFLIBS}:
+- make cbflibs
++ $(MAKE) cbflibs
+
+ ${JPGLIBS}:
+- make jpglibs
++ $(MAKE) jpglibs
+
+-libs: ${DPSLIBS} ${CBFLIBS} ${JPGLIBS}
++libs: ${DPSLIBS} ${CBFLIBS}
+ @echo "****************************************************************"
+ @echo " Making libraries for system ${HOSTTYPE}"
+ @echo "****************************************************************"
+@@ -71,11 +70,11 @@ ipmosflm: libs
+ @echo "****************************************************************"
+ @echo " Making IPMOSFLM for system ${HOSTTYPE}"
+ @echo "****************************************************************"
+- cd mosflm ; make ipmosflm
++ $(MAKE) -C mosflm ipmosflm
+
+ force:
+ rm bin/ipmosflm
+- make ipmosflm
++ $(MAKE) ipmosflm
+
+ install:
+ @echo "the executable is in ${MOSHOME}/bin/ipmosflm"
+diff --git a/cbf/Makefile b/cbf/Makefile
+index e61497c..c3c94ac 100644
+--- a/cbf/Makefile
++++ b/cbf/Makefile
+@@ -362,6 +362,8 @@ HEADERS = $(INCLUDE)/cbf.h \
+ $(EXAMPLES)/img.h \
+ $(INCLUDE)/md5.h
+
++OBJ = $(subst .c,.o,$(SOURCE))
++
+ #
+ # Compile the library and examples
+ #
+@@ -379,11 +381,14 @@ $(INSTALLDIR):
+ $(LIB):
+ mkdir $(LIB)
+
++
++.c.o: $(SOURCE) $(HEADERS)
++ $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $<
++
+ #
+ # CBF library
+ #
+-$(LIB)/libcbf.a: $(SOURCE) $(HEADERS) $(COMMONDEP)
+- $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $(SOURCE)
++$(LIB)/libcbf.a: $(OBJ) $(COMMONDEP)
+ $(AR) cr $@ *.o
+ rm *.o
+ if [ -f $(RANLIB) ]; then $(RANLIB) $@ ; fi
diff --git a/sci-chemistry/mosflm/files/7.0.9-parallel.patch b/sci-chemistry/mosflm/files/7.0.9-parallel.patch
new file mode 100644
index 000000000000..38c6fc45a5c0
--- /dev/null
+++ b/sci-chemistry/mosflm/files/7.0.9-parallel.patch
@@ -0,0 +1,92 @@
+ Makefile | 21 ++++++++++-----------
+ cbf/Makefile | 9 +++++++--
+ 2 files changed, 17 insertions(+), 13 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 3d2f543..2219d8d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -22,8 +22,8 @@ DPSLIBS = lib/DPSLIB.a
+ CBFLIBS = cbf/lib/libcbf.a
+ JPGLIBS = jpg/libjpeg.a
+
+-all: $(DPSLIBS) $(CBFLIBS) $(JPGLIBS)
+- cd mosflm ; make
++all: $(DPSLIBS)
++ $(MAKE) -C mosflm
+
+ dpslibs:
+ @-find . -name "*a" -delete
+@@ -32,22 +32,21 @@ dpslibs:
+
+ cbflibs:
+ @-find ./cbf -name "*.a" -delete
+- cd cbf ; make all ; if [ -f $(RANLIB) ]; \
+- then $(RANLIB) lib/libcbf.a; fi
++ $(MAKE) -C cbf all
+
+ jpglibs:
+- cd jpg ; if [ ! -f Makefile ]; then ./configure ; fi; make libjpeg.a
++ cd jpg ; if [ ! -f Makefile ]; then ./configure ; fi; $(MAKE) libjpeg.a
+
+ ${DPSLIBS}:
+- make dpslibs
++ $(MAKE) dpslibs
+
+ ${CBFLIBS}:
+- make cbflibs
++ $(MAKE) cbflibs
+
+ ${JPGLIBS}:
+- make jpglibs
++ $(MAKE) jpglibs
+
+-libs: ${DPSLIBS} ${CBFLIBS} ${JPGLIBS}
++libs: ${DPSLIBS} ${CBFLIBS}
+ @echo "****************************************************************"
+ @echo " Making libraries for system ${HOSTTYPE}"
+ @echo "****************************************************************"
+@@ -56,11 +55,11 @@ ipmosflm: libs
+ @echo "****************************************************************"
+ @echo " Making IPMOSFLM for system ${HOSTTYPE}"
+ @echo "****************************************************************"
+- cd mosflm ; make ipmosflm
++ $(MAKE) -C mosflm ipmosflm
+
+ force:
+ @-rm -f bin/ipmosflm
+- make ipmosflm
++ $(MAKE) ipmosflm
+
+ install:
+ @echo "the executable is in ${MOSHOME}/bin/ipmosflm"
+diff --git a/cbf/Makefile b/cbf/Makefile
+index e61497c..c3c94ac 100644
+--- a/cbf/Makefile
++++ b/cbf/Makefile
+@@ -362,6 +362,8 @@ HEADERS = $(INCLUDE)/cbf.h \
+ $(EXAMPLES)/img.h \
+ $(INCLUDE)/md5.h
+
++OBJ = $(subst .c,.o,$(SOURCE))
++
+ #
+ # Compile the library and examples
+ #
+@@ -379,11 +381,14 @@ $(INSTALLDIR):
+ $(LIB):
+ mkdir $(LIB)
+
++
++.c.o: $(SOURCE) $(HEADERS)
++ $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $<
++
+ #
+ # CBF library
+ #
+-$(LIB)/libcbf.a: $(SOURCE) $(HEADERS) $(COMMONDEP)
+- $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $(SOURCE)
++$(LIB)/libcbf.a: $(OBJ) $(COMMONDEP)
+ $(AR) cr $@ *.o
+ rm *.o
+ if [ -f $(RANLIB) ]; then $(RANLIB) $@ ; fi
diff --git a/sci-chemistry/mosflm/files/mosflm-7.0.7-buffer-overflow.patch b/sci-chemistry/mosflm/files/mosflm-7.0.7-buffer-overflow.patch
new file mode 100644
index 000000000000..90158eb458d5
--- /dev/null
+++ b/sci-chemistry/mosflm/files/mosflm-7.0.7-buffer-overflow.patch
@@ -0,0 +1,16 @@
+ mosflm/pilatus_c.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/mosflm/pilatus_c.c b/mosflm/pilatus_c.c
+index 1eaae26..cce5a02 100644
+--- a/mosflm/pilatus_c.c
++++ b/mosflm/pilatus_c.c
+@@ -34,7 +34,7 @@ delete them later */
+ int cbf_int[16];
+ long cbf_int4[16];
+ double cbf_double[16];
+- char cbf_char[16][24];
++ char cbf_char[16][32];
+ /* temporary from cbfwrap.c - pilatus doesn't have these, so we'll
+ delete them later */
+ int id, index, iindex;
diff --git a/sci-chemistry/mosflm/files/mosflm-7.0.7-impl-dec.patch b/sci-chemistry/mosflm/files/mosflm-7.0.7-impl-dec.patch
new file mode 100644
index 000000000000..32f251f8e00c
--- /dev/null
+++ b/sci-chemistry/mosflm/files/mosflm-7.0.7-impl-dec.patch
@@ -0,0 +1,29 @@
+ mosflm/mosflm_jpeg.c | 1 +
+ src/dps/index/ind_gen_direct.c | 2 ++
+ 2 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/mosflm/mosflm_jpeg.c b/mosflm/mosflm_jpeg.c
+index 2b32b2e..54684d0 100644
+--- a/mosflm/mosflm_jpeg.c
++++ b/mosflm/mosflm_jpeg.c
+@@ -76,6 +76,7 @@ G. Winter
+ #include <fcntl.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #if (defined _MSC_VER)
+ /* no need to do this for __MINGW_ (Mingw gcc) this is just about unique!*/
+ #define S_IRWXU S_IREAD|S_IWRITE|S_IEXEC
+diff --git a/src/dps/index/ind_gen_direct.c b/src/dps/index/ind_gen_direct.c
+index 6e143df..2eea61b 100644
+--- a/src/dps/index/ind_gen_direct.c
++++ b/src/dps/index/ind_gen_direct.c
+@@ -41,6 +41,8 @@
+ /* #include <malloc.h> */
+ #include "util.h"
+ #include "ind_gen_direct.h"
++#include "ind_help.h"
++#include "ind_sort_merge.h"
+ /* char *strcat( char *, const char *); */
+
+
diff --git a/sci-chemistry/mosflm/files/mosflm-7.0.9-buffer-overflow.patch b/sci-chemistry/mosflm/files/mosflm-7.0.9-buffer-overflow.patch
new file mode 100644
index 000000000000..bb4a16bf30fc
--- /dev/null
+++ b/sci-chemistry/mosflm/files/mosflm-7.0.9-buffer-overflow.patch
@@ -0,0 +1,16 @@
+ mosflm/pilatus_c.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/mosflm/pilatus_c.c b/mosflm/pilatus_c.c
+index 4a85b26..9893e0c 100644
+--- a/mosflm/pilatus_c.c
++++ b/mosflm/pilatus_c.c
+@@ -34,7 +34,7 @@ delete them later */
+ int cbf_int[16] = {0};
+ long cbf_int4[16] = {0};
+ double cbf_double[16] = {0};
+- char cbf_char[16][24] = {' '};
++ char cbf_char[16][32] = {' '};
+ /* temporary from cbfwrap.c - pilatus doesn't have these, so we'll
+ delete them later */
+ int id, index, iindex;
diff --git a/sci-chemistry/mosflm/metadata.xml b/sci-chemistry/mosflm/metadata.xml
new file mode 100644
index 000000000000..ae9ec7c5f6a4
--- /dev/null
+++ b/sci-chemistry/mosflm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/mosflm/mosflm-7.0.9.ebuild b/sci-chemistry/mosflm/mosflm-7.0.9.ebuild
new file mode 100644
index 000000000000..3aa74ced3d94
--- /dev/null
+++ b/sci-chemistry/mosflm/mosflm-7.0.9.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils fortran-2 toolchain-funcs versionator
+
+MY_PV="$(delete_all_version_separators)"
+MY_P="${PN}${MY_PV}"
+
+DESCRIPTION="A program for integrating single crystal diffraction data from area detectors"
+HOMEPAGE="http://www.mrc-lmb.cam.ac.uk/harry/mosflm/"
+SRC_URI="${HOMEPAGE}ver${MY_PV}/build-it-yourself/${MY_P}.tgz"
+
+SLOT="0"
+LICENSE="ccp4"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ app-shells/tcsh
+ sci-libs/cbflib
+ sci-libs/ccp4-libs
+ sys-libs/ncurses
+ virtual/jpeg:0=
+ x11-libs/libxdl_view"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed \
+ -e "s:../cbf/lib/libcbf.a:-lcbf -limg:g" \
+ -e "s:../jpg/libjpeg.a:-ljpeg:g" \
+ -i ${PN}/Makefile || die
+
+ sed \
+ -e '/jinclude.h/d' \
+ -i mosflm/mosflm_jpeg.c || die
+
+ cp DATETIME.C mosflm/datetime.c || die
+
+ epatch \
+ "${FILESDIR}"/${PV}-parallel.patch \
+ "${FILESDIR}"/7.0.6-impl-dec.patch \
+ "${FILESDIR}"/${P}-buffer-overflow.patch \
+ "${FILESDIR}"/${PN}-7.0.7-impl-dec.patch
+
+ rm -rf test.f {cbf,jpg}/*.{h,c} || die
+}
+
+src_compile() {
+ emake \
+ MOSHOME="${S}" \
+ DPS="${S}" \
+ FC=$(tc-getFC) \
+ FLINK=$(tc-getFC) \
+ CC=$(tc-getCC) \
+ AR_FLAGS=vru \
+ MOSLIBS="-lccp4f -lccp4c -lxdl_view $($(tc-getPKG_CONFIG) --libs ncurses) -lXt -lmmdb -lccif -lstdc++" \
+ MCFLAGS="-O0 -fno-second-underscore" \
+ MOSFLAGS="${FFLAGS} -fno-second-underscore" \
+ FFLAGS="${FFLAGS} -fno-second-underscore" \
+ CFLAGS="${CFLAGS}" \
+ MOSCFLAGS="${CFLAGS}" \
+ LFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ exeinto /usr/libexec/ccp4/bin/
+ doexe bin/ipmosflm
+ dosym ../libexec/ccp4/bin/ip${PN} /usr/bin/ip${PN}
+}