summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/msms-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/msms-bin')
-rw-r--r--sci-chemistry/msms-bin/Manifest2
-rw-r--r--sci-chemistry/msms-bin/metadata.xml8
-rw-r--r--sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild45
3 files changed, 55 insertions, 0 deletions
diff --git a/sci-chemistry/msms-bin/Manifest b/sci-chemistry/msms-bin/Manifest
new file mode 100644
index 000000000000..7cffef46c709
--- /dev/null
+++ b/sci-chemistry/msms-bin/Manifest
@@ -0,0 +1,2 @@
+DIST msms_i86Linux2_2.6.1.tar.gz 112762 RMD160 5bbf6102471026112e4f688f56f0a6b8730124c9 SHA1 6ee76d87f3ac3ae543a15d2ea9f86bf3f67d5d4c SHA256 ab4f9e60df6fe18a5ac05550bf074b287792638a818a047697ead049d8737caf
+DIST msms_i86_64Linux2_2.6.1.tar.gz 593147 RMD160 a239db5e85afc445c32a165f4086d186010ab123 SHA1 39f9aa955016927138c4014ec0bb40c6a8df18a2 SHA256 5f0ca50360b5938e74c538e0399d582abc4a40ef4cf410e66f31a1f91e6e3e1f
diff --git a/sci-chemistry/msms-bin/metadata.xml b/sci-chemistry/msms-bin/metadata.xml
new file mode 100644
index 000000000000..51426ab8d003
--- /dev/null
+++ b/sci-chemistry/msms-bin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>alexxy@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild b/sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild
new file mode 100644
index 000000000000..8b4267088281
--- /dev/null
+++ b/sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="MSMS allows to compute very efficiently triangulations of Solvent Excluded Surfaces"
+HOMEPAGE="http://mgl.scripps.edu/people/sanner/html/msms_home.html"
+SRC_URI="
+ amd64? ( msms_i86_64Linux2_2.6.1.tar.gz )
+ x86? ( msms_i86Linux2_2.6.1.tar.gz )
+"
+
+LICENSE="MSMS"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RESTRICT="fetch"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="${EROOT#/}opt/bin/.*"
+
+pkg_nofetch() {
+ einfo "Please download ${A} from http://mgltools.scripps.edu/downloads#msms and place it to ${DISTDIR}"
+}
+
+src_install() {
+ doman msms.1
+ dodoc README msms.html ReleaseNotes
+ exeinto /opt/bin
+ if use amd64; then
+ newexe ${PN%-bin}.x86_64Linux2.${PV} msms
+ elif use x86; then
+ newexe ${PN%-bin}.i86Linux2.${PV} msms
+ fi
+ insinto /usr/share/${PN}/
+ doins atmtypenumbers
+ sed \
+ -e 's:nawk:awk:g' \
+ -e "s:./atmtypenumbers:${EPREFIX}/usr/share/${PN}/atmtypenumbers:g" \
+ -i pdb_to_xyz* || die
+ dobin pdb_to_xyz*
+}