summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-17 23:31:52 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-17 23:33:08 +0100
commit9a64979f181d12d3b19c6a0d6f4edaf21a0c6e75 (patch)
tree6904a8e12785bcc6f45ef49d72e6fbf9d8ef63d0 /sci-chemistry/p3d/p3d-0.4.3-r1.ebuild
parentsci-geosciences/gpsd: Clean old version up (diff)
downloadgentoo-9a64979f181d12d3b19c6a0d6f4edaf21a0c6e75.tar.gz
gentoo-9a64979f181d12d3b19c6a0d6f4edaf21a0c6e75.tar.bz2
gentoo-9a64979f181d12d3b19c6a0d6f4edaf21a0c6e75.zip
sci-chemistry/p3d: distutils-r1, git-r3, EAPI=6
Diffstat (limited to 'sci-chemistry/p3d/p3d-0.4.3-r1.ebuild')
-rw-r--r--sci-chemistry/p3d/p3d-0.4.3-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-chemistry/p3d/p3d-0.4.3-r1.ebuild b/sci-chemistry/p3d/p3d-0.4.3-r1.ebuild
new file mode 100644
index 000000000000..6961e1e0e19b
--- /dev/null
+++ b/sci-chemistry/p3d/p3d-0.4.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+GITHUB_ID="gb8b9a75"
+
+DESCRIPTION="Python module for structural bioinformatics"
+HOMEPAGE="http://p3d.fufezan.net/"
+SRC_URI="https://nodeload.github.com/fu/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE="examples"
+
+src_install() {
+ distutils-r1_src_install
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r pdbs exampleScripts
+ fi
+}