summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-06-03 20:07:42 +0100
committerJustin Lecher <jlec@gentoo.org>2017-06-03 20:36:43 +0100
commit98de0462e35852cfb2cad1ee7ac06d682fd5cb0c (patch)
treeeb7c472a237fbf2b3903133de7cfb7074e2bc4ae /sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.0.7.ebuild
parentapp-backup/duply: Version Bump (diff)
downloadgentoo-98de0462e35852cfb2cad1ee7ac06d682fd5cb0c.tar.gz
gentoo-98de0462e35852cfb2cad1ee7ac06d682fd5cb0c.tar.bz2
gentoo-98de0462e35852cfb2cad1ee7ac06d682fd5cb0c.zip
sci-chemistry/pymol-plugins-dynamics: Version Bump
Drop old Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.0.7.ebuild')
-rw-r--r--sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.0.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.0.7.ebuild b/sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.0.7.ebuild
new file mode 100644
index 000000000000..a860012cf6ff
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+MY_PN="Dynamics"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Molecular dynamics in Pymol"
+HOMEPAGE="https://github.com/tomaszmakarewicz/Dynamics"
+SRC_URI="https://github.com/tomaszmakarewicz/Dynamics/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ sci-chemistry/prody[${PYTHON_USEDEP}]
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS=( manual.odt )
+
+src_install() {
+ python_moduleinto pmg_tk/startup
+ python_foreach_impl python_domodule pymol_plugin_dynamics.py
+}