summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/scala
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/scala')
-rw-r--r--sci-chemistry/scala/Manifest1
-rw-r--r--sci-chemistry/scala/files/3.3.18-gcc4.6.patch17
-rw-r--r--sci-chemistry/scala/files/Makefile.am7
-rw-r--r--sci-chemistry/scala/files/configure.ac14
-rw-r--r--sci-chemistry/scala/metadata.xml13
-rw-r--r--sci-chemistry/scala/scala-3.3.20.ebuild38
6 files changed, 90 insertions, 0 deletions
diff --git a/sci-chemistry/scala/Manifest b/sci-chemistry/scala/Manifest
new file mode 100644
index 000000000000..e03416a28733
--- /dev/null
+++ b/sci-chemistry/scala/Manifest
@@ -0,0 +1 @@
+DIST scala-3.3.20.tar.gz 368628 SHA256 0efb108923a4d21fdc75d7ee92567e4bac4ae409f8798fbabd8142b5b026e976 SHA512 9f9812527013d87c80101333baf7ee646f6b3c665cdb477bb4e633c0a1fa57b31b6327913cf712e961c4484a9d9edf1aab5f3cfc66e6834aca1e970a4e0ca898 WHIRLPOOL 7d6082872a9f2f992186a2626dbf7ccd9f827b1322d1399b41ebc1b07267a46cfed5f7ea085403415c01eba4fc44e9d51983080537db04b227469d6871f8f1f9
diff --git a/sci-chemistry/scala/files/3.3.18-gcc4.6.patch b/sci-chemistry/scala/files/3.3.18-gcc4.6.patch
new file mode 100644
index 000000000000..0bb3d40d479a
--- /dev/null
+++ b/sci-chemistry/scala/files/3.3.18-gcc4.6.patch
@@ -0,0 +1,17 @@
+ scala.f | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/scala.f b/scala.f
+index d7e1cbe..8ed6fd2 100644
+--- a/scala.f
++++ b/scala.f
+@@ -3955,7 +3955,8 @@ c line buffer
+ character*40 key, value
+ character*200 realfilename
+
+- integer intfp, i2swap, lenstr
++ integer intfp, lenstr
++ integer*2 i2swap
+ external intfp, i2swap, lenstr
+ logical litend
+ external litend
diff --git a/sci-chemistry/scala/files/Makefile.am b/sci-chemistry/scala/files/Makefile.am
new file mode 100644
index 000000000000..49fd61180ef0
--- /dev/null
+++ b/sci-chemistry/scala/files/Makefile.am
@@ -0,0 +1,7 @@
+
+LIBS = -lccp4f $(LAPACK_LIBS)
+
+bin_PROGRAMS = scala
+
+scala_SOURCES = scala.f
+
diff --git a/sci-chemistry/scala/files/configure.ac b/sci-chemistry/scala/files/configure.ac
new file mode 100644
index 000000000000..35c4c7fdd194
--- /dev/null
+++ b/sci-chemistry/scala/files/configure.ac
@@ -0,0 +1,14 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(scala, https://bugs.gentoo.org/)
+AC_CONFIG_SRCDIR([scala.f])
+AM_INIT_AUTOMAKE([foreign])
+
+PKG_CHECK_MODULES([LAPACK],[lapack])
+
+# Checks for programs.
+AC_PROG_FC
+AC_PROG_F77
+AC_OUTPUT([Makefile])
diff --git a/sci-chemistry/scala/metadata.xml b/sci-chemistry/scala/metadata.xml
new file mode 100644
index 000000000000..2c9359ab3513
--- /dev/null
+++ b/sci-chemistry/scala/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+This program scales together multiple observations of reflections from
+Xray difraction experiments, and merges multiple observations into an
+average intensity.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/scala/scala-3.3.20.ebuild b/sci-chemistry/scala/scala-3.3.20.ebuild
new file mode 100644
index 000000000000..3555cc29a9d1
--- /dev/null
+++ b/sci-chemistry/scala/scala-3.3.20.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools fortran-2
+
+DESCRIPTION="Scale together multiple observations of reflections"
+HOMEPAGE="http://www.ccp4.ac.uk/dist/html/scala.html"
+SRC_URI="ftp://ftp.mrc-lmb.cam.ac.uk/pub/pre/${P}.tar.gz"
+
+LICENSE="ccp4"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ !<sci-chemistry/ccp4-6.1.2
+ !dev-lang/scala-bin
+ !dev-lang/scala
+ sci-libs/ccp4-libs
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ cp "${FILESDIR}"/{configure.ac,Makefile.am} "${S}"
+ eautoreconf
+}
+
+src_install() {
+ exeinto /usr/libexec/ccp4/bin/
+ doexe ${PN}
+ dosym ../libexec/ccp4/bin/${PN} /usr/bin/${PN}
+ dodoc ${PN}.doc
+ dohtml ${PN}.html
+}