summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/sfcheck
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/sfcheck')
-rw-r--r--sci-chemistry/sfcheck/Manifest1
-rw-r--r--sci-chemistry/sfcheck/files/7.03.17-ldflags.patch12
-rw-r--r--sci-chemistry/sfcheck/metadata.xml5
-rw-r--r--sci-chemistry/sfcheck/sfcheck-7.03.18-r1.ebuild42
4 files changed, 60 insertions, 0 deletions
diff --git a/sci-chemistry/sfcheck/Manifest b/sci-chemistry/sfcheck/Manifest
new file mode 100644
index 000000000000..77615cec106b
--- /dev/null
+++ b/sci-chemistry/sfcheck/Manifest
@@ -0,0 +1 @@
+DIST sfcheck-7.03.18.tar.gz 535707 SHA256 def9ceec86fc50f35b9a729e6f84b45a83560e2c6c20a5105647182e10313148 SHA512 256aa1690e0f5ca6aca0483a7d00c1deeb7b77701d950771a134532a658f7c3189bc6abec620ea6da2af200fc879ac9ff07ef7f4ba8614b6cd4e8455a11bed93 WHIRLPOOL 7b9f99f1a8387c5bc63bdab2078d3fcfab4146046429c56503760ca12a1898e944b5aa3c42b358d303206487e5d493bdcb77fe1795490779e7bd79b8b66a2d7a
diff --git a/sci-chemistry/sfcheck/files/7.03.17-ldflags.patch b/sci-chemistry/sfcheck/files/7.03.17-ldflags.patch
new file mode 100644
index 000000000000..4163cb52ac1e
--- /dev/null
+++ b/sci-chemistry/sfcheck/files/7.03.17-ldflags.patch
@@ -0,0 +1,12 @@
+diff --git a/src/makefile b/src/makefile
+index ab43d7d..37e469f 100755
+--- a/src/makefile
++++ b/src/makefile
+@@ -60,6 +60,6 @@ main_sfcheck_ccp4.o: main_sfcheck_ccp4.f sfch_version.fh
+ $(MR_FORT) -c main_sfcheck_ccp4.f
+
+ sfcheck: $(OBJS)
+- $(MR_FORT) -o $(BIN)/sfcheck $(OBJSL) $(MR_LIBRARY)
++ $(MR_FORT) $(LDFLAGS) -o $(BIN)/sfcheck $(OBJSL) $(MR_LIBRARY)
+
+ # ----------------------------------------
diff --git a/sci-chemistry/sfcheck/metadata.xml b/sci-chemistry/sfcheck/metadata.xml
new file mode 100644
index 000000000000..9ac9ffdb3a41
--- /dev/null
+++ b/sci-chemistry/sfcheck/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+</pkgmetadata>
diff --git a/sci-chemistry/sfcheck/sfcheck-7.03.18-r1.ebuild b/sci-chemistry/sfcheck/sfcheck-7.03.18-r1.ebuild
new file mode 100644
index 000000000000..e18673d0923e
--- /dev/null
+++ b/sci-chemistry/sfcheck/sfcheck-7.03.18-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils fortran-2 toolchain-funcs
+
+DESCRIPTION="Program for assessing the agreement between the atomic model and X-ray data or EM map"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~alexei/sfcheck.html"
+#SRC_URI="http://www.ysbl.york.ac.uk/~alexei/downloads/sfcheck.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ccp4"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sci-libs/ccp4-libs"
+DEPEND="${RDEPEND}
+ !<sci-chmistry/ccp4-apps-6.1.3"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/7.03.17-ldflags.patch
+
+ emake -C src clean
+}
+
+src_compile() {
+ MR_FORT="$(tc-getFC) ${FFLAGS}" \
+ MR_LIBRARY="-lccp4f" \
+ emake -C src all
+}
+
+src_install() {
+ exeinto /usr/libexec/ccp4/bin/
+ doexe bin/${PN}
+ dosym ../libexec/ccp4/bin/${PN} /usr/bin/${PN}
+ dodoc readme ${PN}.com.gz doc/${PN}*
+}