summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-04-14 19:35:30 +0100
committerJustin Lecher <jlec@gentoo.org>2017-04-14 19:59:57 +0100
commit8b50a13b56cc9ac53dd7c6770432e1b2155bdc79 (patch)
tree3b01bc0c1b767f741abb3792787b7b1033981a71 /sci-chemistry/threeV/threeV-1.2-r1.ebuild
parentsci-chemistry/ghemical: Bump EAPI to 6 (diff)
downloadgentoo-8b50a13b56cc9ac53dd7c6770432e1b2155bdc79.tar.gz
gentoo-8b50a13b56cc9ac53dd7c6770432e1b2155bdc79.tar.bz2
gentoo-8b50a13b56cc9ac53dd7c6770432e1b2155bdc79.zip
sci-chemistry/threeV: Bump EAPI to 6
fix format-security problems Package-Manager: Portage-2.3.5, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry/threeV/threeV-1.2-r1.ebuild')
-rw-r--r--sci-chemistry/threeV/threeV-1.2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-chemistry/threeV/threeV-1.2-r1.ebuild b/sci-chemistry/threeV/threeV-1.2-r1.ebuild
new file mode 100644
index 000000000000..1d4a1e1f3466
--- /dev/null
+++ b/sci-chemistry/threeV/threeV-1.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="3V: Voss Volume Voxelator"
+HOMEPAGE="http://geometry.molmovdb.org/3v/"
+SRC_URI="http://geometry.molmovdb.org/3v/3v-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+PDEPEND="sci-chemistry/msms-bin"
+# sci-chemistry/usf-rave"
+
+S="${WORKDIR}/3v-${PV}/src"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-format-security.patch
+)
+
+src_prepare() {
+ default
+ tc-export CXX
+ emake distclean
+
+ export MAKEOPTS+=" V=1"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ cd .. || die
+ dodoc AUTHORS ChangeLog QUICKSTART README TODO VERSION
+}