summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/viewmol/viewmol-2.4.1-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/viewmol/viewmol-2.4.1-r2.ebuild')
-rw-r--r--sci-chemistry/viewmol/viewmol-2.4.1-r2.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/sci-chemistry/viewmol/viewmol-2.4.1-r2.ebuild b/sci-chemistry/viewmol/viewmol-2.4.1-r2.ebuild
new file mode 100644
index 000000000000..33fcaab73c3a
--- /dev/null
+++ b/sci-chemistry/viewmol/viewmol-2.4.1-r2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="tk"
+
+inherit eutils multilib prefix python toolchain-funcs
+
+DESCRIPTION="Open-source graphical front end for computational chemistry programs"
+HOMEPAGE="http://viewmol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/viewmol/${P}.src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libpng
+ media-libs/tiff
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ >=x11-libs/motif-2.3:0"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+S="${WORKDIR}/${P}/source"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-remove-icc-check.patch \
+ "${FILESDIR}"/${PV}-change-default-paths.patch
+
+ eprefixify getrc.c
+ sed "s:GENTOOLIBDIR:$(get_libdir):g" \
+ -i install getrc.c || die
+ sed "s:GENTOODOCDIR:${PF}:g" -i install || die
+
+ LINKFORSHARED=$($(PYTHON) -c "import distutils.sysconfig; print distutils.sysconfig.get_config_var('LINKFORSHARED')")
+
+ mkdir $(uname -s) && cd $(uname -s)
+
+ cat >> .config.$(uname -s) <<- EOF
+ LIBTIFF = -L"${EPREFIX}/usr/$(get_libdir)"
+ TIFFINCLUDE = "${EPREFIX}/usr/include"
+ LIBPNG = -L"${EPREFIX}/usr/$(get_libdir)"
+ PNGINCLUDE = "${EPREFIX}/usr/include"
+ PYTHONVERSION = $(PYTHON)
+ PYTHONINCLUDE = "${EPREFIX}/$(python_get_includedir)"
+ PYTHONLIB = "${EPREFIX}/usr/$(get_libdir)"
+ COMPILER = $(tc-getCC)
+ CFLAGS = ${CFLAGS} -DLINUX
+ LDFLAGS = ${LDFLAGS} ${LINKFORSHARED}
+ SCANDIR=
+ INCLUDE=\$(TIFFINCLUDE) -I\$(PNGINCLUDE) -I\$(PYTHONINCLUDE)
+ LIBRARY=\$(LIBTIFF) \$(LIBPNG) -L\$(LIBPYTHON)
+ LIBS=-L"${EPREFIX}/usr/$(get_libdir)" $(python_get_library -l) -ltiff -lpng -lz -lGLU -lGL -L"${EPREFIX}/usr/X11R6/lib" -lXm -lXmu -lXp -lXi -lXext -lXt -lX11 -lpthread -lutil -ldl -lm
+ EOF
+
+ cp .config.$(uname -s) makefile
+ cat ../Makefile >> makefile
+}
+
+src_compile() {
+ pushd $(uname -s)
+ emake viewmol_ tm_ bio_ readgamess_ readgauss_ readmopac_ readpdb_ || die
+ popd
+ "${EPREFIX}"/bin/bash makeTranslations || die
+}
+
+src_install() {
+ ./install "${ED}"/usr || die
+ mv "${ED}"/usr/{usr/share,} || die
+ rm -rf "${ED}"/usr/usr
+}