summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2020-06-21 09:05:56 -0600
committerChristoph Junghans <junghans@gentoo.org>2020-06-21 09:41:38 -0600
commit2756ba25e300e9f7e298b975195c343efcfc5796 (patch)
tree127ab8b5a05773c707db5e6ad2401fb10491a2f6 /sci-chemistry/votca-csg/votca-csg-1.6.1.ebuild
parentsci-libs/votca-tools: version bump (diff)
downloadgentoo-2756ba25e300e9f7e298b975195c343efcfc5796.tar.gz
gentoo-2756ba25e300e9f7e298b975195c343efcfc5796.tar.bz2
gentoo-2756ba25e300e9f7e298b975195c343efcfc5796.zip
sci-chemistry/votca-csg: version bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-chemistry/votca-csg/votca-csg-1.6.1.ebuild')
-rw-r--r--sci-chemistry/votca-csg/votca-csg-1.6.1.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/sci-chemistry/votca-csg/votca-csg-1.6.1.ebuild b/sci-chemistry/votca-csg/votca-csg-1.6.1.ebuild
new file mode 100644
index 000000000000..39920bd3c0a6
--- /dev/null
+++ b/sci-chemistry/votca-csg/votca-csg-1.6.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit bash-completion-r1 cmake-utils multilib
+
+IUSE="doc examples extras +gromacs hdf5"
+PDEPEND="extras? ( ~sci-chemistry/${PN}apps-${PV} )"
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( https://github.com/${PN/-//}-manual/releases/download/v${PV}/${PN}-manual-${PV}.pdf )
+ examples? ( https://github.com/${PN/-//}-tutorials/archive/v${PV}.tar.gz -> ${PN}-tutorials-${PV}.tar.gz )"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ KEYWORDS="~amd64 ~x86"
+ PDEPEND="${PDEPEND} doc? ( ~app-doc/${PN}-manual-${PV} )"
+fi
+
+DESCRIPTION="Votca coarse-graining engine"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ ~sci-libs/votca-tools-${PV}
+ >=dev-cpp/eigen-3.3
+ gromacs? ( sci-chemistry/gromacs:= )
+ hdf5? ( sci-libs/hdf5 )
+ dev-lang/perl
+ app-shells/bash:*"
+
+DEPEND="${RDEPEND}
+ >=app-text/txt2tags-2.5
+ virtual/pkgconfig"
+
+DOCS=( README.md NOTICE CHANGELOG.md )
+
+src_unpack() {
+ if [[ ${PV} != *9999 ]]; then
+ default
+ else
+ git-r3_src_unpack
+ if use examples; then
+ EGIT_REPO_URI="https://github.com/${PN/-//}-tutorials.git"
+ EGIT_BRANCH="master"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PN#votca-}-tutorials"\
+ git-r3_src_unpack
+ fi
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_GMX=$(usex gromacs)
+ -DCMAKE_DISABLE_FIND_PACKAGE_HDF5=$(usex '!hdf5')
+ -DWITH_RC_FILES=OFF
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newbashcomp "${ED}"/usr/share/votca/rc/csg-completion.bash csg_call
+ for i in "${ED}"/usr/bin/csg_*; do
+ [[ ${i} = *csg_call ]] && continue
+ bashcomp_alias csg_call "${i##*/}"
+ done
+ if use doc; then
+ [[ ${PV} != *9999* ]] && dodoc "${DISTDIR}/${PN}-manual-${PV}.pdf"
+ fi
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/tutorials"
+ docompress -x "/usr/share/doc/${PF}/tutorials"
+ rm -rf "${WORKDIR}/${PN#votca-}"-tutorials*/CMake*
+ doins -r "${WORKDIR}/${PN#votca-}"-tutorials*/*
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read and cite:"
+ einfo "VOTCA, J. Chem. Theory Comput. 5, 3211 (2009). "
+ einfo "https://dx.doi.org/10.1021/ct900369w"
+ einfo
+}