summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2021-01-12 17:46:42 -0700
committerChristoph Junghans <junghans@gentoo.org>2021-01-12 18:20:24 -0700
commite25a6ed7fcd124c68b92d71d409dc9d85d1f7165 (patch)
tree5b83f4527fb3f1999022726e6fdc5d7e1c69f75e /sci-chemistry/votca-csg
parentsci-chemistry/votca-csgapps: add v1.6.4 (diff)
downloadgentoo-e25a6ed7fcd124c68b92d71d409dc9d85d1f7165.tar.gz
gentoo-e25a6ed7fcd124c68b92d71d409dc9d85d1f7165.tar.bz2
gentoo-e25a6ed7fcd124c68b92d71d409dc9d85d1f7165.zip
sci-chemistry/votca-csg: live ebuild updates
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-chemistry/votca-csg')
-rw-r--r--sci-chemistry/votca-csg/votca-csg-9999.ebuild7
1 files changed, 1 insertions, 6 deletions
diff --git a/sci-chemistry/votca-csg/votca-csg-9999.ebuild b/sci-chemistry/votca-csg/votca-csg-9999.ebuild
index 0f23782e0f18..562ae3f8fdf8 100644
--- a/sci-chemistry/votca-csg/votca-csg-9999.ebuild
+++ b/sci-chemistry/votca-csg/votca-csg-9999.ebuild
@@ -8,10 +8,8 @@ CMAKE_MAKEFILE_GENERATOR="ninja"
inherit bash-completion-r1 cmake multilib
IUSE="doc examples extras +gromacs hdf5"
-PDEPEND="extras? ( ~sci-chemistry/${PN}apps-${PV} )"
if [ "${PV}" != "9999" ]; then
SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- doc? ( https://github.com/${PN/-//}-manual/releases/download/v${PV}/${PN}-manual-${PV}.pdf )
examples? ( https://github.com/${PN/-//}-tutorials/archive/v${PV}.tar.gz -> ${PN}-tutorials-${PV}.tar.gz )"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
S="${WORKDIR}/${P#votca-}"
@@ -19,7 +17,6 @@ else
inherit git-r3
EGIT_REPO_URI="https://github.com/${PN/-//}.git"
KEYWORDS=""
- PDEPEND="${PDEPEND} doc? ( ~app-doc/${PN}-manual-${PV} )"
fi
DESCRIPTION="Votca coarse-graining engine"
@@ -61,6 +58,7 @@ src_configure() {
-DWITH_GMX=$(usex gromacs)
-DCMAKE_DISABLE_FIND_PACKAGE_HDF5=$(usex '!hdf5')
-DWITH_RC_FILES=OFF
+ -DBUILD_CSGAPPS=ON
)
cmake_src_configure
}
@@ -72,9 +70,6 @@ src_install() {
[[ ${i} = *csg_call ]] && continue
bashcomp_alias csg_call "${i##*/}"
done
- if use doc; then
- [[ ${PV} != *9999* ]] && dodoc "${DISTDIR}/${PN}-manual-${PV}.pdf"
- fi
if use examples; then
insinto "/usr/share/doc/${PF}/tutorials"
docompress -x "/usr/share/doc/${PF}/tutorials"