summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2019-11-21 18:59:01 -0700
committerChristoph Junghans <junghans@gentoo.org>2019-11-21 19:26:28 -0700
commitf58f2b927229a8a6dc09f344825310a6f415abd2 (patch)
treea01264eb10d8c6afa2cb68feb2a2558e509ff643 /sci-chemistry/votca-xtp/votca-xtp-1.5.1.ebuild
parentsci-chemistry/votca-ctp: Version bump (diff)
downloadgentoo-f58f2b927229a8a6dc09f344825310a6f415abd2.tar.gz
gentoo-f58f2b927229a8a6dc09f344825310a6f415abd2.tar.bz2
gentoo-f58f2b927229a8a6dc09f344825310a6f415abd2.zip
sci-chemistry/votca-xtp: version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-chemistry/votca-xtp/votca-xtp-1.5.1.ebuild')
-rw-r--r--sci-chemistry/votca-xtp/votca-xtp-1.5.1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/sci-chemistry/votca-xtp/votca-xtp-1.5.1.ebuild b/sci-chemistry/votca-xtp/votca-xtp-1.5.1.ebuild
new file mode 100644
index 000000000000..3d34efdc74c2
--- /dev/null
+++ b/sci-chemistry/votca-xtp/votca-xtp-1.5.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit bash-completion-r1 cmake-utils multilib
+
+IUSE="doc"
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( https://github.com/${PN/-//}/releases/download/v${PV}/${PN}-manual-${PV}.pdf )"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Votca excitation and charge properties module"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ ~sci-libs/votca-tools-${PV}[sqlite]
+ >=dev-cpp/eigen-3.3
+ ~sci-chemistry/votca-csg-${PV}
+ sci-libs/ceres-solver
+ sci-libs/libxc"
+
+DEPEND="${RDEPEND}
+ >=app-text/txt2tags-2.5
+ virtual/pkgconfig"
+
+if [ "${PV}" != "9999" ]; then
+ DEPEND="${DEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ dev-tex/pgf
+ )"
+fi
+
+DOCS=( README.md NOTICE CHANGELOG.md )
+
+src_configure() {
+ [[ ${PV} = *9999* ]] && mycmakeargs=(
+ -DBUILD_XTP_MANUAL=$(usex doc)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc; then
+ [[ ${PV} != *9999* ]] && dodoc "${DISTDIR}/${PN}-manual-${PV}.pdf"
+ cmake-utils_src_make -C "${CMAKE_BUILD_DIR}" html
+ dodoc -r "${CMAKE_BUILD_DIR}"/share/doc/html
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read and cite:"
+ einfo "VOTCA-XTP, J. Chem. Theo. Comp. 14, 6353 (2018)"
+ einfo "https://doi.org/10.1021/acs.jctc.8b00617"
+ einfo
+}