summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2020-01-12 14:50:56 -0700
committerChristoph Junghans <junghans@gentoo.org>2020-01-12 14:51:10 -0700
commit4111b6c8c2d278a4fb310f13cddd004713ecf959 (patch)
tree4aa7a97c58513574ab48a0fb5a974acb93afe06b /sci-chemistry/votca-xtp/votca-xtp-1.6_rc1.ebuild
parentsci-chemistry/votca-csgapps: version bump (diff)
downloadgentoo-4111b6c8c2d278a4fb310f13cddd004713ecf959.tar.gz
gentoo-4111b6c8c2d278a4fb310f13cddd004713ecf959.tar.bz2
gentoo-4111b6c8c2d278a4fb310f13cddd004713ecf959.zip
sci-chemistry/votca-xtp: version bump
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-chemistry/votca-xtp/votca-xtp-1.6_rc1.ebuild')
-rw-r--r--sci-chemistry/votca-xtp/votca-xtp-1.6_rc1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-chemistry/votca-xtp/votca-xtp-1.6_rc1.ebuild b/sci-chemistry/votca-xtp/votca-xtp-1.6_rc1.ebuild
new file mode 100644
index 000000000000..4de1f7f7474f
--- /dev/null
+++ b/sci-chemistry/votca-xtp/votca-xtp-1.6_rc1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit bash-completion-r1 cmake-utils multilib
+
+IUSE=""
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Votca excitation and charge properties module"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ ~sci-libs/votca-tools-${PV}
+ >=dev-cpp/eigen-3.3
+ ~sci-chemistry/votca-csg-${PV}
+ sci-libs/libxc"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README.md NOTICE CHANGELOG.md )
+
+pkg_postinst() {
+ einfo
+ einfo "Please read and cite:"
+ einfo "VOTCA-XTP, J. Chem. Theo. Comp. 14, 6353 (2018)"
+ einfo "https://doi.org/10.1021/acs.jctc.8b00617"
+ einfo
+}