summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/xia2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/xia2')
-rw-r--r--sci-chemistry/xia2/Manifest6
-rw-r--r--sci-chemistry/xia2/files/0.3.1.0-fix-syntax.patch61
-rw-r--r--sci-chemistry/xia2/files/0.3.1.6-fix-syntax.patch61
-rw-r--r--sci-chemistry/xia2/files/0.3.1.7-fix-syntax.patch61
-rw-r--r--sci-chemistry/xia2/files/0.3.3.1-fix-syntax.patch61
-rw-r--r--sci-chemistry/xia2/files/0.3.3.3-fix-syntax.patch28
-rw-r--r--sci-chemistry/xia2/files/0.3.4.0-fix-syntax.patch28
-rw-r--r--sci-chemistry/xia2/metadata.xml5
-rw-r--r--sci-chemistry/xia2/xia2-0.3.1.0.ebuild59
-rw-r--r--sci-chemistry/xia2/xia2-0.3.1.6.ebuild66
-rw-r--r--sci-chemistry/xia2/xia2-0.3.1.7.ebuild66
-rw-r--r--sci-chemistry/xia2/xia2-0.3.3.1.ebuild70
-rw-r--r--sci-chemistry/xia2/xia2-0.3.3.3.ebuild70
-rw-r--r--sci-chemistry/xia2/xia2-0.3.4.0.ebuild70
14 files changed, 712 insertions, 0 deletions
diff --git a/sci-chemistry/xia2/Manifest b/sci-chemistry/xia2/Manifest
new file mode 100644
index 000000000000..e7fa594c3ec9
--- /dev/null
+++ b/sci-chemistry/xia2/Manifest
@@ -0,0 +1,6 @@
+DIST xia2-0.3.1.0.tar.bz2 3389906 SHA256 32f1866bc17b093cbf157ec7bc217e47d059957104b20c88ed1b5c3706fc7e28
+DIST xia2-0.3.1.6.tar.bz2 3464982 SHA256 fde814a763e6666a1618d01569c19d574f1bf71d754dc3960beeb13c35dd201f
+DIST xia2-0.3.1.7.tar.bz2 3650285 SHA256 54beb26396c4b6ecb343544c777c2505238385f2127482d035d2c47b24a7fcf1
+DIST xia2-0.3.3.1.tar.bz2 3074989 SHA256 f1bf94cd9305f768fea1b541ac53d66917126e92620263a96f9c23923ec829c4
+DIST xia2-0.3.3.3.tar.bz2 2919316 SHA256 3cf09fcf9d2c0ea6d6cb8cf66a3c5af752b4345af6a882e2d398424cf3b4b0d3
+DIST xia2-0.3.4.0.tar.bz2 21404771 SHA256 20afe3d24c35446ef8c8944974d684229f053d3916e96e46766d8eefa4c5fabf
diff --git a/sci-chemistry/xia2/files/0.3.1.0-fix-syntax.patch b/sci-chemistry/xia2/files/0.3.1.0-fix-syntax.patch
new file mode 100644
index 000000000000..9d92af7e33ce
--- /dev/null
+++ b/sci-chemistry/xia2/files/0.3.1.0-fix-syntax.patch
@@ -0,0 +1,61 @@
+diff --git a/xia2-0.3.1.0/Applications/xia2find.py b/xia2-0.3.1.0/Applications/xia2find.py
+index 1a3b0e2..e0b8a1e 100755
+--- a/xia2-0.3.1.0/Applications/xia2find.py
++++ b/xia2-0.3.1.0/Applications/xia2find.py
+@@ -38,7 +38,7 @@ from Schema.Sweep import SweepFactory
+ from Experts.FindImages import image2template_directory
+
+ known_image_extensions = ['img', 'mccd', 'mar2300', 'mar1200', 'mar3450',
+- 'osc', 'cbf', 'mar2000']]
++ 'osc', 'cbf', 'mar2000']
+ known_sweeps = { }
+
+ def is_image_name(file):
+diff --git a/xia2-0.3.1.0/Experts/DRStrategyExpert.py b/xia2-0.3.1.0/Experts/DRStrategyExpert.py
+index 28b1dc3..dba3ef7 100644
+--- a/xia2-0.3.1.0/Experts/DRStrategyExpert.py
++++ b/xia2-0.3.1.0/Experts/DRStrategyExpert.py
+@@ -48,24 +48,24 @@ strategy_dict = {
+ 'default':{
+ 'score':1,
+ 'pipeline':{
+- 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'}
++ 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'},
+ 'depends-on':['labelit.screen', 'xds', 'xscale', 'scala', 'combat',
+ 'pointless-1.1.0.4']},
+ 'default':{
+ 'score':2,
+ 'pipeline':{
+- 'indexer':'labelit', 'integrater':'mosflm', 'scaler':'mosflm'}
++ 'indexer':'labelit', 'integrater':'mosflm', 'scaler':'mosflm'},
+ 'depends-on':['labelit.screen', 'mosflm', 'scala', 'reindex',
+ 'pointless-1.1.0.4']},
+ 'mosaic':{
+ 'score':1,
+ 'pipeline':{
+- 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'}
++ 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'},
+ 'depends-on':['labelit.screen', 'xds', 'xscale', 'scala', 'combat',
+ 'pointless-1.1.0.4']},
+ 'mosaic':{
+ 'score':2,
+ 'pipeline':{
+- 'indexer':'xds', 'integrater':'xds', 'scaler':'xds'}
++ 'indexer':'xds', 'integrater':'xds', 'scaler':'xds'},
+ 'depends-on':['xds', 'xscale']}
+ }
+diff --git a/xia2core-0.3.1.0/Python/Examples/CCP4/Cad.py b/xia2core-0.3.1.0/Python/Examples/CCP4/Cad.py
+index 88f9218..5fb6f2a 100644
+--- a/xia2core-0.3.1.0/Python/Examples/CCP4/Cad.py
++++ b/xia2core-0.3.1.0/Python/Examples/CCP4/Cad.py
+@@ -49,8 +49,8 @@ def Cad(DriverType = None):
+ self.add_command_line(hklin)
+
+ self.set_task('Rewriting reflections %s => %s' %
+- ` (os.path.split(hklin)[-1],
+- ` os.path.split(self.getHklout())[-1]))
++ (os.path.split(hklin)[-1],
++ os.path.split(self.getHklout())[-1]))
+
+ self.start()
+
diff --git a/sci-chemistry/xia2/files/0.3.1.6-fix-syntax.patch b/sci-chemistry/xia2/files/0.3.1.6-fix-syntax.patch
new file mode 100644
index 000000000000..7770a53c4451
--- /dev/null
+++ b/sci-chemistry/xia2/files/0.3.1.6-fix-syntax.patch
@@ -0,0 +1,61 @@
+diff --git a/xia2-0.3.1.6/Applications/xia2find.py b/xia2-0.3.1.6/Applications/xia2find.py
+index 1a3b0e2..e0b8a1e 100755
+--- a/xia2-0.3.1.6/Applications/xia2find.py
++++ b/xia2-0.3.1.6/Applications/xia2find.py
+@@ -38,7 +38,7 @@ from Schema.Sweep import SweepFactory
+ from Experts.FindImages import image2template_directory
+
+ known_image_extensions = ['img', 'mccd', 'mar2300', 'mar1200', 'mar3450',
+- 'osc', 'cbf', 'mar2000']]
++ 'osc', 'cbf', 'mar2000']
+ known_sweeps = { }
+
+ def is_image_name(file):
+diff --git a/xia2-0.3.1.6/Experts/DRStrategyExpert.py b/xia2-0.3.1.6/Experts/DRStrategyExpert.py
+index 28b1dc3..dba3ef7 100644
+--- a/xia2-0.3.1.6/Experts/DRStrategyExpert.py
++++ b/xia2-0.3.1.6/Experts/DRStrategyExpert.py
+@@ -48,24 +48,24 @@ strategy_dict = {
+ 'default':{
+ 'score':1,
+ 'pipeline':{
+- 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'}
++ 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'},
+ 'depends-on':['labelit.screen', 'xds', 'xscale', 'scala', 'combat',
+ 'pointless-1.1.0.4']},
+ 'default':{
+ 'score':2,
+ 'pipeline':{
+- 'indexer':'labelit', 'integrater':'mosflm', 'scaler':'mosflm'}
++ 'indexer':'labelit', 'integrater':'mosflm', 'scaler':'mosflm'},
+ 'depends-on':['labelit.screen', 'mosflm', 'scala', 'reindex',
+ 'pointless-1.1.0.4']},
+ 'mosaic':{
+ 'score':1,
+ 'pipeline':{
+- 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'}
++ 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'},
+ 'depends-on':['labelit.screen', 'xds', 'xscale', 'scala', 'combat',
+ 'pointless-1.1.0.4']},
+ 'mosaic':{
+ 'score':2,
+ 'pipeline':{
+- 'indexer':'xds', 'integrater':'xds', 'scaler':'xds'}
++ 'indexer':'xds', 'integrater':'xds', 'scaler':'xds'},
+ 'depends-on':['xds', 'xscale']}
+ }
+diff --git a/xia2core-0.3.1.6/Python/Examples/CCP4/Cad.py b/xia2core-0.3.1.6/Python/Examples/CCP4/Cad.py
+index 88f9218..5fb6f2a 100644
+--- a/xia2core-0.3.1.6/Python/Examples/CCP4/Cad.py
++++ b/xia2core-0.3.1.6/Python/Examples/CCP4/Cad.py
+@@ -49,8 +49,8 @@ def Cad(DriverType = None):
+ self.add_command_line(hklin)
+
+ self.set_task('Rewriting reflections %s => %s' %
+- ` (os.path.split(hklin)[-1],
+- ` os.path.split(self.getHklout())[-1]))
++ (os.path.split(hklin)[-1],
++ os.path.split(self.getHklout())[-1]))
+
+ self.start()
+
diff --git a/sci-chemistry/xia2/files/0.3.1.7-fix-syntax.patch b/sci-chemistry/xia2/files/0.3.1.7-fix-syntax.patch
new file mode 100644
index 000000000000..ec8ada48aad1
--- /dev/null
+++ b/sci-chemistry/xia2/files/0.3.1.7-fix-syntax.patch
@@ -0,0 +1,61 @@
+diff --git a/xia2-0.3.1.7/Applications/xia2find.py b/xia2-0.3.1.7/Applications/xia2find.py
+index 1a3b0e2..e0b8a1e 100755
+--- a/xia2-0.3.1.7/Applications/xia2find.py
++++ b/xia2-0.3.1.7/Applications/xia2find.py
+@@ -38,7 +38,7 @@ from Schema.Sweep import SweepFactory
+ from Experts.FindImages import image2template_directory
+
+ known_image_extensions = ['img', 'mccd', 'mar2300', 'mar1200', 'mar3450',
+- 'osc', 'cbf', 'mar2000']]
++ 'osc', 'cbf', 'mar2000']
+ known_sweeps = { }
+
+ def is_image_name(file):
+diff --git a/xia2-0.3.1.7/Experts/DRStrategyExpert.py b/xia2-0.3.1.7/Experts/DRStrategyExpert.py
+index 28b1dc3..dba3ef7 100644
+--- a/xia2-0.3.1.7/Experts/DRStrategyExpert.py
++++ b/xia2-0.3.1.7/Experts/DRStrategyExpert.py
+@@ -48,24 +48,24 @@ strategy_dict = {
+ 'default':{
+ 'score':1,
+ 'pipeline':{
+- 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'}
++ 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'},
+ 'depends-on':['labelit.screen', 'xds', 'xscale', 'scala', 'combat',
+ 'pointless-1.1.0.4']},
+ 'default':{
+ 'score':2,
+ 'pipeline':{
+- 'indexer':'labelit', 'integrater':'mosflm', 'scaler':'mosflm'}
++ 'indexer':'labelit', 'integrater':'mosflm', 'scaler':'mosflm'},
+ 'depends-on':['labelit.screen', 'mosflm', 'scala', 'reindex',
+ 'pointless-1.1.0.4']},
+ 'mosaic':{
+ 'score':1,
+ 'pipeline':{
+- 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'}
++ 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'},
+ 'depends-on':['labelit.screen', 'xds', 'xscale', 'scala', 'combat',
+ 'pointless-1.1.0.4']},
+ 'mosaic':{
+ 'score':2,
+ 'pipeline':{
+- 'indexer':'xds', 'integrater':'xds', 'scaler':'xds'}
++ 'indexer':'xds', 'integrater':'xds', 'scaler':'xds'},
+ 'depends-on':['xds', 'xscale']}
+ }
+diff --git a/xia2core-0.3.1.7/Python/Examples/CCP4/Cad.py b/xia2core-0.3.1.7/Python/Examples/CCP4/Cad.py
+index 88f9218..5fb6f2a 100644
+--- a/xia2core-0.3.1.7/Python/Examples/CCP4/Cad.py
++++ b/xia2core-0.3.1.7/Python/Examples/CCP4/Cad.py
+@@ -49,8 +49,8 @@ def Cad(DriverType = None):
+ self.add_command_line(hklin)
+
+ self.set_task('Rewriting reflections %s => %s' %
+- ` (os.path.split(hklin)[-1],
+- ` os.path.split(self.getHklout())[-1]))
++ (os.path.split(hklin)[-1],
++ os.path.split(self.getHklout())[-1]))
+
+ self.start()
+
diff --git a/sci-chemistry/xia2/files/0.3.3.1-fix-syntax.patch b/sci-chemistry/xia2/files/0.3.3.1-fix-syntax.patch
new file mode 100644
index 000000000000..36cf6bb60d1d
--- /dev/null
+++ b/sci-chemistry/xia2/files/0.3.3.1-fix-syntax.patch
@@ -0,0 +1,61 @@
+diff --git a/xia2-0.3.3.0/Applications/xia2find.py b/xia2-0.3.3.0/Applications/xia2find.py
+index 1a3b0e2..e0b8a1e 100755
+--- a/xia2-0.3.3.1/Applications/xia2find.py
++++ b/xia2-0.3.3.1/Applications/xia2find.py
+@@ -38,7 +38,7 @@ from Schema.Sweep import SweepFactory
+ from Experts.FindImages import image2template_directory
+
+ known_image_extensions = ['img', 'mccd', 'mar2300', 'mar1200', 'mar3450',
+- 'osc', 'cbf', 'mar2000']]
++ 'osc', 'cbf', 'mar2000']
+ known_sweeps = { }
+
+ def is_image_name(file):
+diff --git a/xia2-0.3.3.0/Experts/DRStrategyExpert.py b/xia2-0.3.3.0/Experts/DRStrategyExpert.py
+index 28b1dc3..dba3ef7 100644
+--- a/xia2-0.3.3.1/Experts/DRStrategyExpert.py
++++ b/xia2-0.3.3.1/Experts/DRStrategyExpert.py
+@@ -48,24 +48,24 @@ strategy_dict = {
+ 'default':{
+ 'score':1,
+ 'pipeline':{
+- 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'}
++ 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'},
+ 'depends-on':['labelit.screen', 'xds', 'xscale', 'scala', 'combat',
+ 'pointless-1.1.0.4']},
+ 'default':{
+ 'score':2,
+ 'pipeline':{
+- 'indexer':'labelit', 'integrater':'mosflm', 'scaler':'mosflm'}
++ 'indexer':'labelit', 'integrater':'mosflm', 'scaler':'mosflm'},
+ 'depends-on':['labelit.screen', 'mosflm', 'scala', 'reindex',
+ 'pointless-1.1.0.4']},
+ 'mosaic':{
+ 'score':1,
+ 'pipeline':{
+- 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'}
++ 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'},
+ 'depends-on':['labelit.screen', 'xds', 'xscale', 'scala', 'combat',
+ 'pointless-1.1.0.4']},
+ 'mosaic':{
+ 'score':2,
+ 'pipeline':{
+- 'indexer':'xds', 'integrater':'xds', 'scaler':'xds'}
++ 'indexer':'xds', 'integrater':'xds', 'scaler':'xds'},
+ 'depends-on':['xds', 'xscale']}
+ }
+diff --git a/xia2core-0.3.3.0/Python/Examples/CCP4/Cad.py b/xia2core-0.3.3.0/Python/Examples/CCP4/Cad.py
+index 88f9218..5fb6f2a 100644
+--- a/xia2core-0.3.3.1/Python/Examples/CCP4/Cad.py
++++ b/xia2core-0.3.3.1/Python/Examples/CCP4/Cad.py
+@@ -49,8 +49,8 @@ def Cad(DriverType = None):
+ self.add_command_line(hklin)
+
+ self.set_task('Rewriting reflections %s => %s' %
+- ` (os.path.split(hklin)[-1],
+- ` os.path.split(self.getHklout())[-1]))
++ (os.path.split(hklin)[-1],
++ os.path.split(self.getHklout())[-1]))
+
+ self.start()
+
diff --git a/sci-chemistry/xia2/files/0.3.3.3-fix-syntax.patch b/sci-chemistry/xia2/files/0.3.3.3-fix-syntax.patch
new file mode 100644
index 000000000000..53cacbb5c681
--- /dev/null
+++ b/sci-chemistry/xia2/files/0.3.3.3-fix-syntax.patch
@@ -0,0 +1,28 @@
+diff --git a/xia2-0.3.3.0/Applications/xia2find.py b/xia2-0.3.3.0/Applications/xia2find.py
+index 1a3b0e2..e0b8a1e 100755
+--- a/xia2-0.3.3.3/Applications/xia2find.py
++++ b/xia2-0.3.3.3/Applications/xia2find.py
+@@ -38,7 +38,7 @@ from Schema.Sweep import SweepFactory
+ from Experts.FindImages import image2template_directory
+
+ known_image_extensions = ['img', 'mccd', 'mar2300', 'mar1200', 'mar3450',
+- 'osc', 'cbf', 'mar2000']]
++ 'osc', 'cbf', 'mar2000']
+ known_sweeps = { }
+
+ def is_image_name(file):
+diff --git a/xia2core-0.3.3.0/Python/Examples/CCP4/Cad.py b/xia2core-0.3.3.0/Python/Examples/CCP4/Cad.py
+index 88f9218..5fb6f2a 100644
+--- a/xia2core-0.3.3.3/Python/Examples/CCP4/Cad.py
++++ b/xia2core-0.3.3.3/Python/Examples/CCP4/Cad.py
+@@ -49,8 +49,8 @@ def Cad(DriverType = None):
+ self.add_command_line(hklin)
+
+ self.set_task('Rewriting reflections %s => %s' %
+- ` (os.path.split(hklin)[-1],
+- ` os.path.split(self.getHklout())[-1]))
++ (os.path.split(hklin)[-1],
++ os.path.split(self.getHklout())[-1]))
+
+ self.start()
+
diff --git a/sci-chemistry/xia2/files/0.3.4.0-fix-syntax.patch b/sci-chemistry/xia2/files/0.3.4.0-fix-syntax.patch
new file mode 100644
index 000000000000..9ba4c94495ea
--- /dev/null
+++ b/sci-chemistry/xia2/files/0.3.4.0-fix-syntax.patch
@@ -0,0 +1,28 @@
+diff --git a/xia2-0.3.3.0/Applications/xia2find.py b/xia2-0.3.3.0/Applications/xia2find.py
+index 1a3b0e2..e0b8a1e 100755
+--- a/xia2-0.3.4.0/Applications/xia2find.py
++++ b/xia2-0.3.4.0/Applications/xia2find.py
+@@ -38,7 +38,7 @@ from Schema.Sweep import SweepFactory
+ from Experts.FindImages import image2template_directory
+
+ known_image_extensions = ['img', 'mccd', 'mar2300', 'mar1200', 'mar3450',
+- 'osc', 'cbf', 'mar2000']]
++ 'osc', 'cbf', 'mar2000']
+ known_sweeps = { }
+
+ def is_image_name(file):
+diff --git a/xia2core-0.3.3.0/Python/Examples/CCP4/Cad.py b/xia2core-0.3.3.0/Python/Examples/CCP4/Cad.py
+index 88f9218..5fb6f2a 100644
+--- a/xia2core-0.3.4.0/Python/Examples/CCP4/Cad.py
++++ b/xia2core-0.3.4.0/Python/Examples/CCP4/Cad.py
+@@ -49,8 +49,8 @@ def Cad(DriverType = None):
+ self.add_command_line(hklin)
+
+ self.set_task('Rewriting reflections %s => %s' %
+- ` (os.path.split(hklin)[-1],
+- ` os.path.split(self.getHklout())[-1]))
++ (os.path.split(hklin)[-1],
++ os.path.split(self.getHklout())[-1]))
+
+ self.start()
+
diff --git a/sci-chemistry/xia2/metadata.xml b/sci-chemistry/xia2/metadata.xml
new file mode 100644
index 000000000000..9ac9ffdb3a41
--- /dev/null
+++ b/sci-chemistry/xia2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+</pkgmetadata>
diff --git a/sci-chemistry/xia2/xia2-0.3.1.0.ebuild b/sci-chemistry/xia2/xia2-0.3.1.0.ebuild
new file mode 100644
index 000000000000..33b3d841acfa
--- /dev/null
+++ b/sci-chemistry/xia2/xia2-0.3.1.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils python
+
+DESCRIPTION="An automated data reduction system for crystallography"
+HOMEPAGE="http://www.ccp4.ac.uk/xia/"
+SRC_URI="http://www.ccp4.ac.uk/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=sci-chemistry/ccp4-apps-6.1.2
+ sci-chemistry/mosflm
+ sci-chemistry/pointless
+ >=sci-libs/ccp4-libs-6.1.2
+ sci-libs/cctbx"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ find . -name '*.bat' | xargs rm || die
+
+ epatch "${FILESDIR}"/${PV}-fix-syntax.patch
+}
+
+src_install() {
+ rm -rf ${P}/binaries ${PN}core-${PV}/Test || die
+
+ insinto /usr/share/ccp4/XIAROOT/
+ doins -r * || die
+
+ # Set programs executable
+# fperms cannot handle wildcards
+ chmod 755 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/* || die
+ chmod 644 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/*.py || die
+
+ cat >> "${T}"/23XIA <<- EOF
+ XIA2_HOME="${EPREFIX}"/usr/share/ccp4/XIAROOT
+ XIA2CORE_ROOT="${EPREFIX}"/usr/share/ccp4/XIAROOT/xia2core-${PV}
+ XIA2_ROOT="${EPREFIX}"/usr/share/ccp4/XIAROOT/xia2-${PV}
+ PATH="${EPREFIX}"/usr/share/ccp4/XIAROOT/xia2-${PV}/Applications
+ EOF
+
+ doenvd "${T}"/23XIA
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/ccp4/XIAROOT
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/ccp4/XIAROOT
+}
diff --git a/sci-chemistry/xia2/xia2-0.3.1.6.ebuild b/sci-chemistry/xia2/xia2-0.3.1.6.ebuild
new file mode 100644
index 000000000000..537735e1351f
--- /dev/null
+++ b/sci-chemistry/xia2/xia2-0.3.1.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="An automated data reduction system for crystallography"
+HOMEPAGE="http://www.ccp4.ac.uk/xia/"
+SRC_URI="http://www.ccp4.ac.uk/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=sci-chemistry/ccp4-apps-6.1.2
+ sci-chemistry/mosflm
+ sci-chemistry/pointless
+ >=sci-libs/ccp4-libs-6.1.2
+ sci-libs/cctbx"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ find . -name '*.bat' -delete || die
+
+ epatch "${FILESDIR}"/${PV}-fix-syntax.patch
+ python_convert_shebangs -r $(python_get_version) .
+}
+
+src_install() {
+ rm -rf ${P}/binaries ${PN}core-${PV}/Test || die
+
+ insinto /usr/share/ccp4/XIAROOT/
+ doins -r * || die
+
+ # Set programs executable
+# fperms cannot handle wildcards
+ chmod 755 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/* || die
+ chmod 644 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/*.py || die
+
+ cat >> "${T}"/23XIA <<- EOF
+ XIA2_HOME="${EPREFIX}"/usr/share/ccp4/XIAROOT
+ XIA2CORE_ROOT="${EPREFIX}"/usr/share/ccp4/XIAROOT/xia2core-${PV}
+ XIA2_ROOT="${EPREFIX}"/usr/share/ccp4/XIAROOT/xia2-${PV}
+ PATH="${EPREFIX}"/usr/share/ccp4/XIAROOT/xia2-${PV}/Applications
+ EOF
+
+ doenvd "${T}"/23XIA
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/ccp4/XIAROOT
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/ccp4/XIAROOT
+}
diff --git a/sci-chemistry/xia2/xia2-0.3.1.7.ebuild b/sci-chemistry/xia2/xia2-0.3.1.7.ebuild
new file mode 100644
index 000000000000..16fbf797d1b4
--- /dev/null
+++ b/sci-chemistry/xia2/xia2-0.3.1.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="An automated data reduction system for crystallography"
+HOMEPAGE="http://www.ccp4.ac.uk/xia/"
+SRC_URI="http://www.ccp4.ac.uk/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=sci-chemistry/ccp4-apps-6.1.2
+ sci-chemistry/mosflm
+ sci-chemistry/pointless
+ >=sci-libs/ccp4-libs-6.1.2
+ sci-libs/cctbx"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ find . -name '*.bat' -delete || die
+
+ epatch "${FILESDIR}"/${PV}-fix-syntax.patch
+ python_convert_shebangs -r $(python_get_version) .
+}
+
+src_install() {
+ rm -rf ${P}/binaries ${PN}core-${PV}/Test || die
+
+ insinto /usr/share/ccp4/XIAROOT/
+ doins -r * || die
+
+ # Set programs executable
+# fperms cannot handle wildcards
+ chmod 755 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/* || die
+ chmod 644 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/*.py || die
+
+ cat >> "${T}"/23XIA <<- EOF
+ XIA2_HOME="${EPREFIX}"/usr/share/ccp4/XIAROOT
+ XIA2CORE_ROOT="${EPREFIX}"/usr/share/ccp4/XIAROOT/xia2core-${PV}
+ XIA2_ROOT="${EPREFIX}"/usr/share/ccp4/XIAROOT/xia2-${PV}
+ PATH="${EPREFIX}"/usr/share/ccp4/XIAROOT/xia2-${PV}/Applications
+ EOF
+
+ doenvd "${T}"/23XIA
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/ccp4/XIAROOT
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/ccp4/XIAROOT
+}
diff --git a/sci-chemistry/xia2/xia2-0.3.3.1.ebuild b/sci-chemistry/xia2/xia2-0.3.3.1.ebuild
new file mode 100644
index 000000000000..26fb7d0d4c83
--- /dev/null
+++ b/sci-chemistry/xia2/xia2-0.3.3.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="An automated data reduction system for crystallography"
+HOMEPAGE="http://www.ccp4.ac.uk/xia/"
+SRC_URI="http://www.ccp4.ac.uk/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=sci-chemistry/ccp4-apps-6.1.2
+ sci-chemistry/mosflm
+ sci-chemistry/pointless
+ >=sci-libs/ccp4-libs-6.1.2
+ sci-libs/cctbx"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ find . -name '*.bat' -delete || die
+
+ epatch "${FILESDIR}"/${PV}-fix-syntax.patch
+ python_convert_shebangs -r $(python_get_version) .
+}
+
+src_install() {
+ rm -rf ${P}/binaries ${PN}core-${PV}/Test || die
+
+ insinto /usr/share/ccp4/XIAROOT/
+ doins -r * || die
+
+ # Set programs executable
+# fperms cannot handle wildcards
+ chmod 755 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/* || die
+ chmod 644 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/*.py || die
+
+ cat >> "${T}"/23XIA <<- EOF
+ XIA2_HOME="${EPREFIX}/usr/share/ccp4/XIAROOT"
+ XIA2CORE_ROOT="${EPREFIX}/usr/share/ccp4/XIAROOT/xia2core-${PV}"
+ XIA2_ROOT="${EPREFIX}/usr/share/ccp4/XIAROOT/xia2-${PV}"
+ PATH="${EPREFIX}/usr/share/ccp4/XIAROOT/xia2-${PV}/Applications"
+ EOF
+
+ doenvd "${T}"/23XIA
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/ccp4/XIAROOT
+ echo ""
+ elog "In order to use the package, you need to"
+ elog "\t source ${EPREFIX}/etc/profile"
+ echo ""
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/ccp4/XIAROOT
+}
diff --git a/sci-chemistry/xia2/xia2-0.3.3.3.ebuild b/sci-chemistry/xia2/xia2-0.3.3.3.ebuild
new file mode 100644
index 000000000000..60778aa75fb9
--- /dev/null
+++ b/sci-chemistry/xia2/xia2-0.3.3.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="An automated data reduction system for crystallography"
+HOMEPAGE="http://www.ccp4.ac.uk/xia/"
+SRC_URI="http://www.ccp4.ac.uk/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=sci-chemistry/ccp4-apps-6.1.2
+ sci-chemistry/mosflm
+ sci-chemistry/pointless
+ >=sci-libs/ccp4-libs-6.1.2
+ sci-libs/cctbx"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ find . -name '*.bat' -delete || die
+
+ epatch "${FILESDIR}"/${PV}-fix-syntax.patch
+ python_convert_shebangs -r $(python_get_version) .
+}
+
+src_install() {
+ rm -rf ${P}/binaries ${PN}core-${PV}/Test || die
+
+ insinto /usr/share/ccp4/XIAROOT/
+ doins -r * || die
+
+ # Set programs executable
+# fperms cannot handle wildcards
+ chmod 755 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/* || die
+ chmod 644 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/*.py || die
+
+ cat >> "${T}"/23XIA <<- EOF
+ XIA2_HOME="${EPREFIX}/usr/share/ccp4/XIAROOT"
+ XIA2CORE_ROOT="${EPREFIX}/usr/share/ccp4/XIAROOT/xia2core-${PV}"
+ XIA2_ROOT="${EPREFIX}/usr/share/ccp4/XIAROOT/xia2-${PV}"
+ PATH="${EPREFIX}/usr/share/ccp4/XIAROOT/xia2-${PV}/Applications"
+ EOF
+
+ doenvd "${T}"/23XIA
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/ccp4/XIAROOT
+ echo ""
+ elog "In order to use the package, you need to"
+ elog "\t source ${EPREFIX}/etc/profile"
+ echo ""
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/ccp4/XIAROOT
+}
diff --git a/sci-chemistry/xia2/xia2-0.3.4.0.ebuild b/sci-chemistry/xia2/xia2-0.3.4.0.ebuild
new file mode 100644
index 000000000000..1d27abd355dc
--- /dev/null
+++ b/sci-chemistry/xia2/xia2-0.3.4.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="An automated data reduction system for crystallography"
+HOMEPAGE="http://www.ccp4.ac.uk/xia/"
+SRC_URI="http://www.ccp4.ac.uk/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=sci-chemistry/ccp4-apps-6.1.2
+ sci-chemistry/mosflm
+ sci-chemistry/pointless
+ >=sci-libs/ccp4-libs-6.1.2
+ sci-libs/cctbx"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ find . -name '*.bat' -delete || die
+
+ epatch "${FILESDIR}"/${PV}-fix-syntax.patch
+ python_convert_shebangs -r $(python_get_version) .
+}
+
+src_install() {
+ rm -rf ${P}/binaries ${PN}core-${PV}/Test || die
+
+ insinto /usr/share/ccp4/XIAROOT/
+ doins -r * || die
+
+ # Set programs executable
+# fperms cannot handle wildcards
+ chmod 755 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/* || die
+ chmod 644 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/*.py || die
+
+ cat >> "${T}"/23XIA <<- EOF
+ XIA2_HOME="${EPREFIX}/usr/share/ccp4/XIAROOT"
+ XIA2CORE_ROOT="${EPREFIX}/usr/share/ccp4/XIAROOT/xia2core-${PV}"
+ XIA2_ROOT="${EPREFIX}/usr/share/ccp4/XIAROOT/xia2-${PV}"
+ PATH="${EPREFIX}/usr/share/ccp4/XIAROOT/xia2-${PV}/Applications"
+ EOF
+
+ doenvd "${T}"/23XIA
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/ccp4/XIAROOT
+ echo ""
+ elog "In order to use the package, you need to"
+ elog "\t source ${EPREFIX}/etc/profile"
+ echo ""
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/ccp4/XIAROOT
+}