summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-19 12:40:11 +0000
committerSam James <sam@gentoo.org>2021-02-19 12:45:58 +0000
commit449c7b60dd05216a0d49b58256327b022497dd64 (patch)
tree1080002e40088f8d33314bbde3fa5e17a49ff4b2 /sci-chemistry
parentsci-libs/netcdf-fortran: workaround gcc 10 (fortran) failure (diff)
downloadgentoo-449c7b60dd05216a0d49b58256327b022497dd64.tar.gz
gentoo-449c7b60dd05216a0d49b58256327b022497dd64.tar.bz2
gentoo-449c7b60dd05216a0d49b58256327b022497dd64.zip
sci-chemistry/molden: workaround gcc 10 (fortran) failure
Closes: https://bugs.gentoo.org/724556 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/molden/molden-5.5.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sci-chemistry/molden/molden-5.5.ebuild b/sci-chemistry/molden/molden-5.5.ebuild
index 425238389f6e..2587fffdd9be 100644
--- a/sci-chemistry/molden/molden-5.5.ebuild
+++ b/sci-chemistry/molden/molden-5.5.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit desktop fortran-2 flag-o-matic toolchain-funcs
MY_P="${PN}${PV}"
@@ -51,6 +52,10 @@ src_compile() {
# Use -mieee on alpha, according to the Makefile
use alpha && append-flags -mieee
+ # GCC 10 workaround
+ # bug #724556
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
args=(
CC="$(tc-getCC) ${CFLAGS}"
FC="$(tc-getFC)"