summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-09-02 13:59:21 +0200
committerPacho Ramos <pacho@gentoo.org>2021-09-02 14:00:49 +0200
commit4e4e045da2570733e3a7cf50ed1712945d44dc2f (patch)
treef8aaf92e813a75be4ed184c93baba6a8165bf25f /sci-chemistry
parentsci-chemistry/dssp: Needs boost with zlib and bzip2 support (diff)
downloadgentoo-4e4e045da2570733e3a7cf50ed1712945d44dc2f.tar.gz
gentoo-4e4e045da2570733e3a7cf50ed1712945d44dc2f.tar.bz2
gentoo-4e4e045da2570733e3a7cf50ed1712945d44dc2f.zip
sci-chemistry/dssp: Bump to 3.0.11
It is the latest version that seems to work with gmx do_dssp from my tests, also the one packaged in Fedora currently Closes: https://bugs.gentoo.org/802417 Closes: https://bugs.gentoo.org/808669 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/dssp/Manifest1
-rw-r--r--sci-chemistry/dssp/dssp-3.0.11.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sci-chemistry/dssp/Manifest b/sci-chemistry/dssp/Manifest
index 170fb6728d5e..95f2e93d4a47 100644
--- a/sci-chemistry/dssp/Manifest
+++ b/sci-chemistry/dssp/Manifest
@@ -1,2 +1,3 @@
DIST dssp-2.2.1.tgz 47141 BLAKE2B 34d8b2db8797a8c23763766c0214337f03584c4be52c1bc820a0df0db6a5f78ac0229aafdd47a60b8fd6f4832abf0399663c53f9e898c75f08ecbe22b141c8da SHA512 4a273714d6b3230daea166caa7f4117d5ccb225bea0cf1bc2eb61539b6cc8e227d0ba19047d61f0ad0d1d6bc2efdec9c193bd44341e15ef0950acb4a22498811
+DIST dssp-3.0.11.tar.gz 168085 BLAKE2B e1c42fd22cfb2287f10b5deae48b56a4583d4a67737a3485dcbd160d1597a15c2d5105c3794c875d8001abede1c014efb4f7f5b7c250f867bdf9ed95a0860217 SHA512 a0cfe44e517ff1f909ef2928b62ae2c639c6bddfd8a0fb538883f647fd2771e00da68e0fd2521aa02ba3c6d1b0c9b784b7fe142392af3a3abf6ea89f1546bd9d
DIST dssp-4.0.1_p20210831.tar.gz 121793 BLAKE2B 1e028b086b418772a93db350f8084d1786996ff6ea935d236b1431d8f4a07c0b33ebf374a4c4d5d4d243952f3f56e29a548ce09763863a1e0c529755fba6c211 SHA512 62f1ac781dd3d6f3436e6c155ae1a470d0baf6a6d9f6d6729034a7a5ef41550f76d0473c688d235279336306c9f3598377c056cddd6d00a89a826fbb04c1bfb3
diff --git a/sci-chemistry/dssp/dssp-3.0.11.ebuild b/sci-chemistry/dssp/dssp-3.0.11.ebuild
new file mode 100644
index 000000000000..b0771e31047d
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-3.0.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools
+
+MY_PN="hssp"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="https://swift.cmbi.umcn.nl/gv/dssp/ https://github.com/cmbi/hssp"
+SRC_URI="https://github.com/cmbi/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-lang/perl:=
+ dev-libs/boost:=[bzip2,zlib,threads(+)]
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Fix version
+ sed -i -e "s/3.0.10/${PV}/" configure.ac || die
+
+ sed -i -e '/-Werror/d' Makefile.am || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ dosym mkdssp /usr/bin/dssp
+ doenvd "${FILESDIR}"/30-${PN}
+}