summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-05-02 20:33:23 +0200
committerPacho Ramos <pacho@gentoo.org>2023-05-02 20:42:46 +0200
commit618bc6c662f2658d4e245c75143a2d3189015f91 (patch)
tree4b9c8e1b55752835e6f853ef531442226aca7c4b /sci-chemistry
parentsci-chemistry/pymol: enable py3.11 (diff)
downloadgentoo-618bc6c662f2658d4e245c75143a2d3189015f91.tar.gz
gentoo-618bc6c662f2658d4e245c75143a2d3189015f91.tar.bz2
gentoo-618bc6c662f2658d4e245c75143a2d3189015f91.zip
sci-chemistry/MDAnalysis: add 2.4.3
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/MDAnalysis/MDAnalysis-2.4.3.ebuild39
-rw-r--r--sci-chemistry/MDAnalysis/Manifest1
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-chemistry/MDAnalysis/MDAnalysis-2.4.3.ebuild b/sci-chemistry/MDAnalysis/MDAnalysis-2.4.3.ebuild
new file mode 100644
index 000000000000..5e7d91b36bf3
--- /dev/null
+++ b/sci-chemistry/MDAnalysis/MDAnalysis-2.4.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A python library to analyze and manipulate molecular dynamics trajectories"
+HOMEPAGE="https://www.mdanalysis.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+# TODO: fix this
+# ImportError: MDAnalysis not installed properly. This can happen if your C extensions have not been built.
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/numpy-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.0.0[${PYTHON_USEDEP}]
+ >=sci-biology/biopython-1.71[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.0[${PYTHON_USEDEP}]
+ >=dev-python/GridDataFormats-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/joblib-0.12[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-1.5.1[${PYTHON_USEDEP}]
+ >=dev-python/mmtf-python-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.43.0[${PYTHON_USEDEP}]
+ >=dev-python/gsd-1.9.3[${PYTHON_USEDEP}]
+ dev-python/threadpoolctl[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
diff --git a/sci-chemistry/MDAnalysis/Manifest b/sci-chemistry/MDAnalysis/Manifest
index 81a4e8053d86..ce48cb3b96d6 100644
--- a/sci-chemistry/MDAnalysis/Manifest
+++ b/sci-chemistry/MDAnalysis/Manifest
@@ -1 +1,2 @@
DIST MDAnalysis-2.4.1.tar.gz 3746899 BLAKE2B af63f74a31dcde8a68cbffe5158f2f955d5eda1345bcff6a19e8df3284101b1e85006de3326d29d4fe1867dc6b0c5f55467b9e3242704f97440c6a43b52f47b8 SHA512 796dad98c26bd36f30db166bea5ff782aa5e3ac5cddb1675b628fb753a4f645fb27e06d3986047e2ba21a22cd91f96d0ba8e529256ed960a2b7cf95204076927
+DIST MDAnalysis-2.4.3.tar.gz 3747565 BLAKE2B 733be78aa3e57e8bbb9c291606a86d9100cb904cc587fa3e44c4205596b4da7eb5c2247388655dcd145b45ca6ecb47a3f95d7d659d029232d1febd2ebc99ab51 SHA512 0870bc392ef8b8fbae68cf60d1df2f5d413f4d1235ca795421061fd32a8fe97867d5bd610288237a59d1075f31cc43d281ab2f1e7e8bb0767dac7d278b8453d8